aboutsummaryrefslogtreecommitdiff
path: root/math/pure-mpfr
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-08-07 14:42:45 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-08-07 14:42:45 +0000
commit1035cb6ba782a13ba0e51ebe7d7053cd8317cf1b (patch)
treef39d7af813b169bd88d29af901b106b34a559724 /math/pure-mpfr
parent12f39f759de99a2ace4c578ee76cbd6dec731f9c (diff)
1: Stagify.
2: Strip binary.
Notes
Notes: svn path=/head/; revision=364278
Diffstat (limited to 'math/pure-mpfr')
-rw-r--r--math/pure-mpfr/Makefile28
1 files changed, 8 insertions, 20 deletions
diff --git a/math/pure-mpfr/Makefile b/math/pure-mpfr/Makefile
index a90e1bbac416..379b8716e4d0 100644
--- a/math/pure-mpfr/Makefile
+++ b/math/pure-mpfr/Makefile
@@ -14,32 +14,20 @@ COMMENT= Multiprecision floats for Pure
LICENSE= GPLv3 LGPL3
LICENSE_COMB= dual
-MAKE_ARGS+= libdir="${PREFIX}/lib"
-
USES= pkgconfig pure
-
-PLIST_FILES= lib/pure/mpfr.pure \
- lib/pure/mpfr.so
-
-NO_STAGE= yes
-
+MAKE_ARGS+= libdir="${PREFIX}/lib"
PORTDOCS= README
-
PORTEXAMPLES= *
-
OPTIONS_DEFINE= DOCS EXAMPLES
-.include <bsd.port.options.mk>
+PLIST_FILES= lib/pure/mpfr.pure \
+ lib/pure/mpfr.so
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
-
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- @(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
-.endif
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/pure/mpfr.so
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>