aboutsummaryrefslogtreecommitdiff
path: root/math/py-Diofant
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-01-31 05:22:03 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-01-31 05:22:03 +0000
commit124699d03c147a8f2fd8caf73713a47c6ea6210b (patch)
tree03c85076861e8118b3622cc479d3c829ea31246d /math/py-Diofant
parent5376b7f979a9563a55fc8a20c6d53649ff791dad (diff)
downloadports-124699d03c147a8f2fd8caf73713a47c6ea6210b.tar.gz
ports-124699d03c147a8f2fd8caf73713a47c6ea6210b.zip
Notes
Diffstat (limited to 'math/py-Diofant')
-rw-r--r--math/py-Diofant/Makefile8
-rw-r--r--math/py-Diofant/distinfo6
-rw-r--r--math/py-Diofant/files/patch-setup.cfg10
-rw-r--r--math/py-Diofant/files/patch-setup.py11
-rw-r--r--math/py-Diofant/pkg-descr2
5 files changed, 18 insertions, 19 deletions
diff --git a/math/py-Diofant/Makefile b/math/py-Diofant/Makefile
index d23a6bb3643c..0233b86687bd 100644
--- a/math/py-Diofant/Makefile
+++ b/math/py-Diofant/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= Diofant
-DISTVERSION= 0.9.0
-PORTREVISION= 1
+DISTVERSION= 0.10.0
CATEGORIES= math python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,10 +10,11 @@ MAINTAINER= yuri@FreeBSD.org
COMMENT= Python library for symbolic mathematics
LICENSE= BSD3CLAUSE
-LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.rst
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}isort>0:devel/py-isort@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest-runner>0:devel/py-pytest-runner@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}pytest-runner>0:devel/py-pytest-runner@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR}
# RUN_DEPENDS includes extra_reqs for convenience
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cachetools>0:devel/py-cachetools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}gmpy2>=2.0.8:math/py-gmpy2@${PY_FLAVOR} \
diff --git a/math/py-Diofant/distinfo b/math/py-Diofant/distinfo
index 4d41077c1b84..0e333d25670e 100644
--- a/math/py-Diofant/distinfo
+++ b/math/py-Diofant/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1522358534
-SHA256 (Diofant-0.9.0.tar.gz) = 2ad017257c4ae3ccb2bc065863bf411602a67fc82af4d417dfb6e21c85e775a8
-SIZE (Diofant-0.9.0.tar.gz) = 2309393
+TIMESTAMP = 1548911511
+SHA256 (Diofant-0.10.0.tar.gz) = 1ced513e42458042c02062eafca97ec1e5b847bfb78260b2cf1d33f16b054f62
+SIZE (Diofant-0.10.0.tar.gz) = 2473549
diff --git a/math/py-Diofant/files/patch-setup.cfg b/math/py-Diofant/files/patch-setup.cfg
new file mode 100644
index 000000000000..1ff3e3933d02
--- /dev/null
+++ b/math/py-Diofant/files/patch-setup.cfg
@@ -0,0 +1,10 @@
+--- setup.cfg.orig 2019-01-31 05:16:32 UTC
++++ setup.cfg
+@@ -33,7 +33,6 @@ packages = find:
+ python_requires = >=3.5
+ setup_requires = setuptools>=36.7.0
+ setuptools_scm
+- pip>=9.0.1
+ pytest-runner
+ isort
+ install_requires = mpmath>=0.19
diff --git a/math/py-Diofant/files/patch-setup.py b/math/py-Diofant/files/patch-setup.py
deleted file mode 100644
index 014af031d847..000000000000
--- a/math/py-Diofant/files/patch-setup.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- setup.py.orig 2018-03-29 22:06:10 UTC
-+++ setup.py
-@@ -20,7 +20,7 @@ with open('diofant/__init__.py') as f:
- if m:
- __version__ = m.group(1)
-
--setup_reqs = ['setuptools>=5.5.1', 'pip>=6.0', 'pytest-runner', 'isort']
-+setup_reqs = ['setuptools>=5.5.1', 'pytest-runner', 'isort']
- extra_reqs = {'exports': ['numpy>=1.12.1', 'scipy', 'Theano>=0.9.0'],
- 'gmpy': ['gmpy2>=2.0.8'],
- 'plot': ['pyparsing!=2.1.2', 'matplotlib!=2.1.1'],
diff --git a/math/py-Diofant/pkg-descr b/math/py-Diofant/pkg-descr
index 1ba305ec7afd..956a4def95e1 100644
--- a/math/py-Diofant/pkg-descr
+++ b/math/py-Diofant/pkg-descr
@@ -1,6 +1,6 @@
Diofant is a Python library for symbolic mathematics.
It is able to symbolically differentiate, integrate functions, solve
-algebraoc equations and a lot more.
+algebraic equations and a lot more.
It can present results in a very cool pseudographics in your terminal.