aboutsummaryrefslogtreecommitdiff
path: root/math/py-apgl/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-10-28 13:20:08 +0000
committerWen Heping <wen@FreeBSD.org>2010-10-28 13:20:08 +0000
commit5745b0e03d70b7a4d5c3aa2b87abc8b0805d187e (patch)
tree50c96984e573c2bcc1d3762a60047354dec2ecb0 /math/py-apgl/Makefile
parent8cc6e98d25c121140909e3b56c1be81b600134b3 (diff)
downloadports-5745b0e03d70b7a4d5c3aa2b87abc8b0805d187e.tar.gz
ports-5745b0e03d70b7a4d5c3aa2b87abc8b0805d187e.zip
Notes
Diffstat (limited to 'math/py-apgl/Makefile')
-rw-r--r--math/py-apgl/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/math/py-apgl/Makefile b/math/py-apgl/Makefile
new file mode 100644
index 000000000000..a0bc679f3bc6
--- /dev/null
+++ b/math/py-apgl/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: py-apgl
+# Date created: Oct 28, 2010
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= apgl
+PORTVERSION= 0.5.9.1
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= A fast python graph library with some machine learning features
+
+BUILD_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>0.7.0:${PORTSDIR}/science/py-scipy
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+
+.include <bsd.port.mk>