aboutsummaryrefslogtreecommitdiff
path: root/math/py-arviz
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-12-01 17:52:12 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-12-01 17:52:12 +0000
commitea9191355fa721062fcc514b837bddd99cbda77f (patch)
tree22cde106e7457c3db0ffdad399596c8c8eadb80a /math/py-arviz
parent07ec3d2815d69808ca4d645a8a6c90d40f143f22 (diff)
downloadports-ea9191355fa721062fcc514b837bddd99cbda77f.tar.gz
ports-ea9191355fa721062fcc514b837bddd99cbda77f.zip
Notes
Diffstat (limited to 'math/py-arviz')
-rw-r--r--math/py-arviz/Makefile27
-rw-r--r--math/py-arviz/distinfo3
-rw-r--r--math/py-arviz/pkg-descr10
3 files changed, 40 insertions, 0 deletions
diff --git a/math/py-arviz/Makefile b/math/py-arviz/Makefile
new file mode 100644
index 000000000000..9128910867e7
--- /dev/null
+++ b/math/py-arviz/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= arviz
+DISTVERSION= 0.5.1
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Package for exploratory analysis of Bayesian models
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}netCDF4>0:science/py-netCDF4@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>=0.23:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.19:science/py-scipy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}xarray>=0.11:devel/py-xarray@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/math/py-arviz/distinfo b/math/py-arviz/distinfo
new file mode 100644
index 000000000000..769a60d3d4dc
--- /dev/null
+++ b/math/py-arviz/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1575220065
+SHA256 (arviz-0.5.1.tar.gz) = b0a796cccda61dbd26aad36d0258bb46bb3c412e41176d3b9fbbb49c2a69be12
+SIZE (arviz-0.5.1.tar.gz) = 1321172
diff --git a/math/py-arviz/pkg-descr b/math/py-arviz/pkg-descr
new file mode 100644
index 000000000000..824e9c8dc260
--- /dev/null
+++ b/math/py-arviz/pkg-descr
@@ -0,0 +1,10 @@
+ArviZ is a Python package for exploratory analysis of Bayesian models. Includes
+functions for posterior analysis, sample diagnostics, model checking, and
+comparison.
+
+The goal is to provide backend-agnostic tools for diagnostics and visualizations
+of Bayesian inference in Python, by first converting inference data into xarray
+objects. See here for more on xarray and ArviZ usage and here for more on
+InferenceData structure and specification.
+
+WWW: https://arviz-devs.github.io/arviz/