aboutsummaryrefslogtreecommitdiff
path: root/math/py-basemap-data
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2006-12-24 09:31:31 +0000
committerNicola Vitale <nivit@FreeBSD.org>2006-12-24 09:31:31 +0000
commit46fb0d3e7e8d11d9397f36bcec33ec1b374d2591 (patch)
treedea492891a9c0f03019cf12932e7be76171f01a3 /math/py-basemap-data
parent1ed76491817619a6f39224093ac5b51f614cc9f6 (diff)
downloadports-46fb0d3e7e8d11d9397f36bcec33ec1b374d2591.tar.gz
ports-46fb0d3e7e8d11d9397f36bcec33ec1b374d2591.zip
Notes
Diffstat (limited to 'math/py-basemap-data')
-rw-r--r--math/py-basemap-data/Makefile44
-rw-r--r--math/py-basemap-data/distinfo3
-rw-r--r--math/py-basemap-data/pkg-descr3
3 files changed, 50 insertions, 0 deletions
diff --git a/math/py-basemap-data/Makefile b/math/py-basemap-data/Makefile
new file mode 100644
index 000000000000..15e9bb9dcd2b
--- /dev/null
+++ b/math/py-basemap-data/Makefile
@@ -0,0 +1,44 @@
+# ex:ts=8
+# Ports collection makefile for: py-basemap-data
+# Date created: April 21, 2006
+# Whom: mainland@apeiron.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= basemap-data
+PORTVERSION= 0.9
+CATEGORIES= math python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= matplotlib
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= mainland@apeiron.net
+COMMENT= Map data for py-basemap
+
+USE_PYTHON= 2.2+
+USE_PYDISTUTILS= yes
+
+DATADIR= ${PREFIX}/share/py-${PORTNAME}
+
+MAKE_ENV= BASEMAP_DATA_PATH=${DATADIR}
+
+PLISTDIR= ${DATADIR}/*_[hi].txt
+
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} >= 250
+PLISTDIR+= ${PYTHON_SITELIBDIR}/basemap_data-0.9-py2.5.egg-info
+.endif
+
+post-install:
+.for dir in ${PLISTDIR}
+ @${FIND} ${dir} ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${dir} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+.endfor
+ @${ECHO} "@dirrm ${DATADIR:S,${PREFIX}/,,}" >> ${TMPPLIST}
+
+.include <bsd.port.post.mk>
diff --git a/math/py-basemap-data/distinfo b/math/py-basemap-data/distinfo
new file mode 100644
index 000000000000..ec7bc579691c
--- /dev/null
+++ b/math/py-basemap-data/distinfo
@@ -0,0 +1,3 @@
+MD5 (basemap-data-0.9.tar.gz) = 5c4baf8f3de54193d64ab31c363a0e89
+SHA256 (basemap-data-0.9.tar.gz) = 6f64baf508ac48ff6776e394e17dbca3ed826c9cad30ad6cfd6bfa26ae582d77
+SIZE (basemap-data-0.9.tar.gz) = 24995626
diff --git a/math/py-basemap-data/pkg-descr b/math/py-basemap-data/pkg-descr
new file mode 100644
index 000000000000..6a288a9cc321
--- /dev/null
+++ b/math/py-basemap-data/pkg-descr
@@ -0,0 +1,3 @@
+Map data for the py-basemap port.
+
+WWW: http://matplotlib.sourceforge.net/matplotlib.toolkits.basemap.basemap.html