aboutsummaryrefslogtreecommitdiff
path: root/math/py-cvxopt
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-09-21 17:01:49 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-09-21 17:47:02 +0000
commit0533133ad087257f0a22cbba6e4bc8b18a933795 (patch)
treefd0e7f85b4e565f26a6e07e38b46a417098e606d /math/py-cvxopt
parentf307a5b7fa6d3b4703a0aa7c854d165ea59ee9a9 (diff)
downloadports-0533133ad087257f0a22cbba6e4bc8b18a933795.tar.gz
ports-0533133ad087257f0a22cbba6e4bc8b18a933795.zip
Diffstat (limited to 'math/py-cvxopt')
-rw-r--r--math/py-cvxopt/Makefile13
-rw-r--r--math/py-cvxopt/distinfo6
2 files changed, 13 insertions, 6 deletions
diff --git a/math/py-cvxopt/Makefile b/math/py-cvxopt/Makefile
index 0a56859d1cc3..806d1a55ae43 100644
--- a/math/py-cvxopt/Makefile
+++ b/math/py-cvxopt/Makefile
@@ -1,6 +1,5 @@
PORTNAME= cvxopt
-DISTVERSION= 1.2.6
-PORTREVISION= 2
+DISTVERSION= 1.2.7
CATEGORIES= math python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -10,9 +9,14 @@ COMMENT= Python software for convex optimization
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libblas.so:math/blas \
+LIB_DEPENDS= libamd.so:math/suitesparse-amd \
+ libblas.so:math/blas \
+ libcholmod.so:math/suitesparse-cholmod \
+ libcolamd.so:math/suitesparse-colamd \
liblapack.so:math/lapack \
+ libsuitesparseconfig.so:math/suitesparse-config \
libumfpack.so:math/suitesparse-umfpack
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
USES= python:3.6+ localbase:ldflags
USE_GITHUB= yes
@@ -42,4 +46,7 @@ DSDP_LIB_DEPENDS= libdsdp.so:math/dsdp
post-install:
@${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/cvxopt/*.so
+do-test: install
+ @cd ${WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest
+
.include <bsd.port.mk>
diff --git a/math/py-cvxopt/distinfo b/math/py-cvxopt/distinfo
index 36a5b9822835..0977dc5b6408 100644
--- a/math/py-cvxopt/distinfo
+++ b/math/py-cvxopt/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1613681013
-SHA256 (cvxopt-cvxopt-1.2.6_GH0.tar.gz) = 8d277eec27b8e6ca5eefde6232a474bfc25aa195653229217dfbd37918fc52d5
-SIZE (cvxopt-cvxopt-1.2.6_GH0.tar.gz) = 4114036
+TIMESTAMP = 1632242651
+SHA256 (cvxopt-cvxopt-1.2.7_GH0.tar.gz) = 26557c00b07aed6e6d7e7110443472766f3664faa43733c8cc520e4d9b856594
+SIZE (cvxopt-cvxopt-1.2.7_GH0.tar.gz) = 4115486