aboutsummaryrefslogtreecommitdiff
path: root/math/py-ducc0
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-04-26 07:07:05 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-04-26 07:07:37 +0000
commit2c8e6e08548d4b445a125411e5ab679874582562 (patch)
tree30bd849c3452a8b359a8c1b4f7ef7b35b5991db7 /math/py-ducc0
parent5e865ee1ec3e0e2c9961bd6ba7164c4cd094763d (diff)
downloadports-2c8e6e08548d4b445a125411e5ab679874582562.tar.gz
ports-2c8e6e08548d4b445a125411e5ab679874582562.zip
Diffstat (limited to 'math/py-ducc0')
-rw-r--r--math/py-ducc0/Makefile21
-rw-r--r--math/py-ducc0/distinfo3
-rw-r--r--math/py-ducc0/pkg-descr6
3 files changed, 30 insertions, 0 deletions
diff --git a/math/py-ducc0/Makefile b/math/py-ducc0/Makefile
new file mode 100644
index 000000000000..f974440f7a76
--- /dev/null
+++ b/math/py-ducc0/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= ducc0
+PORTVERSION= 0.9.0
+CATEGORIES= math
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Distinctly Useful Code Collection (DUCC)
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pybind11>0:devel/py-pybind11@${PY_FLAVOR}
+
+USES= compiler:c++17-lang python:3.6+
+
+USE_PYTHON= distutils autoplist
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/ducc0*.so
+.include <bsd.port.mk>
diff --git a/math/py-ducc0/distinfo b/math/py-ducc0/distinfo
new file mode 100644
index 000000000000..3ac5b1a02947
--- /dev/null
+++ b/math/py-ducc0/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1619411151
+SHA256 (ducc0-0.9.0.tar.gz) = 53ca2691fef8f1efba239e7bb77308163901633bd9fb788820fab33440478707
+SIZE (ducc0-0.9.0.tar.gz) = 181020
diff --git a/math/py-ducc0/pkg-descr b/math/py-ducc0/pkg-descr
new file mode 100644
index 000000000000..996b8ad23fe2
--- /dev/null
+++ b/math/py-ducc0/pkg-descr
@@ -0,0 +1,6 @@
+ducc0 is a collection of basic programming tools for numerical computation,
+including Fast Fourier Transforms, Spherical Harmonic Transforms, non-equispaced
+Fourier transforms, as well as some concrete applications like 4pi convolution
+on the sphere and gridding/degridding of radio interferometry data.
+
+WWW: https://gitlab.mpcdf.mpg.de/mtr/ducc