aboutsummaryrefslogtreecommitdiff
path: root/math/py-fastcluster
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-12-18 11:12:40 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-12-18 11:12:40 +0000
commit6afaa267f3ef73e3d07e034bac5761248cb3ecc1 (patch)
tree8a713ab4c475c2ac5bc846e2fc6fff1dfa7134a3 /math/py-fastcluster
parent8b022e8e233f466e0a5cd96008ad6def99c8c5ca (diff)
Notes
Diffstat (limited to 'math/py-fastcluster')
-rw-r--r--math/py-fastcluster/Makefile32
-rw-r--r--math/py-fastcluster/distinfo2
-rw-r--r--math/py-fastcluster/pkg-descr14
3 files changed, 48 insertions, 0 deletions
diff --git a/math/py-fastcluster/Makefile b/math/py-fastcluster/Makefile
new file mode 100644
index 000000000000..8cd44faaeea6
--- /dev/null
+++ b/math/py-fastcluster/Makefile
@@ -0,0 +1,32 @@
+# Created by: Johannes Meixner <xmj@chaot.net>
+# $FreeBSD$
+
+PORTNAME= fastcluster
+PORTVERSION= 1.1.13
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= xmj@chaot.net
+COMMENT= Python functions for hierarchical clustering
+
+LICENSE= BSD2CLAUSE
+
+BUILD_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>0:${PORTSDIR}/science/py-scipy
+
+PORTDOCS= CITATION.txt \
+ INSTALL.txt \
+ NEWS.txt \
+ README.txt
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/math/py-fastcluster/distinfo b/math/py-fastcluster/distinfo
new file mode 100644
index 000000000000..44f0146aac7b
--- /dev/null
+++ b/math/py-fastcluster/distinfo
@@ -0,0 +1,2 @@
+SHA256 (fastcluster-1.1.13.tar.gz) = abdf99d327e6e6569dc2782eaca1d6ed2ced88ab6c6b43c8e9850dae66f9648c
+SIZE (fastcluster-1.1.13.tar.gz) = 148538
diff --git a/math/py-fastcluster/pkg-descr b/math/py-fastcluster/pkg-descr
new file mode 100644
index 000000000000..69815a4b6480
--- /dev/null
+++ b/math/py-fastcluster/pkg-descr
@@ -0,0 +1,14 @@
+Fastcluster provides Python functions for hierarchical clustering. It generates
+hierarchical clusters from distance matrices or from vector data.
+
+Part of this module is intended to replace the functions
+ linkage, single, complete, average, weighted, centroid, median, ward
+in the module scipy.cluster.hierarchy with the same functionality but much
+faster algorithms. Moreover, the function 'linkage_vector' provides
+memory-efficient clustering for vector data.
+
+The interface is very similar to MATLAB's Statistics Toolbox API to make code
+easier to port from MATLAB to Python/Numpy. The core implementation of this
+library is in C++ for efficiency.
+
+WWW: http://danifold.net/fastcluster.html