aboutsummaryrefslogtreecommitdiff
path: root/math/py-gato/Makefile
diff options
context:
space:
mode:
authorJohann Visagie <wjv@FreeBSD.org>2001-09-03 10:45:18 +0000
committerJohann Visagie <wjv@FreeBSD.org>2001-09-03 10:45:18 +0000
commit89bcea86393caf6987e10665199d3effcd482f33 (patch)
tree9d131d74f511d76562ad1b4707457deebb8575c4 /math/py-gato/Makefile
parent2f0c6d8518e24fb05724e1172d9c82a37960e9bd (diff)
Notes
Diffstat (limited to 'math/py-gato/Makefile')
-rw-r--r--math/py-gato/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/math/py-gato/Makefile b/math/py-gato/Makefile
new file mode 100644
index 000000000000..6872c8f65224
--- /dev/null
+++ b/math/py-gato/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: py-gato
+# Date created: 31 August 2001
+# Whom: Johann Visagie <wjv@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gato
+PORTVERSION= 0.96.g
+CATEGORIES= math python
+MASTER_SITES= http://www.zpr.uni-koeln.de/~gato/Download/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= Gato-${PORTVERSION:U:C|\.([^.]*)$|\1|}
+EXTRACT_SUFX= .tar
+
+MAINTAINER= wjv@FreeBSD.org
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
+
+USE_PYTHON= yes
+WRKSRC= ${WRKDIR}/Gato
+GATO_DIR= ${PREFIX}/lib/${PYTHON_VERSION}/site-packages/Gato
+EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}
+CPIO= cpio --quiet -pdum -R
+
+pre-build:
+ @ ${TOUCH} ${WRKSRC}/__init__.py
+
+do-build:
+ @ ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+ @ ${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+
+do-install:
+ @ ${MKDIR} ${GATO_DIR}
+ @ cd ${WRKSRC} && find *.py *.pyc *.pyo \
+ -name Gato.py\* -o -name Gred.py\* -o -print \
+ | ${CPIO} ${BINOWN}:${BINGRP} ${GATO_DIR}
+.for script in Gato Gred
+ @ ${INSTALL_SCRIPT} ${WRKSRC}/${script}.py ${PREFIX}/bin/${script}
+.endfor
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${EXAMPLESDIR}
+.for egfile in *.alg *.pro *.cat
+ @ ${INSTALL_DATA} ${WRKSRC}/${egfile} ${EXAMPLESDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>