aboutsummaryrefslogtreecommitdiff
path: root/math/py-gato
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-03-16 10:43:34 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-03-16 10:43:34 +0000
commitc4bebab08ab2e6989d6f546ad6c9db9feb9993db (patch)
treed27515ab761fb66a312a4327f69d77cbeb66e8e0 /math/py-gato
parent8d491af5829dfecd5c0dc3c3bc18d1075b3908e0 (diff)
downloadports-c4bebab08ab2e6989d6f546ad6c9db9feb9993db.tar.gz
ports-c4bebab08ab2e6989d6f546ad6c9db9feb9993db.zip
Notes
Diffstat (limited to 'math/py-gato')
-rw-r--r--math/py-gato/Makefile10
-rw-r--r--math/py-gato/distinfo6
-rw-r--r--math/py-gato/files/patch-Gato.py57
-rw-r--r--math/py-gato/files/patch-GatoFile.py8
-rw-r--r--math/py-gato/files/patch-GraphUtil.py76
-rw-r--r--math/py-gato/files/patch-Gred.py28
-rw-r--r--math/py-gato/files/patch-TextTreeWidget.py8
-rw-r--r--math/py-gato/pkg-descr4
-rw-r--r--math/py-gato/pkg-plist6
9 files changed, 87 insertions, 116 deletions
diff --git a/math/py-gato/Makefile b/math/py-gato/Makefile
index 32147c353b1e..bb420b27ce2c 100644
--- a/math/py-gato/Makefile
+++ b/math/py-gato/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= gato
-PORTVERSION= 0.98.J
+PORTVERSION= 0.98.Q
CATEGORIES= math python
-MASTER_SITES= http://www.zpr.uni-koeln.de/~gato/Download/
+MASTER_SITES= http://gato.sourceforge.net/Download/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= Gato-${PORTVERSION:U:C|\.([^.]*)$|\1|}
-EXTRACT_SUFX= .tar
MAINTAINER= ports@FreeBSD.org
COMMENT= A Python-based toolbox to visualise algorithms on graphs
@@ -22,7 +21,6 @@ USE_PYTHON= yes
WRKSRC= ${WRKDIR}/Gato
GATO_DIR= ${PREFIX}/lib/${PYTHON_VERSION}/site-packages/Gato
EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}
-CPIO= cpio --quiet -pdum -R
pre-build:
@ ${TOUCH} ${WRKSRC}/__init__.py
@@ -34,8 +32,8 @@ do-build:
do-install:
@ ${MKDIR} ${GATO_DIR}
@ cd ${WRKSRC} && ${FIND} *.py *.pyc *.pyo \
- -name Gato.py\* -o -name Gred.py\* -o -print \
- | ${CPIO} ${BINOWN}:${BINGRP} ${GATO_DIR}
+ -name Gato.py\* -o -print \
+ | ${CPIO} --verbose -pdum -R ${BINOWN}:${BINGRP} ${GATO_DIR}
.for script in Gato Gred
@ ${INSTALL_SCRIPT} ${WRKSRC}/${script}.py ${PREFIX}/bin/${script}
.endfor
diff --git a/math/py-gato/distinfo b/math/py-gato/distinfo
index 2b728f7dbc54..6786e429e66a 100644
--- a/math/py-gato/distinfo
+++ b/math/py-gato/distinfo
@@ -1,3 +1,3 @@
-MD5 (Gato-0.98J.tar) = c6235e2b90cd30365c79abc6bc18c91a
-SHA256 (Gato-0.98J.tar) = bbdc48375b28af81bc96c858af032e6a541e5d41057750523fc29354c27f9acc
-SIZE (Gato-0.98J.tar) = 653312
+MD5 (Gato-0.98Q.tar.gz) = c46a1e4b79632aad628caf452a0b3b69
+SHA256 (Gato-0.98Q.tar.gz) = 2c1749d312c45e50b81e3c4916de912f4309251c9502448a5a5f8856aae770a9
+SIZE (Gato-0.98Q.tar.gz) = 178578
diff --git a/math/py-gato/files/patch-Gato.py b/math/py-gato/files/patch-Gato.py
index be050b9feeab..0e26798a60ab 100644
--- a/math/py-gato/files/patch-Gato.py
+++ b/math/py-gato/files/patch-Gato.py
@@ -1,6 +1,19 @@
---- Gato.py.dist Thu Dec 18 00:34:01 2003
-+++ Gato.py Thu Dec 18 00:35:50 2003
-@@ -54,15 +54,15 @@
+--- Gato.py Fri Jan 20 15:15:55 2006
++++ Gato.py Wed Mar 8 15:23:21 2006
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python2.3
++#!/usr/bin/env python
+ ################################################################################
+ #
+ # This file is part of Gato (Graph Animation Toolbox)
+@@ -48,22 +48,22 @@
+ import tkFont
+ import copy
+
+-import Gred
++from Gato import Gred
+
+ from Tkinter import *
from tkFileDialog import askopenfilename, asksaveasfilename
from tkMessageBox import askokcancel, showerror, askyesno
from ScrolledText import ScrolledText
@@ -13,6 +26,7 @@
-from GatoDialogs import AboutBox, SplashScreen, HTMLViewer
-import GatoIcons
-import GatoSystemConfiguration
+-from AnimationHistory import AnimationHistory
+from Gato.GatoConfiguration import GatoConfiguration
+from Gato.Graph import Graph
+from Gato.GraphUtil import *
@@ -21,24 +35,25 @@
+from Gato.GatoGlobals import *
+from Gato.GatoDialogs import AboutBox, SplashScreen, HTMLViewer
+from Gato import GatoIcons
-+import Gato.GatoSystemConfiguration
++from Gato import GatoSystemConfiguration
++from Gato.AnimationHistory import AnimationHistory
# put someplace else
def WMExtrasGeometry(window):
-@@ -1397,11 +1397,11 @@
- self.algoGlobals['A'] = self.GUI.graphDisplay
- # XXX
- # explictely loading packages we want to make available to the algorithm
-- modules = ['DataStructures',
-- 'AnimatedDataStructures',
-- 'AnimatedAlgorithms',
-- 'GraphUtil',
-- 'GatoUtil']
-+ modules = ['Gato.DataStructures',
-+ 'Gato.AnimatedDataStructures',
-+ 'Gato.AnimatedAlgorithms',
-+ 'Gato.GraphUtil',
-+ 'Gato.GatoUtil']
-
- for m in modules:
- exec("from %s import *" % m, self.algoGlobals, self.algoGlobals)
+@@ -1419,11 +1419,11 @@
+ self.algoGlobals['A'] = self.GUI.graphDisplay
+ # XXX
+ # explictely loading packages we want to make available to the algorithm
+- modules = ['DataStructures',
+- 'AnimatedDataStructures',
+- 'AnimatedAlgorithms',
+- 'GraphUtil',
+- 'GatoUtil']
++ modules = ['Gato.DataStructures',
++ 'Gato.AnimatedDataStructures',
++ 'Gato.AnimatedAlgorithms',
++ 'Gato.GraphUtil',
++ 'Gato.GatoUtil']
+
+ for m in modules:
+ exec("from %s import *" % m, self.algoGlobals, self.algoGlobals)
diff --git a/math/py-gato/files/patch-GatoFile.py b/math/py-gato/files/patch-GatoFile.py
new file mode 100644
index 000000000000..f75bc3793f78
--- /dev/null
+++ b/math/py-gato/files/patch-GatoFile.py
@@ -0,0 +1,8 @@
+--- GatoFile.py Wed Mar 8 10:47:35 2006
++++ GatoFile.py Wed Mar 8 10:47:47 2006
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python2.3
++#!/usr/bin/env python
+ ################################################################################
+ #
+ # This file is part of Gato (Graph Animation Toolbox)
diff --git a/math/py-gato/files/patch-GraphUtil.py b/math/py-gato/files/patch-GraphUtil.py
deleted file mode 100644
index fe744b91e881..000000000000
--- a/math/py-gato/files/patch-GraphUtil.py
+++ /dev/null
@@ -1,76 +0,0 @@
---- GraphUtil.py.orig Wed May 16 13:16:58 2001
-+++ GraphUtil.py Mon Sep 3 12:21:49 2001
-@@ -223,13 +223,13 @@
- break
-
- if lineNr == 2: # Read directed and euclidian
-- splitLine = split(line[:-1],';')
-- G.directed = eval(split(splitLine[0],':')[1])
-- G.simple = eval(split(splitLine[1],':')[1])
-- G.euclidian = eval(split(splitLine[2],':')[1])
-- intWeights = eval(split(splitLine[3],':')[1])
-- nrOfEdgeWeights = eval(split(splitLine[4],':')[1])
-- nrOfVertexWeights = eval(split(splitLine[5],':')[1])
-+ splitLine = split(';',line[:-1])
-+ G.directed = eval(split(':',splitLine[0])[1])
-+ G.simple = eval(split(':',splitLine[1])[1])
-+ G.euclidian = eval(split(':',splitLine[2])[1])
-+ intWeights = eval(split(':',splitLine[3])[1])
-+ nrOfEdgeWeights = eval(split(':',splitLine[4])[1])
-+ nrOfVertexWeights = eval(split(':',splitLine[5])[1])
- for i in xrange(nrOfEdgeWeights):
- G.edgeWeights[i] = EdgeWeight(G)
- for i in xrange(nrOfVertexWeights):
-@@ -237,33 +237,33 @@
-
-
- if lineNr == 5: # Read nr of vertices
-- nrOfVertices = eval(split(line[:-2],':')[1]) # Strip of "\n" and ;
-+ nrOfVertices = eval(split(':',line[:-2])[1]) # Strip of "\n" and ;
- firstVertexLineNr = lineNr + 1
- lastVertexLineNr = lineNr + nrOfVertices
-
- if firstVertexLineNr <= lineNr and lineNr <= lastVertexLineNr:
-- splitLine = split(line[:-1],';')
-+ splitLine = split(';',line[:-1])
- v = G.AddVertex()
-- x = eval(split(splitLine[1],':')[1])
-- y = eval(split(splitLine[2],':')[1])
-+ x = eval(split(':',splitLine[1])[1])
-+ y = eval(split(':',splitLine[2])[1])
- for i in xrange(nrOfVertexWeights):
-- w = eval(split(splitLine[3+i],':')[1])
-+ w = eval(split(':',splitLine[3+i])[1])
- G.vertexWeights[i][v] = w
-
- E[v] = Point2D(x,y)
-
- if lineNr == lastVertexLineNr + 1: # Read Nr of edges
-- nrOfEdges = eval(split(line[:-2],':')[1]) # Strip of "\n" and ;
-+ nrOfEdges = eval(split(':',line[:-2])[1]) # Strip of "\n" and ;
- firstEdgeLineNr = lineNr + 1
- lastEdgeLineNr = lineNr + nrOfEdges
-
- if firstEdgeLineNr <= lineNr and lineNr <= lastEdgeLineNr:
-- splitLine = split(line[:-1],';')
-- h = eval(split(splitLine[0],':')[1])
-- t = eval(split(splitLine[1],':')[1])
-+ splitLine = split(';',line[:-1])
-+ h = eval(split(':',splitLine[0])[1])
-+ t = eval(split(':',splitLine[1])[1])
- G.AddEdge(t,h)
- for i in xrange(nrOfEdgeWeights):
-- G.edgeWeights[i][(t,h)] = eval(split(splitLine[3+i],':')[1])
-+ G.edgeWeights[i][(t,h)] = eval(split(':',splitLine[3+i])[1])
-
- lineNr = lineNr + 1
-
-@@ -345,7 +345,7 @@
- if not line:
- return retval
-
-- token = filter(lambda x: x != '', split(line[:-1],"[\t ]*"))
-+ token = filter(lambda x: x != '', split("[\t ]*",line[:-1]))
-
- if len(token) == 1 and token[0] == ']':
- return retval
diff --git a/math/py-gato/files/patch-Gred.py b/math/py-gato/files/patch-Gred.py
index 0eb1005f69ca..a02164cebbc5 100644
--- a/math/py-gato/files/patch-Gred.py
+++ b/math/py-gato/files/patch-Gred.py
@@ -1,5 +1,11 @@
---- Gred.py.orig Fri Dec 5 13:08:46 2003
-+++ Gred.py Thu Dec 18 00:43:24 2003
+--- Gred.py Fri Jan 20 15:15:55 2006
++++ Gred.py Wed Mar 8 12:28:28 2006
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python2.3
++#!/usr/bin/env python
+ ################################################################################
+ #
+ # This file is part of Gato (Graph Animation Toolbox)
@@ -34,17 +34,17 @@
# last change by $Author: schliep $.
#
@@ -8,13 +14,13 @@
-import GatoGlobals # Needed for help viewer.XXX
-from Graph import Graph
-from DataStructures import EdgeWeight, VertexWeight
--from GraphUtil import OpenCATBoxGraph, OpenGMLGraph, SaveCATBoxGraph, WeightedGraphInformer
+-from GraphUtil import OpenCATBoxGraph, OpenGMLGraph, OpenDotGraph, SaveCATBoxGraph, WeightedGraphInformer
-from GraphEditor import GraphEditor
+from Gato.GatoGlobals import *
+import Gato.GatoGlobals # Needed for help viewer.XXX
+from Gato.Graph import Graph
+from Gato.DataStructures import EdgeWeight, VertexWeight
-+from Gato.GraphUtil import OpenCATBoxGraph, OpenGMLGraph, SaveCATBoxGraph, WeightedGraphInformer
++from Gato.GraphUtil import OpenCATBoxGraph, OpenGMLGraph, OpenDotGraph, SaveCATBoxGraph, WeightedGraphInformer
+from Gato.GraphEditor import GraphEditor
from Tkinter import *
import tkFont
@@ -27,13 +33,21 @@
from ScrolledText import *
from tkFileDialog import askopenfilename, asksaveasfilename
-@@ -55,7 +55,8 @@
+@@ -55,7 +55,7 @@
import sys
import os
-import GraphCreator, Embedder
-+from Gato import GraphCreator
-+from Gato import Embedder
++from Gato import GraphCreator, Embedder
class GredSplashScreen(GatoDialogs.SplashScreen):
+@@ -843,7 +843,7 @@
+ ## globals()['gVertexRadius'] = 12
+ ## globals()['gVertexFrameWidth'] = 0
+ ## globals()['gEdgeWidth'] = 2
+- GatoGlobals.cVertexDefault = '#000099'
++ Gato.GatoGlobals.cVertexDefault = '#000099'
+ ## globals()['cEdgeDefault'] = '#999999'
+ ## globals()['cLabelDefault'] = 'white'
+
diff --git a/math/py-gato/files/patch-TextTreeWidget.py b/math/py-gato/files/patch-TextTreeWidget.py
new file mode 100644
index 000000000000..4354615a763b
--- /dev/null
+++ b/math/py-gato/files/patch-TextTreeWidget.py
@@ -0,0 +1,8 @@
+--- TextTreeWidget.py Wed Mar 8 10:47:35 2006
++++ TextTreeWidget.py Wed Mar 8 10:47:47 2006
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python2.3
++#!/usr/bin/env python
+ ################################################################################
+ #
+ # This file is part of Gato (Graph Animation Toolbox)
diff --git a/math/py-gato/pkg-descr b/math/py-gato/pkg-descr
index 2f45a321aa5e..9d5b8517f595 100644
--- a/math/py-gato/pkg-descr
+++ b/math/py-gato/pkg-descr
@@ -11,6 +11,4 @@ Paraphrasing the website:
input - by terms of blinking, changing colors and other visual effects.
Author: Alexander Schliep <schliep@zpr.uni-koeln.de>
-WWW: http://www.zpr.uni-koeln.de/~gato/
-
--- Johann Visagie <wjv@FreeBSD.org>
+WWW: http://gato.sourceforge.net/index.html
diff --git a/math/py-gato/pkg-plist b/math/py-gato/pkg-plist
index 14af193aead0..b647d43a6768 100644
--- a/math/py-gato/pkg-plist
+++ b/math/py-gato/pkg-plist
@@ -5,6 +5,9 @@
%%PORTDOCS%%share/examples/gato/sample.cat
bin/Gato
bin/Gred
+lib/%%PYTHON_VERSION%%/site-packages/Gato/AnimationHistory.py
+lib/%%PYTHON_VERSION%%/site-packages/Gato/AnimationHistory.pyc
+lib/%%PYTHON_VERSION%%/site-packages/Gato/AnimationHistory.pyo
lib/%%PYTHON_VERSION%%/site-packages/Gato/AnimatedAlgorithms.py
lib/%%PYTHON_VERSION%%/site-packages/Gato/AnimatedAlgorithms.pyc
lib/%%PYTHON_VERSION%%/site-packages/Gato/AnimatedAlgorithms.pyo
@@ -59,6 +62,9 @@ lib/%%PYTHON_VERSION%%/site-packages/Gato/GraphEditor.pyo
lib/%%PYTHON_VERSION%%/site-packages/Gato/GraphUtil.py
lib/%%PYTHON_VERSION%%/site-packages/Gato/GraphUtil.pyc
lib/%%PYTHON_VERSION%%/site-packages/Gato/GraphUtil.pyo
+lib/%%PYTHON_VERSION%%/site-packages/Gato/Gred.py
+lib/%%PYTHON_VERSION%%/site-packages/Gato/Gred.pyc
+lib/%%PYTHON_VERSION%%/site-packages/Gato/Gred.pyo
lib/%%PYTHON_VERSION%%/site-packages/Gato/PlanarEmbedding.py
lib/%%PYTHON_VERSION%%/site-packages/Gato/PlanarEmbedding.pyc
lib/%%PYTHON_VERSION%%/site-packages/Gato/PlanarEmbedding.pyo