aboutsummaryrefslogtreecommitdiff
path: root/math/py-gnuplot/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-02-01 14:36:03 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-02-01 14:36:03 +0000
commite46598248a16bfa28a4f45207ac05d8a510fca3f (patch)
treec57cf96e83198e01e51e6013c0bfc4f5ae5de759 /math/py-gnuplot/Makefile
parent8ea3b67cff6432a8cf3cc8beef6d5a5338381c27 (diff)
Notes
Diffstat (limited to 'math/py-gnuplot/Makefile')
-rw-r--r--math/py-gnuplot/Makefile19
1 files changed, 14 insertions, 5 deletions
diff --git a/math/py-gnuplot/Makefile b/math/py-gnuplot/Makefile
index 7855025277b5..becc1c69a1ef 100644
--- a/math/py-gnuplot/Makefile
+++ b/math/py-gnuplot/Makefile
@@ -6,23 +6,32 @@
#
PORTNAME= py-gnuplot
-PORTVERSION= 1.4
+PORTVERSION= 1.5
CATEGORIES= math python
-MASTER_SITES= http://monsoon.harvard.edu/~mhagger/Gnuplot/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gnuplot-py
DISTNAME= Gnuplot-${PORTVERSION}
MAINTAINER= sobomax@FreeBSD.org
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/Numeric/_numpy.so:${PORTSDIR}/math/numpy
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot \
${PYTHON_SITELIBDIR}/Numeric/_numpy.so:${PORTSDIR}/math/numpy
USE_PYTHON= yes
+SETUP_CMD= cd ${WRKSRC}; ${PYTHON_CMD} setup.py
do-build:
- @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+ @${SETUP_CMD} build
do-install:
- ${MKDIR} ${PYTHON_SITELIBDIR}/Gnuplot
- ${INSTALL_DATA} ${WRKSRC}/*.py? ${PYTHON_SITELIBDIR}/Gnuplot
+ @${SETUP_CMD} install
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/py-gnuplot
+ cd ${WRKSRC}/doc && ${TAR} -chf - * | \
+ ${TAR} --unlink -xf - -C ${PREFIX}/share/doc/py-gnuplot
+.endif
.include <bsd.port.mk>