aboutsummaryrefslogtreecommitdiff
path: root/math/py-gnuplot/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-09-28 06:12:54 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-09-28 06:12:54 +0000
commit3babd03858cf96a0c5599ad5de1a0e8d58c1ba42 (patch)
tree0e0d1d6a4f54bb863caa2e18d0d33e2069be0198 /math/py-gnuplot/Makefile
parent95ed191e4d5af86a51209b974be8e2ae7aca6448 (diff)
Pythonize.
Submitted by: tg
Notes
Notes: svn path=/head/; revision=33194
Diffstat (limited to 'math/py-gnuplot/Makefile')
-rw-r--r--math/py-gnuplot/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/math/py-gnuplot/Makefile b/math/py-gnuplot/Makefile
index bdfae5e376a6..d374787c8f10 100644
--- a/math/py-gnuplot/Makefile
+++ b/math/py-gnuplot/Makefile
@@ -13,18 +13,16 @@ DISTNAME= Gnuplot-${PORTVERSION}
MAINTAINER= sobomax@FreeBSD.org
-BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15
-RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15 \
- gnuplot:${PORTSDIR}/math/gnuplot \
- ${LOCALBASE}/lib/python1.5/site-packages/Numeric/_numpy.so:${PORTSDIR}/math/numpy
+RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot \
+ ${PYTHON_SITELIBDIR}/Numeric/_numpy.so:${PORTSDIR}/math/numpy
+
+USE_PYTHON= yes
do-build:
- @${LOCALBASE}/bin/python \
- ${LOCALBASE}/lib/python1.5/compileall.py ${WRKSRC}
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
do-install:
- ${MKDIR} ${PREFIX}/lib/python1.5/site-packages/Gnuplot
- ${INSTALL_DATA} ${WRKSRC}/*.py? \
- ${PREFIX}/lib/python1.5/site-packages/Gnuplot
+ ${MKDIR} ${PYTHON_SITELIBDIR}/Gnuplot
+ ${INSTALL_DATA} ${WRKSRC}/*.py? ${PYTHON_SITELIBDIR}/Gnuplot
.include <bsd.port.mk>