aboutsummaryrefslogtreecommitdiff
path: root/math/py-igraph
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-12-21 19:57:35 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-12-21 19:57:35 +0000
commitd23f4f558c953fadc79eecf666c1cbcf3d3c78b7 (patch)
treee2c17d95e0e416d48fcace38ce8faea2651e6d1f /math/py-igraph
parentb1828256697ec90d0012ce669cb0e10771a445d3 (diff)
downloadports-d23f4f558c953fadc79eecf666c1cbcf3d3c78b7.tar.gz
ports-d23f4f558c953fadc79eecf666c1cbcf3d3c78b7.zip
Notes
Diffstat (limited to 'math/py-igraph')
-rw-r--r--math/py-igraph/Makefile28
-rw-r--r--math/py-igraph/distinfo3
-rw-r--r--math/py-igraph/pkg-descr7
-rw-r--r--math/py-igraph/pkg-plist30
4 files changed, 68 insertions, 0 deletions
diff --git a/math/py-igraph/Makefile b/math/py-igraph/Makefile
new file mode 100644
index 000000000000..6523207506b9
--- /dev/null
+++ b/math/py-igraph/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: py-igraph
+# Date created: 2006-12-20
+# Whom: Li-Wen Hsu <lwhsu@lwhsu.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= igraph
+PORTVERSION= 0.3.2
+CATEGORIES= math python
+MASTER_SITES= http://cheeseshop.python.org/packages/source/i/igraph/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= lwhsu@lwhsu.org
+COMMENT= High performance graph data structures and algorithms
+
+LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
+
+USE_PYTHON= 2.4+
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Does not compile on 4.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/py-igraph/distinfo b/math/py-igraph/distinfo
new file mode 100644
index 000000000000..cc0a0c660d42
--- /dev/null
+++ b/math/py-igraph/distinfo
@@ -0,0 +1,3 @@
+MD5 (igraph-0.3.2.tar.gz) = 343bdffef7fcf3841858acf6c16f06b3
+SHA256 (igraph-0.3.2.tar.gz) = e6753c708a6226e71d63159773b439c9d576e127830b2303aa3dabd048dab2ca
+SIZE (igraph-0.3.2.tar.gz) = 347036
diff --git a/math/py-igraph/pkg-descr b/math/py-igraph/pkg-descr
new file mode 100644
index 000000000000..941eb887b7d6
--- /dev/null
+++ b/math/py-igraph/pkg-descr
@@ -0,0 +1,7 @@
+This module extends Python with a Graph class which is capable of handling
+arbitrary directed and undirected graphs with thousands of nodes and millions
+of edges. Since the module makes use of the open source igraph library
+written in almost 100% pure C, it is blazing fast and outperforms most other
+pure Python-based packages around.
+
+WWW: http://cneurocvs.rmki.kfki.hu/igraph
diff --git a/math/py-igraph/pkg-plist b/math/py-igraph/pkg-plist
new file mode 100644
index 000000000000..5c494cbd5351
--- /dev/null
+++ b/math/py-igraph/pkg-plist
@@ -0,0 +1,30 @@
+%%PYTHON_SITELIBDIR%%/igraph/__init__.py
+%%PYTHON_SITELIBDIR%%/igraph/test/__init__.py
+%%PYTHON_SITELIBDIR%%/igraph/test/attributes.py
+%%PYTHON_SITELIBDIR%%/igraph/test/basic.py
+%%PYTHON_SITELIBDIR%%/igraph/test/flow.py
+%%PYTHON_SITELIBDIR%%/igraph/test/foreign.py
+%%PYTHON_SITELIBDIR%%/igraph/test/games.py
+%%PYTHON_SITELIBDIR%%/igraph/test/spectral.py
+%%PYTHON_SITELIBDIR%%/igraph/test/structural.py
+%%PYTHON_SITELIBDIR%%/igraph/test/__init__.pyc
+%%PYTHON_SITELIBDIR%%/igraph/test/attributes.pyc
+%%PYTHON_SITELIBDIR%%/igraph/test/basic.pyc
+%%PYTHON_SITELIBDIR%%/igraph/test/flow.pyc
+%%PYTHON_SITELIBDIR%%/igraph/test/foreign.pyc
+%%PYTHON_SITELIBDIR%%/igraph/test/games.pyc
+%%PYTHON_SITELIBDIR%%/igraph/test/spectral.pyc
+%%PYTHON_SITELIBDIR%%/igraph/test/structural.pyc
+%%PYTHON_SITELIBDIR%%/igraph/test/__init__.pyo
+%%PYTHON_SITELIBDIR%%/igraph/test/attributes.pyo
+%%PYTHON_SITELIBDIR%%/igraph/test/basic.pyo
+%%PYTHON_SITELIBDIR%%/igraph/test/flow.pyo
+%%PYTHON_SITELIBDIR%%/igraph/test/foreign.pyo
+%%PYTHON_SITELIBDIR%%/igraph/test/games.pyo
+%%PYTHON_SITELIBDIR%%/igraph/test/spectral.pyo
+%%PYTHON_SITELIBDIR%%/igraph/test/structural.pyo
+%%PYTHON_SITELIBDIR%%/igraph/_igraph.so
+%%PYTHON_SITELIBDIR%%/igraph/__init__.pyc
+%%PYTHON_SITELIBDIR%%/igraph/__init__.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/igraph/test
+@dirrm %%PYTHON_SITELIBDIR%%/igraph