aboutsummaryrefslogtreecommitdiff
path: root/math/py-matplotlib/Makefile
diff options
context:
space:
mode:
authorJosh Paetzel <jpaetzel@FreeBSD.org>2010-07-29 04:01:50 +0000
committerJosh Paetzel <jpaetzel@FreeBSD.org>2010-07-29 04:01:50 +0000
commit8edd02e17089303568ace3fefe3ca1775d365cf9 (patch)
treee961c7b49ff083af6de5a6bab9dd3d7dfff0d504 /math/py-matplotlib/Makefile
parente971ac5f265005919174ea76347103e9ef303c27 (diff)
downloadports-8edd02e17089303568ace3fefe3ca1775d365cf9.tar.gz
ports-8edd02e17089303568ace3fefe3ca1775d365cf9.zip
Notes
Diffstat (limited to 'math/py-matplotlib/Makefile')
-rw-r--r--math/py-matplotlib/Makefile94
1 files changed, 80 insertions, 14 deletions
diff --git a/math/py-matplotlib/Makefile b/math/py-matplotlib/Makefile
index 7de788e7dfce..da0a87affd21 100644
--- a/math/py-matplotlib/Makefile
+++ b/math/py-matplotlib/Makefile
@@ -7,11 +7,11 @@
#
PORTNAME= matplotlib
-PORTVERSION= 0.99.1.1
+PORTVERSION= 1.0.0
CATEGORIES= math python
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-0.99.1/
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-1.0/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTFILES= ${PORTNAME}-0.99.1.2.tar.gz
+DISTNAME= ${PORTNAME}-1.0.0
MAINTAINER= mainland@apeiron.net
COMMENT= A plotting library uses a syntax familiar to matlab users
@@ -19,40 +19,106 @@ COMMENT= A plotting library uses a syntax familiar to matlab users
BUILD_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}dateutil>=1.4:${PORTSDIR}/devel/py-dateutil \
${PYTHON_PKGNAMEPREFIX}pytz>0:${PORTSDIR}/devel/py-pytz \
- ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter \
${LOCALBASE}/lib/libagg.a:${PORTSDIR}/graphics/agg
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
png.6:${PORTSDIR}/graphics/png
-RUN_DEPENDS= ${PYNUMPY} \
- ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
-.if defined(PACKAGE_BUILDING)
-BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT}
-.endif
+RUN_DEPENDS= ${PYNUMPY}
USE_PYTHON= 2.4+
USE_PYDISTUTILS= yes
+CFLAGS+= -I${LOCALBASE}/include
+WRKSRC= ${WRKDIR}/${PORTNAME}-1.0.0/
+
+OPTIONS= GTKBACKEND "GTK backend support" ON \
+ GTKAGGBACKEND "GTKAgg backend support" ON \
+ TKAGGBACKEND "TKAgg backend support" ON \
+ WXAGGBACKEND "WXAgg backend support" OFF
+
+UNIQUENAME= ${PORTNAME}
+
+.include <bsd.port.options.mk>
+
+.if defined(PACKAGE_BUILDING) && \
+ (defined(WITH_GTKBACKEND) || defined(WITH_GTKAGGBACKEND) || \
+ defined(WITH_TKAGGBACKEND) || defined(WITH_WXAGGBACKEND))
+BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT}
+.endif
+
+.if defined(WITH_GTKBACKEND) || defined(WITH_GTKAGGBACKEND)
USE_GNOME= gtk20 pygtk2
+.endif
+
+.if defined(WITH_GTKBACKEND) && !defined(WITHOUT_GTKBACKEND)
+GTK_BACKEND=True
+
+PLIST_SUB+= GTKBACKEND=""
+.else
+GTK_BACKEND=False
+
+PLIST_SUB+= GTKBACKEND="@comment "
+.endif
+
+.if defined(WITH_GTKAGGBACKEND)
+GTKAGG_BACKEND=True
+
+PLIST_SUB+= GTKAGGBACKEND=""
+.else
+GTKAGG_BACKEND=False
+
+PLIST_SUB+= GTKAGGBACKEND="@comment "
+.endif
+
+.if defined(WITH_TKAGGBACKEND)
+BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
+
USE_TCL_RUN= yes
USE_TK_RUN= yes
-CFLAGS+= -I${LOCALBASE}/include
-WRKSRC= ${WRKDIR}/${PORTNAME}-0.99.1.1
-WANT_WX= 2.6
-.include <bsd.port.pre.mk>
+TKAGG_BACKEND=True
+
+PLIST_SUB+= TKAGGBACKEND=""
+.else
+TKAGG_BACKEND=False
-.if defined(WITH_WXPYTHON) || ${HAVE_WX:Mpython} != ""
+PLIST_SUB+= TKAGGBACKEND="@comment "
+.endif
+
+.if defined(WITH_WXAGGBACKEND)
USE_WX= 2.6
WX_COMPS= python
CONFIGURE_ENV+= WX_CONFIG="${WX_CONFIG}"
+
+WXAGG_BACKEND=True
+
+PLIST_SUB+= WXAGGBACKEND=""
+.else
+WXAGG_BACKEND=False
+
+PLIST_SUB+= WXAGGBACKEND="@comment "
.endif
+.include <bsd.port.pre.mk>
+
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
+# bsd.tcl.mk doesn't set TK_VER, so we use TCL_VER instead
post-patch:
${REINPLACE_CMD} -e 's|png_infopp_NULL|NULL|' \
${WRKSRC}/src/_png.cpp
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
+ -e 's|%%TCL_INCLUDEDIR%%|${TCL_INCLUDEDIR}|g' \
+ -e 's|%%TK_INCLUDEDIR%%|${TK_INCLUDEDIR}|g' \
+ -e 's|%%TCL_LIBDIR%%|${TCL_LIBDIR}|g' \
+ -e 's|%%TK_LIBDIR%%|${TK_LIBDIR}|g' \
+ -e 's|%%TCL_VER%%|${TCL_VER:S/.//}|g' \
+ -e 's|%%TK_VER%%|${TCL_VER:S/.//}|g' \
${WRKSRC}/setupext.py
+ ${REINPLACE_CMD} -e 's|%%GTK_BACKEND%%|${GTK_BACKEND}|g' \
+ -e 's|%%GTKAGG_BACKEND%%|${GTKAGG_BACKEND}|g' \
+ -e 's|%%TKAGG_BACKEND%%|${TKAGG_BACKEND}|g' \
+ -e 's|%%WXAGG_BACKEND%%|${WXAGG_BACKEND}|g' \
+ ${WRKSRC}/setup.cfg
.if !defined(NOPORTEXAMPLES)
post-install: