aboutsummaryrefslogtreecommitdiff
path: root/math/py-matplotlib/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-10-05 13:31:32 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-10-05 13:31:32 +0000
commit3c36e3474deddf85d2ca1e5b1f1b7e0cc5977f11 (patch)
tree8037259a6a6544ad5115b68af2782b319839dba2 /math/py-matplotlib/Makefile
parent59965b1a0cde25c322ad25ae7881da028a4b4e23 (diff)
downloadports-3c36e3474deddf85d2ca1e5b1f1b7e0cc5977f11.tar.gz
ports-3c36e3474deddf85d2ca1e5b1f1b7e0cc5977f11.zip
Notes
Diffstat (limited to 'math/py-matplotlib/Makefile')
-rw-r--r--math/py-matplotlib/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/math/py-matplotlib/Makefile b/math/py-matplotlib/Makefile
index 2c48a029c235..c823bb1c01c6 100644
--- a/math/py-matplotlib/Makefile
+++ b/math/py-matplotlib/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= matplotlib
-PORTVERSION= 0.91.2
-PORTREVISION= 1
+PORTVERSION= 0.98.3
CATEGORIES= math python
MASTER_SITES= SF
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -29,13 +28,23 @@ RUN_DEPENDS= ${PYNUMPY} \
BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT}
.endif
-USE_PYTHON= yes
+USE_PYTHON= 2.4+
USE_PYDISTUTILS= yes
USE_GNOME= gtk20 pygtk2
USE_TCL_RUN= yes
USE_TK_RUN= yes
CFLAGS+= -I${LOCALBASE}/include
+WANT_WX= 2.6
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_WXPYTHON) || ${HAVE_WX:Mpython} != ""
+USE_WX= 2.6
+WX_COMPS= python
+CONFIGURE_ENV+= WX_CONFIG="${WX_CONFIG}"
+.endif
+
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
post-patch:
@@ -55,4 +64,4 @@ post-install:
${CP} -R ${WRKSRC}/examples/ ${EXAMPLESDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>