aboutsummaryrefslogtreecommitdiff
path: root/math/py-matplotlib/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-08-04 03:33:57 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-08-04 03:33:57 +0000
commit946a062e53ca8894953b201b770ce54981be68cc (patch)
treea14f76adb0cee6cb0507a6a98b01a84c2ce44e8b /math/py-matplotlib/Makefile
parent0675f0cd93dd0b01890817bb1a02c4a4411dd81a (diff)
downloadports-946a062e53ca8894953b201b770ce54981be68cc.tar.gz
ports-946a062e53ca8894953b201b770ce54981be68cc.zip
Notes
Diffstat (limited to 'math/py-matplotlib/Makefile')
-rw-r--r--math/py-matplotlib/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/math/py-matplotlib/Makefile b/math/py-matplotlib/Makefile
new file mode 100644
index 000000000000..bd9f41d033d1
--- /dev/null
+++ b/math/py-matplotlib/Makefile
@@ -0,0 +1,53 @@
+# ex:ts=8
+# Ports collection makefile for: py-matplotlib
+# Date created: Aug 4, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= matplotlib
+PORTVERSION= 0.60.2
+CATEGORIES= math python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A plotting library uses a syntax familiar to matlab users
+
+BUILD_DEPENDS= ${PYNUMERIC} \
+ ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter \
+ ${LOCALBASE}/lib/libagg.a:${PORTSDIR}/graphics/agg
+LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+RUN_DEPENDS= ${PYNUMERIC} \
+ ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
+
+USE_PYTHON= 2.2+
+USE_PYDISTUTILS= yes
+USE_GNOME= gtk20 pygtk2
+CFLAGS+= -I${X11BASE}/include
+
+DATADIR= ${PREFIX}/share/py-${PORTNAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
+
+PLISTDIR= ${PYTHON_SITELIBDIR}/${PORTNAME} ${DATADIR}
+.if !defined(NOPORTDOCS)
+PLISTDIR+= ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.pre.mk>
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/examples/ ${EXAMPLESDIR}
+.endif
+.for dir in ${PLISTDIR}
+ @${FIND} ${dir} ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${dir} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+.endfor
+
+.include <bsd.port.post.mk>