aboutsummaryrefslogtreecommitdiff
path: root/math/py-matplotlib/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-10 06:46:00 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-10 06:46:00 +0000
commit72629cd9c1a094b829d5e7ea04a8d3977aacd636 (patch)
tree6c9cc4793f43e5abecc2018458cedb90cfddbcb7 /math/py-matplotlib/Makefile
parent1af9914df9277a1b8678da8c4a4ee51ff6841a82 (diff)
downloadports-72629cd9c1a094b829d5e7ea04a8d3977aacd636.tar.gz
ports-72629cd9c1a094b829d5e7ea04a8d3977aacd636.zip
Notes
Diffstat (limited to 'math/py-matplotlib/Makefile')
-rw-r--r--math/py-matplotlib/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/math/py-matplotlib/Makefile b/math/py-matplotlib/Makefile
index 123e164dc746..0beba3b07dd6 100644
--- a/math/py-matplotlib/Makefile
+++ b/math/py-matplotlib/Makefile
@@ -8,6 +8,9 @@ PORTREVISION= 1
CATEGORIES= math python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES= 5b7a21e53e11a7064b2171c0d91afda67f30c4e7.patch:-p1 # fix of the failure on 12 i386: https://github.com/matplotlib/matplotlib/issues/10698
+
MAINTAINER= mainland@apeiron.net
COMMENT= Plotting library uses a syntax familiar to MATLAB users
@@ -24,6 +27,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}pytz>=0:devel/py-pytz@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyparsing>=0:devel/py-pyparsing@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tornado>0:www/py-tornado@${FLAVOR}
+py27_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}backports.functools_lru_cache>0:devel/py-backports.functools_lru_cache@${FLAVOR}
USES= compiler:c++11-lib gettext pkgconfig python shebangfix uniquefiles:dirs
USE_GITHUB= yes
@@ -80,12 +84,6 @@ TKAGGBACKEND_BUILD_DEPENDS+= Xvfb:x11-servers/xorg-vfbserver
WXAGGBACKEND_BUILD_DEPENDS= Xvfb:x11-servers/xorg-vfbserver
.endif
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 3000
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}backports.functools_lru_cache>0:devel/py-backports.functools_lru_cache@${FLAVOR}
-.endif
-
post-extract:
${FIND} ${WRKSRC} -name \*.py | ${XARGS} ${CHMOD} -x
@@ -114,4 +112,4 @@ post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${CP} -R ${WRKSRC}/examples/ ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>