aboutsummaryrefslogtreecommitdiff
path: root/math/py-matplotlib
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-03-21 19:41:49 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-03-21 19:41:49 +0000
commit50a9a69da6caaa39beac988ff2abe9e1b991aa00 (patch)
treeeb743cefd555388fb7ae843d14fbbc3fab9e7dba /math/py-matplotlib
parent7ab965fc403f6de736b4a2764e4622819b319ed3 (diff)
downloadports-50a9a69da6caaa39beac988ff2abe9e1b991aa00.tar.gz
ports-50a9a69da6caaa39beac988ff2abe9e1b991aa00.zip
Notes
Diffstat (limited to 'math/py-matplotlib')
-rw-r--r--math/py-matplotlib/Makefile25
-rw-r--r--math/py-matplotlib/distinfo8
-rw-r--r--math/py-matplotlib/files/patch-extern_ttconv_pprdrv__tt.cpp111
3 files changed, 9 insertions, 135 deletions
diff --git a/math/py-matplotlib/Makefile b/math/py-matplotlib/Makefile
index c8dacea7b21e..5adb1ee9d1cd 100644
--- a/math/py-matplotlib/Makefile
+++ b/math/py-matplotlib/Makefile
@@ -2,15 +2,11 @@
# $FreeBSD$
PORTNAME= matplotlib
-DISTVERSIONPREFIX= v
-DISTVERSION= 2.1.2
-PORTREVISION= 6
+DISTVERSION= 2.2.3
CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
-PATCHFILES= 5b7a21e53e11a7064b2171c0d91afda67f30c4e7.patch:-p1 # fix of the failure on 12 i386: https://github.com/matplotlib/matplotlib/issues/10698
-
MAINTAINER= mainland@apeiron.net
COMMENT= Plotting library uses a syntax familiar to MATLAB users
@@ -29,8 +25,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}tornado>0:www/py-tornado@${PY_FLAVOR}
py27_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}backports.functools_lru_cache>0:devel/py-backports.functools_lru_cache@${PY_FLAVOR}
-USES= compiler:c++11-lib gettext pkgconfig python shebangfix uniquefiles:dirs
-USE_GITHUB= yes
+USES= compiler:c++11-lib gettext gnome pkgconfig python shebangfix uniquefiles:dirs
USE_PYTHON= autoplist distutils
CFLAGS+= -I${LOCALBASE}/include
@@ -79,18 +74,10 @@ WXAGGBACKEND_BUILD_DEPENDS= Xvfb:x11-servers/xorg-vfbserver
.endif
post-extract:
- ${FIND} ${WRKSRC} -name \*.py | ${XARGS} ${CHMOD} -x
+ @${FIND} ${WRKSRC} -name '*.py' | ${XARGS} ${CHMOD} -x
post-patch:
- ${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
- -e 's|%%TCL_INCLUDEDIR%%|${TCL_INCLUDEDIR}|g' \
- -e 's|%%TK_INCLUDEDIR%%|${TK_INCLUDEDIR}|g' \
- -e 's|%%TCL_LIBDIR%%|${TCL_LIBDIR}|g' \
- -e 's|%%TK_LIBDIR%%|${TK_LIBDIR}|g' \
- -e 's|%%TCL_VER%%|${TCL_SHLIB_VER}|g' \
- -e 's|%%TK_VER%%|${TK_SHLIB_VER}|g' \
- ${WRKSRC}/setupext.py
- ${REINPLACE_CMD} -e 's|%%GTK_BACKEND%%|${GTK_BACKEND}|g' \
+ @${REINPLACE_CMD} -e 's|%%GTK_BACKEND%%|${GTK_BACKEND}|g' \
-e 's|%%GTKAGG_BACKEND%%|${GTKAGG_BACKEND}|g' \
-e 's|%%QT5AGG_BACKEND%%|${QT5AGG_BACKEND}|g' \
-e 's|%%TKAGG_BACKEND%%|${TKAGG_BACKEND}|g' \
@@ -98,7 +85,7 @@ post-patch:
${WRKSRC}/setup.cfg
post-install:
- @${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR}/matplotlib -name '*.so' \
+ ${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR}/matplotlib -name '*.so' \
| ${XARGS} ${STRIP_CMD}
post-install-EXAMPLES-on:
diff --git a/math/py-matplotlib/distinfo b/math/py-matplotlib/distinfo
index 8ca6ad299d1f..791da95bb981 100644
--- a/math/py-matplotlib/distinfo
+++ b/math/py-matplotlib/distinfo
@@ -1,5 +1,3 @@
-TIMESTAMP = 1520663268
-SHA256 (matplotlib-matplotlib-v2.1.2_GH0.tar.gz) = 613d79282a0a8ba88cfc52dbcf1b08ab070dae395c3d313d141ccc3f87e3c9fa
-SIZE (matplotlib-matplotlib-v2.1.2_GH0.tar.gz) = 35181192
-SHA256 (5b7a21e53e11a7064b2171c0d91afda67f30c4e7.patch) = f332f13cd365cdc3903bed12bdb483366e0212d9481f0949474334db96cc3257
-SIZE (5b7a21e53e11a7064b2171c0d91afda67f30c4e7.patch) = 1736
+TIMESTAMP = 1547732863
+SHA256 (matplotlib-2.2.3.tar.gz) = 7355bf757ecacd5f0ac9dd9523c8e1a1103faadf8d33c22664178e17533f8ce5
+SIZE (matplotlib-2.2.3.tar.gz) = 36839609
diff --git a/math/py-matplotlib/files/patch-extern_ttconv_pprdrv__tt.cpp b/math/py-matplotlib/files/patch-extern_ttconv_pprdrv__tt.cpp
deleted file mode 100644
index 09ed34033f35..000000000000
--- a/math/py-matplotlib/files/patch-extern_ttconv_pprdrv__tt.cpp
+++ /dev/null
@@ -1,111 +0,0 @@
-extern/ttconv/pprdrv_tt.cpp:245:41: error: cast from pointer to smaller type 'char' loses information
- font->Copyright[length]=(char)NULL;
- ^~~~~~~~~~
-extern/ttconv/pprdrv_tt.cpp:261:42: error: cast from pointer to smaller type 'char' loses information
- font->FamilyName[length]=(char)NULL;
- ^~~~~~~~~~
-extern/ttconv/pprdrv_tt.cpp:277:37: error: cast from pointer to smaller type 'char' loses information
- font->Style[length]=(char)NULL;
- ^~~~~~~~~~
-extern/ttconv/pprdrv_tt.cpp:293:40: error: cast from pointer to smaller type 'char' loses information
- font->FullName[length]=(char)NULL;
- ^~~~~~~~~~
-extern/ttconv/pprdrv_tt.cpp:309:39: error: cast from pointer to smaller type 'char' loses information
- font->Version[length]=(char)NULL;
- ^~~~~~~~~~
-extern/ttconv/pprdrv_tt.cpp:325:40: error: cast from pointer to smaller type 'char' loses information
- font->PostName[length]=(char)NULL;
- ^~~~~~~~~~
-extern/ttconv/pprdrv_tt.cpp:340:42: error: cast from pointer to smaller type 'char' loses information
- font->PostName[length/2]=(char)NULL;
- ^~~~~~~~~~
-extern/ttconv/pprdrv_tt.cpp:355:41: error: cast from pointer to smaller type 'char' loses information
- font->Trademark[length]=(char)NULL;
- ^~~~~~~~~~
-extern/ttconv/pprdrv_tt.cpp:1041:19: error: cast from pointer to smaller type 'char' loses information
- temp[len]=(char)NULL; /* a buffer and make it ASCIIz. */
- ^~~~~~~~~~
-
---- extern/ttconv/pprdrv_tt.cpp.orig 2016-09-09 02:50:50 UTC
-+++ extern/ttconv/pprdrv_tt.cpp
-@@ -242,7 +242,7 @@ void Read_name(struct TTFONT *font)
- {
- font->Copyright = (char*)calloc(sizeof(char),length+1);
- strncpy(font->Copyright,(const char*)strings+offset,length);
-- font->Copyright[length]=(char)NULL;
-+ font->Copyright[length]='\0';
- replace_newlines_with_spaces(font->Copyright);
-
- #ifdef DEBUG_TRUETYPE
-@@ -258,7 +258,7 @@ void Read_name(struct TTFONT *font)
- free(font->FamilyName);
- font->FamilyName = (char*)calloc(sizeof(char),length+1);
- strncpy(font->FamilyName,(const char*)strings+offset,length);
-- font->FamilyName[length]=(char)NULL;
-+ font->FamilyName[length]='\0';
- replace_newlines_with_spaces(font->FamilyName);
-
- #ifdef DEBUG_TRUETYPE
-@@ -274,7 +274,7 @@ void Read_name(struct TTFONT *font)
- free(font->Style);
- font->Style = (char*)calloc(sizeof(char),length+1);
- strncpy(font->Style,(const char*)strings+offset,length);
-- font->Style[length]=(char)NULL;
-+ font->Style[length]='\0';
- replace_newlines_with_spaces(font->Style);
-
- #ifdef DEBUG_TRUETYPE
-@@ -290,7 +290,7 @@ void Read_name(struct TTFONT *font)
- free(font->FullName);
- font->FullName = (char*)calloc(sizeof(char),length+1);
- strncpy(font->FullName,(const char*)strings+offset,length);
-- font->FullName[length]=(char)NULL;
-+ font->FullName[length]='\0';
- replace_newlines_with_spaces(font->FullName);
-
- #ifdef DEBUG_TRUETYPE
-@@ -306,7 +306,7 @@ void Read_name(struct TTFONT *font)
- free(font->Version);
- font->Version = (char*)calloc(sizeof(char),length+1);
- strncpy(font->Version,(const char*)strings+offset,length);
-- font->Version[length]=(char)NULL;
-+ font->Version[length]='\0';
- replace_newlines_with_spaces(font->Version);
-
- #ifdef DEBUG_TRUETYPE
-@@ -322,7 +322,7 @@ void Read_name(struct TTFONT *font)
- free(font->PostName);
- font->PostName = (char*)calloc(sizeof(char),length+1);
- strncpy(font->PostName,(const char*)strings+offset,length);
-- font->PostName[length]=(char)NULL;
-+ font->PostName[length]='\0';
- replace_newlines_with_spaces(font->PostName);
-
- #ifdef DEBUG_TRUETYPE
-@@ -337,7 +337,7 @@ void Read_name(struct TTFONT *font)
- free(font->PostName);
- font->PostName = (char*)calloc(sizeof(char),length+1);
- utf16be_to_ascii(font->PostName, (char *)strings+offset, length);
-- font->PostName[length/2]=(char)NULL;
-+ font->PostName[length/2]='\0';
- replace_newlines_with_spaces(font->PostName);
-
- #ifdef DEBUG_TRUETYPE
-@@ -352,7 +352,7 @@ void Read_name(struct TTFONT *font)
- {
- font->Trademark = (char*)calloc(sizeof(char),length+1);
- strncpy(font->Trademark,(const char*)strings+offset,length);
-- font->Trademark[length]=(char)NULL;
-+ font->Trademark[length]='\0';
- replace_newlines_with_spaces(font->Trademark);
-
- #ifdef DEBUG_TRUETYPE
-@@ -1038,7 +1038,7 @@ const char *ttfont_CharStrings_getname(struct TTFONT *
- }
-
- strncpy(temp,ptr,len); /* Copy the pascal string into */
-- temp[len]=(char)NULL; /* a buffer and make it ASCIIz. */
-+ temp[len]='\0'; /* a buffer and make it ASCIIz. */
-
- return temp;
- }