aboutsummaryrefslogtreecommitdiff
path: root/math/py-matplotlib
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2011-11-10 13:20:21 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2011-11-10 13:20:21 +0000
commit3417c1452dc5a68ee017e6525b4adf2e939f225d (patch)
tree10ca8a7b61141b88772bdeb2edc2a91be17563ed /math/py-matplotlib
parentbe2e0e08c531d01b86e397845860f99f355520ad (diff)
downloadports-3417c1452dc5a68ee017e6525b4adf2e939f225d.tar.gz
ports-3417c1452dc5a68ee017e6525b4adf2e939f225d.zip
Notes
Diffstat (limited to 'math/py-matplotlib')
-rw-r--r--math/py-matplotlib/Makefile44
1 files changed, 23 insertions, 21 deletions
diff --git a/math/py-matplotlib/Makefile b/math/py-matplotlib/Makefile
index 01cbd80853f1..dbf3ec26ea82 100644
--- a/math/py-matplotlib/Makefile
+++ b/math/py-matplotlib/Makefile
@@ -8,7 +8,7 @@
PORTNAME= matplotlib
PORTVERSION= 1.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math python
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -21,13 +21,15 @@ BUILD_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}pytz>0:${PORTSDIR}/devel/py-pytz
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
png.6:${PORTSDIR}/graphics/png
-RUN_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>=1.4:${PORTSDIR}/devel/py-dateutil \
+ ${PYTHON_PKGNAMEPREFIX}pytz>0:${PORTSDIR}/devel/py-pytz
USE_PYTHON= 2.4+
-USE_PYDISTUTILS= yes
+USE_PYDISTUTILS=yes
CFLAGS+= -I${LOCALBASE}/include
-OPTIONS= GTKBACKEND "GTK backend support" ON \
+OPTIONS= GTKBACKEND "GTK backend support" ON \
GTKAGGBACKEND "GTKAgg backend support" ON \
TKAGGBACKEND "TKAgg backend support" ON \
WXAGGBACKEND "WXAgg backend support" OFF
@@ -47,23 +49,23 @@ USE_GNOME= gtk20 pygtk2
.endif
.if defined(WITH_GTKBACKEND) && !defined(WITHOUT_GTKBACKEND)
-GTK_BACKEND=True
+GTK_BACKEND= True
-PLIST_SUB+= GTKBACKEND=""
+PLIST_SUB+= GTKBACKEND=""
.else
-GTK_BACKEND=False
+GTK_BACKEND= False
-PLIST_SUB+= GTKBACKEND="@comment "
+PLIST_SUB+= GTKBACKEND="@comment "
.endif
.if defined(WITH_GTKAGGBACKEND)
-GTKAGG_BACKEND=True
+GTKAGG_BACKEND= True
-PLIST_SUB+= GTKAGGBACKEND=""
+PLIST_SUB+= GTKAGGBACKEND=""
.else
-GTKAGG_BACKEND=False
+GTKAGG_BACKEND= False
-PLIST_SUB+= GTKAGGBACKEND="@comment "
+PLIST_SUB+= GTKAGGBACKEND="@comment "
.endif
.if defined(WITH_TKAGGBACKEND)
@@ -73,27 +75,27 @@ RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkint
USE_TCL_RUN= yes
USE_TK_RUN= yes
-TKAGG_BACKEND=True
+TKAGG_BACKEND= True
-PLIST_SUB+= TKAGGBACKEND=""
+PLIST_SUB+= TKAGGBACKEND=""
.else
-TKAGG_BACKEND=False
+TKAGG_BACKEND= False
-PLIST_SUB+= TKAGGBACKEND="@comment "
+PLIST_SUB+= TKAGGBACKEND="@comment "
.endif
.if defined(WITH_WXAGGBACKEND)
-USE_WX= 2.6
+USE_WX= 2.6
WX_COMPS= python
CONFIGURE_ENV+= WX_CONFIG="${WX_CONFIG}"
-WXAGG_BACKEND=True
+WXAGG_BACKEND= True
-PLIST_SUB+= WXAGGBACKEND=""
+PLIST_SUB+= WXAGGBACKEND=""
.else
-WXAGG_BACKEND=False
+WXAGG_BACKEND= False
-PLIST_SUB+= WXAGGBACKEND="@comment "
+PLIST_SUB+= WXAGGBACKEND="@comment "
.endif
.include <bsd.port.pre.mk>