aboutsummaryrefslogtreecommitdiff
path: root/math/py-matplotlib
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /math/py-matplotlib
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'math/py-matplotlib')
-rw-r--r--math/py-matplotlib/Makefile6
-rw-r--r--math/py-matplotlib/files/patch-_png.cpp23
2 files changed, 25 insertions, 4 deletions
diff --git a/math/py-matplotlib/Makefile b/math/py-matplotlib/Makefile
index 1de4c9624142..7c71f3f0a82a 100644
--- a/math/py-matplotlib/Makefile
+++ b/math/py-matplotlib/Makefile
@@ -8,7 +8,7 @@
PORTNAME= matplotlib
PORTVERSION= 1.0.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math python
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -20,7 +20,7 @@ BUILD_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}dateutil>=1.4:${PORTSDIR}/devel/py-dateutil \
${PYTHON_PKGNAMEPREFIX}pytz>0:${PORTSDIR}/devel/py-pytz
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
- png.6:${PORTSDIR}/graphics/png
+ png15:${PORTSDIR}/graphics/png
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}dateutil>=1.4:${PORTSDIR}/devel/py-dateutil \
${PYTHON_PKGNAMEPREFIX}pytz>0:${PORTSDIR}/devel/py-pytz
@@ -102,8 +102,6 @@ post-extract:
# bsd.tcl.mk doesn't set TK_VER, so we use TCL_VER instead
post-patch:
- ${REINPLACE_CMD} -e 's|png_infopp_NULL|NULL|' \
- ${WRKSRC}/src/_png.cpp
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
-e 's|%%TCL_INCLUDEDIR%%|${TCL_INCLUDEDIR}|g' \
-e 's|%%TK_INCLUDEDIR%%|${TK_INCLUDEDIR}|g' \
diff --git a/math/py-matplotlib/files/patch-_png.cpp b/math/py-matplotlib/files/patch-_png.cpp
new file mode 100644
index 000000000000..cfa0202a92c0
--- /dev/null
+++ b/math/py-matplotlib/files/patch-_png.cpp
@@ -0,0 +1,23 @@
+--- src/_png.cpp.orig 2010-10-12 18:14:42.000000000 +0200
++++ src/_png.cpp 2012-05-06 06:33:48.000000000 +0200
+@@ -20,6 +20,7 @@
+ # include "Python.h"
+
+ # include <png.h>
++# include <pngpriv.h>
+ #endif
+
+ // TODO: Un CXX-ify this module
+@@ -459,10 +460,10 @@
+
+ //free the png memory
+ png_read_end(png_ptr, info_ptr);
+-#ifndef png_infopp_NULL
++#ifndef NULL
+ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
+ #else
+- png_destroy_read_struct(&png_ptr, &info_ptr, png_infopp_NULL);
++ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
+ #endif
+ if (close_file)
+ {