aboutsummaryrefslogtreecommitdiff
path: root/math/py-networkx/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-23 16:26:39 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-23 16:26:39 +0000
commit1d228e5cbfec8f8aafddf7c6a89d69b0ba6dd224 (patch)
tree602dea0315b58200803ecd5960306d42552cfbdb /math/py-networkx/Makefile
parent439606a973ea4d62b42c70997391bb96085c32ce (diff)
Notes
Diffstat (limited to 'math/py-networkx/Makefile')
-rw-r--r--math/py-networkx/Makefile21
1 files changed, 15 insertions, 6 deletions
diff --git a/math/py-networkx/Makefile b/math/py-networkx/Makefile
index 5ba4e7a6f7df..9d2e616d227b 100644
--- a/math/py-networkx/Makefile
+++ b/math/py-networkx/Makefile
@@ -4,7 +4,7 @@
# $FreeBSD$
PORTNAME= networkx
-PORTVERSION= 0.36
+PORTVERSION= 0.99
CATEGORIES= math python
MASTER_SITES= https://networkx.lanl.gov/download/networkx/ \
CHEESESHOP
@@ -14,13 +14,22 @@ MAINTAINER= dikshie@sfc.wide.ad.jp
COMMENT= Tools for complex network
USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-
-post-patch:
- @${REINPLACE_CMD} -e 's,%%DOCSDIR%%,${DOCSDIR},' ${WRKSRC}/setup.py
- @${REINPLACE_CMD} -e 's,%%EXAMPLESDIR%%,${EXAMPLESDIR},' ${WRKSRC}/setup.py
+USE_PYDISTUTILS= easy_install
post-install:
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC}/examples \
+ && ${FIND} . -type d -exec ${MKDIR} ${EXAMPLESDIR}/\{} \; \
+ && ${FIND} . -type f -exec ${INSTALL_DATA} \{} ${EXAMPLESDIR}/\{} \;
+.endif
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/INSTALL.txt ${DOCSDIR}
+.endif
+
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>