aboutsummaryrefslogtreecommitdiff
path: root/math/py-numarray
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-10-29 09:04:18 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-10-29 09:04:18 +0000
commitdb5f7b6cf1398ed5620a303804068469c49673fc (patch)
treee6440b94cb8fe0eb0f4ce478471123fc2a854b56 /math/py-numarray
parent1bc4c308f8d68fb4f9924223feab8e52118f9bf2 (diff)
downloadports-db5f7b6cf1398ed5620a303804068469c49673fc.tar.gz
ports-db5f7b6cf1398ed5620a303804068469c49673fc.zip
Notes
Diffstat (limited to 'math/py-numarray')
-rw-r--r--math/py-numarray/Makefile9
-rw-r--r--math/py-numarray/files/patch-setup.py6
2 files changed, 10 insertions, 5 deletions
diff --git a/math/py-numarray/Makefile b/math/py-numarray/Makefile
index 7279417b74a0..608241fac022 100644
--- a/math/py-numarray/Makefile
+++ b/math/py-numarray/Makefile
@@ -27,10 +27,15 @@ post-configure:
${PYTHON_CMD} Include/numarray/genapis.py
post-install:
- ${FIND} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/numarray -name "*.so" -exec \
+ @${FIND} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/numarray -name "*.so" -exec \
${STRIP_CMD} {} \;
- @${MKDIR} ${STAGEDIR}${DOCSDIR} ${STAGEDIR}${EXAMPLESDIR}
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
@${TAR} -C ${WRKSRC}/Doc -cf- .|${TAR} -C ${STAGEDIR}${DOCSDIR} -xf-
+
+port-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
@${TAR} -C ${WRKSRC}/Examples -cf- .|${TAR} -C ${STAGEDIR}${EXAMPLESDIR} -xf-
@${RM} -r ${STAGEDIR}${EXAMPLESDIR}/ufunc/build
diff --git a/math/py-numarray/files/patch-setup.py b/math/py-numarray/files/patch-setup.py
index e730c1c55f89..f002f2533d65 100644
--- a/math/py-numarray/files/patch-setup.py
+++ b/math/py-numarray/files/patch-setup.py
@@ -1,6 +1,6 @@
---- setup.py.orig 2013-12-12 18:04:59.679796972 -0200
-+++ setup.py 2013-12-12 18:05:04.376796310 -0200
-@@ -227,6 +227,4 @@
+--- setup.py.orig 2005-11-17 23:12:49 UTC
++++ setup.py
+@@ -227,6 +227,4 @@ def main():
# Do the installation.
#
if __name__ == "__main__":