aboutsummaryrefslogtreecommitdiff
path: root/math/py-numeric/Makefile
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2008-10-23 04:17:28 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2008-10-23 04:17:28 +0000
commitcb8f66aef9af638ef779a85a6fff68107b3bc15c (patch)
tree319d1a0264195b4600770eed0aec5f5c92a410c0 /math/py-numeric/Makefile
parent85f61c3cfc60e8dfb82848ea554f2ce7ff1732cc (diff)
- Updated Makefile to handle installation differently based on
whether devel/py-setuptools is present or not. The setup.py installer modifies the packing list based on that, so we have to modify pkg-plist in kind. - Added code to handle NOPORTEXAMPLES - Take maintainership PR: ports/122434 Submitted by: "Eugene M. Kim" <gene at nttmcl dot com>
Notes
Notes: svn path=/head/; revision=221922
Diffstat (limited to 'math/py-numeric/Makefile')
-rw-r--r--math/py-numeric/Makefile29
1 files changed, 22 insertions, 7 deletions
diff --git a/math/py-numeric/Makefile b/math/py-numeric/Makefile
index d6ecdbc2c469..f8d1973dfa2c 100644
--- a/math/py-numeric/Makefile
+++ b/math/py-numeric/Makefile
@@ -7,7 +7,7 @@
PORTNAME= numeric
PORTVERSION= 24.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math python
MASTER_SITES= http://numpy.scipy.org/:doc \
${MASTER_SITE_SOURCEFORGE:S/$/:source/}
@@ -17,16 +17,16 @@ DISTFILES= Numeric-${PORTVERSION}${EXTRACT_SUFX}:source \
numpy.pdf:doc
EXTRACT_ONLY= Numeric-${PORTVERSION}${EXTRACT_SUFX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= glarkin@FreeBSD.org
COMMENT= The Numeric Extension to Python
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= Numeric
PYDISTUTILS_EGGINFODIR= ${PYTHONPREFIX_SITELIBDIR}/Numeric
# PYDISTUTILS_NOEGGINFO is used as a temporary workaround to fix the plist
-PYDISTUTILS_NOEGGINFO=yes
+PYDISTUTILS_NOEGGINFO= yes
WRKSRC= ${WRKDIR}/Numeric-${PORTVERSION}
@@ -35,6 +35,19 @@ EXAMPLESDIR= ${PREFIX}/share/examples/py-numeric
.include <bsd.port.pre.mk>
+.if exists(${LOCALBASE}/bin/easy_install)
+# py-setuptools is installed - adjust pkg-plist to work with
+# implicit usage in setup.py
+EASY=""
+NOTEASY="@comment "
+.else
+# py-setuptools is not installed - adjust pkg-plist
+EASY="@comment "
+NOTEASY=""
+.endif
+
+PLIST_SUB+= EASY=${EASY} NOTEASY=${NOTEASY}
+
pre-fetch:
.if ${PYTHON_REL} < 200
@${ECHO} "Py-numeric doesn't work with Python versions < 2.0."
@@ -46,12 +59,14 @@ post-extract:
@${CP} ${DISTDIR}/numpy.pdf ${WRKDIR}
post-install:
- @${MKDIR} ${EXAMPLESDIR}
+.if !defined(NOPORTEXAMPLES)
+ @${INSTALL} -d ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/Demo/*.py ${EXAMPLESDIR}
@${MKDIR} ${EXAMPLESDIR}/NumTut
${INSTALL_DATA} ${WRKSRC}/Demo/NumTut/* ${EXAMPLESDIR}/NumTut
+.endif
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ @${INSTALL} -d ${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/numpy.pdf ${DOCSDIR}
.endif