aboutsummaryrefslogtreecommitdiff
path: root/math/py-numeric
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2000-09-22 11:43:23 +0000
committerThomas Gellekum <tg@FreeBSD.org>2000-09-22 11:43:23 +0000
commit551849729b1ae284a419364f86e0203ae8e96f2e (patch)
tree276630bf27e2b4ddef5ee1dc34981fca773d87f3 /math/py-numeric
parentd0acb1b7bf30adac9b782f799f00ec7bb2ba33f4 (diff)
downloadports-551849729b1ae284a419364f86e0203ae8e96f2e.tar.gz
ports-551849729b1ae284a419364f86e0203ae8e96f2e.zip
Notes
Diffstat (limited to 'math/py-numeric')
-rw-r--r--math/py-numeric/Makefile6
-rw-r--r--math/py-numeric/distinfo2
-rw-r--r--math/py-numeric/files/patch-setup.py36
-rw-r--r--math/py-numeric/pkg-plist2
4 files changed, 13 insertions, 33 deletions
diff --git a/math/py-numeric/Makefile b/math/py-numeric/Makefile
index 380731776bf9..44ebdf301246 100644
--- a/math/py-numeric/Makefile
+++ b/math/py-numeric/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= numeric
-PORTVERSION= 16.1
-PORTREVISION= 1
+PORTVERSION= 16.1.1
CATEGORIES= math python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= numpy
@@ -21,8 +20,7 @@ LIB_DEPENDS= lapack.3:${PORTSDIR}/math/lapack \
blas.2:${PORTSDIR}/math/lapack
USE_PYTHON= yes
-MAKE_ENV= BLASLIBDIR=${LOCALBASE}/lib LAPACKLIBDIR=${LOCALBASE}/lib \
- PYTHON_CMD=${PYTHON_CMD}
+MAKE_ENV= PYTHON_CMD=${PYTHON_CMD}
DOCDIR= ${PREFIX}/share/doc/py-numeric
EXAMPLEDIR= ${PREFIX}/share/examples/py-numeric
diff --git a/math/py-numeric/distinfo b/math/py-numeric/distinfo
index 68b73568b229..8aa4cf607e54 100644
--- a/math/py-numeric/distinfo
+++ b/math/py-numeric/distinfo
@@ -1 +1 @@
-MD5 (Numeric-16.1.tar.gz) = 588c5f6b34c918d499d0b3128dbb467e
+MD5 (Numeric-16.1.1.tar.gz) = a20f535b1761a19fb791456cee37b812
diff --git a/math/py-numeric/files/patch-setup.py b/math/py-numeric/files/patch-setup.py
index fa40835613fa..e3da257d0019 100644
--- a/math/py-numeric/files/patch-setup.py
+++ b/math/py-numeric/files/patch-setup.py
@@ -1,32 +1,12 @@
--- setup.py.orig Tue Sep 12 22:27:29 2000
-+++ setup.py Mon Sep 18 10:00:53 2000
-@@ -22,9 +22,17 @@
-
-
- # Locate the directories in which the BLAS and LAPACK are located.
--# if you know where they are, put it here:
--BLASLIBDIR = None
--LAPACKLIBDIR = None
-+# if you know where they are, pass them via your environment or edit
-+# the except: case.
-+try:
-+ BLASLIBDIR = os.environ['BLASLIBDIR']
-+except KeyError:
-+ BLASLIBDIR = None
-+try:
-+ LAPACKLIBDIR = os.environ['LAPACKLIBDIR']
-+except KeyError:
-+ LAPACKLIBDIR = None
-+
++++ setup.py Thu Sep 21 17:17:55 2000
+@@ -27,6 +27,9 @@
+ LAPACKLIBDIR = None
# places to look and what to look for
POSSIBLE_DIRECTORIES = ['/usr/local/lib', '/usr/lib', 'lapack_lite']
++# add sys.prefix + '/lib', on the assumption that python was
++# installed in the same directory as all other local software
++POSSIBLE_DIRECTORIES.append(sys.prefix + '/lib')
if sys.platform == 'win32':
-@@ -91,7 +99,7 @@
- Extension('umath', ['Src/umathmodule.c']),
- Extension('lapack_lite',
- ['Src/lapack_litemodule.c'],
-- libraries=['lapack', 'blas'],
-+ libraries=['lapack', 'blas', 'g2c'],
- library_dirs=[BLASLIBDIR, LAPACKLIBDIR]),
- Extension('ranlib',
- ['Src/ranlibmodule.c',
+ BLASNAMES = ['blas.lib']
+ LAPACKNAMES = ['lapack.lib']
diff --git a/math/py-numeric/pkg-plist b/math/py-numeric/pkg-plist
index e19eeb69d65a..53d2618a7547 100644
--- a/math/py-numeric/pkg-plist
+++ b/math/py-numeric/pkg-plist
@@ -7,6 +7,8 @@ lib/%%PYTHON_VERSION%%/site-packages/FFT/__init__.py
lib/%%PYTHON_VERSION%%/site-packages/FFT/__init__.pyc
lib/%%PYTHON_VERSION%%/site-packages/MA/MA.py
lib/%%PYTHON_VERSION%%/site-packages/MA/MA.pyc
+lib/%%PYTHON_VERSION%%/site-packages/MA/version.py
+lib/%%PYTHON_VERSION%%/site-packages/MA/version.pyc
lib/%%PYTHON_VERSION%%/site-packages/MA/__init__.py
lib/%%PYTHON_VERSION%%/site-packages/MA/__init__.pyc
lib/%%PYTHON_VERSION%%/site-packages/Numeric.pth