aboutsummaryrefslogtreecommitdiff
path: root/math/py-numpy/Makefile
diff options
context:
space:
mode:
authorSoeren Straarup <xride@FreeBSD.org>2006-12-30 16:02:58 +0000
committerSoeren Straarup <xride@FreeBSD.org>2006-12-30 16:02:58 +0000
commit3f5be3642602db74d8b30e647cb5652ce6303116 (patch)
treefdf45eccc625bbd156bc57b8cfa57044c4d6d259 /math/py-numpy/Makefile
parent5e72726d93cdb330fe992fd3b8252b72f5165e04 (diff)
Notes
Diffstat (limited to 'math/py-numpy/Makefile')
-rw-r--r--math/py-numpy/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/math/py-numpy/Makefile b/math/py-numpy/Makefile
index d6e7dc8b9a98..63ed18e68171 100644
--- a/math/py-numpy/Makefile
+++ b/math/py-numpy/Makefile
@@ -6,7 +6,8 @@
#
PORTNAME= numpy
-PORTVERSION= 1.0r1
+PORTVERSION= 1.0
+PORTEPOCH= 1
CATEGORIES= math python
MASTER_SITES= http://numpy.scipy.org/:doc \
${MASTER_SITE_SOURCEFORGE:S/$/:source/}
@@ -34,6 +35,9 @@ WRKSRC= ${WRKDIR}/${DISTNAME:S/r/rc/}
.if defined(WITH_ATLAS)
LIB_DEPENDS+= atlas.1:${PORTSDIR}/math/atlas
+.if !exists(${LOCALBASE}/lib/libalapack.a)
+IGNORE= atlas needs to be built with WITH_STATICLIB for numpy to function properly
+.endif
.else
LIB_DEPENDS+= lapack.3:${PORTSDIR}/math/lapack \
blas.1:${PORTSDIR}/math/blas