aboutsummaryrefslogtreecommitdiff
path: root/math/py-yt
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2016-12-27 06:35:22 +0000
committerWen Heping <wen@FreeBSD.org>2016-12-27 06:35:22 +0000
commit39007efbd8fc16a75619c23f1f3ea66871ce88e7 (patch)
treefae194502358e55f32f643b9093ac112b0f5b3df /math/py-yt
parent0efd35477d5c9e3b9fa0cb3ba28aed7467e1f5ab (diff)
Notes
Diffstat (limited to 'math/py-yt')
-rw-r--r--math/py-yt/Makefile38
-rw-r--r--math/py-yt/distinfo3
-rw-r--r--math/py-yt/files/patch-yt_extern_tqdm___utils.py10
-rw-r--r--math/py-yt/pkg-descr7
4 files changed, 58 insertions, 0 deletions
diff --git a/math/py-yt/Makefile b/math/py-yt/Makefile
new file mode 100644
index 000000000000..10ad7df6178a
--- /dev/null
+++ b/math/py-yt/Makefile
@@ -0,0 +1,38 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= yt
+PORTVERSION= 3.3.3
+CATEGORIES= math astro python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Analysis and visualization toolkit for volumetric data
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING.txt
+
+BUILD_DEPENDS= cython:lang/cython \
+ ${PYNUMPY}
+RUN_DEPENDS= isympy:math/py-sympy \
+ ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib \
+ ${PYTHON_PKGNAMEPREFIX}ipython>0:devel/ipython
+LIB_DEPENDS= libembree.so:graphics/embree \
+ libomp.so:devel/openmp
+
+USES= localbase python
+USE_PYTHON= autoplist distutils
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|\['-fopenmp', filename\]|['-I${LOCALBASE}/include', '-L${LOCALBASE}/lib', '-lm', '-fopenmp', filename]|" \
+ ${WRKSRC}/setupext.py
+
+post-install:
+ # workaround for the bug https://bitbucket.org/yt_analysis/yt/issues/1296
+ @${ECHO} "${PYTHON_SITELIBDIR}/yt/__hg_version__.py" >> ${_PYTHONPKGLIST}
+ @${ECHO} "${PYTHON_SITELIBDIR}/yt/__hg_version__.pyc" >> ${_PYTHONPKGLIST}
+ @${ECHO} "${PYTHON_SITELIBDIR}/yt/__hg_version__.pyo" >> ${_PYTHONPKGLIST}
+
+.include <bsd.port.mk>
diff --git a/math/py-yt/distinfo b/math/py-yt/distinfo
new file mode 100644
index 000000000000..275495331f3c
--- /dev/null
+++ b/math/py-yt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1482742193
+SHA256 (yt-3.3.3.tar.gz) = edf6453927eee311d4b51afacb52cd5504b2b57cc6d3d92dab9c6bfaf6d883df
+SIZE (yt-3.3.3.tar.gz) = 8911901
diff --git a/math/py-yt/files/patch-yt_extern_tqdm___utils.py b/math/py-yt/files/patch-yt_extern_tqdm___utils.py
new file mode 100644
index 000000000000..14e6ffae54e2
--- /dev/null
+++ b/math/py-yt/files/patch-yt_extern_tqdm___utils.py
@@ -0,0 +1,10 @@
+--- yt/extern/tqdm/_utils.py.orig 2016-10-25 16:08:30 UTC
++++ yt/extern/tqdm/_utils.py
+@@ -40,7 +40,7 @@ def _environ_cols_wrapper(): # pragma:
+ _environ_cols = _environ_cols_windows
+ if _environ_cols is None:
+ _environ_cols = _environ_cols_tput
+- if current_os in ['Linux', 'Darwin'] or current_os.startswith('CYGWIN'):
++ if current_os in ['FreeBSD', 'Linux', 'Darwin'] or current_os.startswith('CYGWIN'):
+ _environ_cols = _environ_cols_linux
+ return _environ_cols
diff --git a/math/py-yt/pkg-descr b/math/py-yt/pkg-descr
new file mode 100644
index 000000000000..164d85c3123e
--- /dev/null
+++ b/math/py-yt/pkg-descr
@@ -0,0 +1,7 @@
+yt supports structured, variable-resolution meshes, unstructured meshes,
+and discrete or sampled data such as particles. Focused on driving
+physically-meaningful inquiry, yt has been applied in domains such as
+astrophysics, seismology, nuclear engineering, molecular dynamics, and
+oceanography.
+
+WWW: http://yt-project.org