aboutsummaryrefslogtreecommitdiff
path: root/math/pygist/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2000-09-06 12:19:39 +0000
committerThomas Gellekum <tg@FreeBSD.org>2000-09-06 12:19:39 +0000
commiteb64e250bb93fdffbe0943967b1cad774dd1f8b5 (patch)
tree2523329c55b6ca9bbe90e028a69fa33256459924 /math/pygist/Makefile
parent40b2a920e9edeaa86854292dd09fbb9a57d4c397 (diff)
downloadports-eb64e250bb93fdffbe0943967b1cad774dd1f8b5.tar.gz
ports-eb64e250bb93fdffbe0943967b1cad774dd1f8b5.zip
Notes
Diffstat (limited to 'math/pygist/Makefile')
-rw-r--r--math/pygist/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/math/pygist/Makefile b/math/pygist/Makefile
index ca1a7e02a619..5ab2489878a9 100644
--- a/math/pygist/Makefile
+++ b/math/pygist/Makefile
@@ -18,10 +18,10 @@ MAINTAINER= tg@FreeBSD.org
BUILD_DEPENDS= python:${PORTSDIR}/lang/python \
${LOCALBASE}/lib/yorick/1.4/lib/libgist.a:${PORTSDIR}/lang/yorick \
${NUMPYDIR}/Numeric.py:${PORTSDIR}/math/numpy \
- ${RNGDIR}/Ranf.py:${PORTSDIR}/math/rng
+ ${RNGDIR}/RNG.so:${PORTSDIR}/math/numpy
RUN_DEPENDS= python:${PORTSDIR}/lang/python \
${NUMPYDIR}/Numeric.py:${PORTSDIR}/math/numpy \
- ${RNGDIR}/Ranf.py:${PORTSDIR}/math/rng
+ ${RNGDIR}/RNG.so:${PORTSDIR}/math/numpy
WRKSRC= ${WRKDIR}/${DISTNAME}/Graphics
CONFIGURE_ENV= PREFIX=${PREFIX}
@@ -34,6 +34,13 @@ NUMPYDIR= ${PYTHONSCRIPTDIR}/site-packages/Numeric
RNGDIR= ${PYTHONSCRIPTDIR}/site-packages/RNG
EXAMPLEDIR= ${PREFIX}/share/examples/PyGist
+post-patch:
+.for file in Gist3D/Demo/demo5.py Gist3D/Demo/gistmeshtest.py \
+ Narcisse/Demo/meshtest.py OOG/Demo/eztest.py \
+ OOG/Demo/surftest3d.py OOG/Demo/surftest4d.py
+ ${PERL} -pi -e 's/from Ranf import/from RNG import/' ${WRKSRC}/${file}
+.endfor
+
do-configure:
@(cd ${WRKSRC} && ${CONFIGURE_ENV} python makethis.py)