aboutsummaryrefslogtreecommitdiff
path: root/math/pygist
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1999-05-05 09:48:30 +0000
committerThomas Gellekum <tg@FreeBSD.org>1999-05-05 09:48:30 +0000
commitcdf04c21eead413ab7f7b61e0b216c3c37f144d9 (patch)
tree7c13d0c70c815e08a5b882e3543bd19827a9609c /math/pygist
parent019506bf17ffd063fbd9584fbcbc19349405da44 (diff)
downloadports-cdf04c21eead413ab7f7b61e0b216c3c37f144d9.tar.gz
ports-cdf04c21eead413ab7f7b61e0b216c3c37f144d9.zip
Notes
Diffstat (limited to 'math/pygist')
-rw-r--r--math/pygist/Makefile6
-rw-r--r--math/pygist/distinfo2
-rw-r--r--math/pygist/files/patch-ac11
-rw-r--r--math/pygist/files/patch-ad11
4 files changed, 26 insertions, 4 deletions
diff --git a/math/pygist/Makefile b/math/pygist/Makefile
index 30fc8756c2d1..228fdb849da1 100644
--- a/math/pygist/Makefile
+++ b/math/pygist/Makefile
@@ -3,10 +3,10 @@
# Date created: 30 May 1998
# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.8 1998/11/16 08:54:41 tg Exp $
+# $Id: Makefile,v 1.9 1998/12/29 14:44:49 tg Exp $
#
-DISTNAME= LLNLPython8
+DISTNAME= LLNLDistribution11
PKGNAME= py-gist-1.5
CATEGORIES= math python
MASTER_SITES= ftp://ftp-icf.llnl.gov/pub/python/
@@ -29,7 +29,7 @@ MAKE_FLAGS+= 'OPT=${CFLAGS}'
PYTHONSCRIPTDIR= ${PREFIX}/lib/python1.5
GISTDIR= ${PYTHONSCRIPTDIR}/site-packages/PyGist
-NUMPYDIR= ${PYTHONSCRIPTDIR}/site-packages/NumPy
+NUMPYDIR= ${PYTHONSCRIPTDIR}/site-packages/numerical
RNGDIR= ${PYTHONSCRIPTDIR}/site-packages/RNG
EXAMPLEDIR= ${PREFIX}/share/examples/PyGist
diff --git a/math/pygist/distinfo b/math/pygist/distinfo
index 02dc8bb27c5c..8195abb118e7 100644
--- a/math/pygist/distinfo
+++ b/math/pygist/distinfo
@@ -1 +1 @@
-MD5 (LLNLPython8.tgz) = aa1bcac7b453444aab6aea8882b48a9a
+MD5 (LLNLDistribution11.tgz) = 7ce5043ff3ec5d8202170c4d7892aa0e
diff --git a/math/pygist/files/patch-ac b/math/pygist/files/patch-ac
new file mode 100644
index 000000000000..17ce9a12459d
--- /dev/null
+++ b/math/pygist/files/patch-ac
@@ -0,0 +1,11 @@
+--- Gist/Src/gistCmodule.c.orig Fri Apr 2 02:14:43 1999
++++ Gist/Src/gistCmodule.c Wed May 5 11:19:38 1999
+@@ -72,7 +72,7 @@
+ #endif
+
+ #include "Python.h"
+-#include "arrayobject.h"
++#include "numerical/arrayobject.h"
+ #include "hlevel.h"
+ #ifndef NO_XLIB
+ # include "dispas.h"
diff --git a/math/pygist/files/patch-ad b/math/pygist/files/patch-ad
new file mode 100644
index 000000000000..7e3bf99b7e84
--- /dev/null
+++ b/math/pygist/files/patch-ad
@@ -0,0 +1,11 @@
+--- Arrayfcns/Src/arrayfnsmodule.c.orig Fri Apr 2 02:14:43 1999
++++ Arrayfcns/Src/arrayfnsmodule.c Wed May 5 11:33:13 1999
+@@ -1,7 +1,7 @@
+ /* Copyright (c) 1996, 1997, The Regents of the University of California.
+ * All rights reserved. See Legal.htm for full text and disclaimer. */
+ #include "Python.h"
+-#include "arrayobject.h"
++#include "numerical/arrayobject.h"
+ /*#include "hlevel.h"*/
+ #include <stdio.h>
+ #include <stdlib.h>