aboutsummaryrefslogtreecommitdiff
path: root/math/qrupdate
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2009-08-06 03:38:13 +0000
committerMaho Nakata <maho@FreeBSD.org>2009-08-06 03:38:13 +0000
commit4e9fc479805aa43e7df49064622c6c6b97122f15 (patch)
treed751d1f3da13927c1d7dd1f9066151207c70ee75 /math/qrupdate
parent62110fb0db0a2901ec03a04c37b337d5a28038c5 (diff)
downloadports-4e9fc479805aa43e7df49064622c6c6b97122f15.tar.gz
ports-4e9fc479805aa43e7df49064622c6c6b97122f15.zip
Notes
Diffstat (limited to 'math/qrupdate')
-rw-r--r--math/qrupdate/Makefile36
-rw-r--r--math/qrupdate/distinfo3
-rw-r--r--math/qrupdate/files/patch-Makeconf22
-rw-r--r--math/qrupdate/files/patch-Makefile37
-rw-r--r--math/qrupdate/files/patch-src-Makefile14
-rw-r--r--math/qrupdate/pkg-descr4
-rw-r--r--math/qrupdate/pkg-plist4
7 files changed, 120 insertions, 0 deletions
diff --git a/math/qrupdate/Makefile b/math/qrupdate/Makefile
new file mode 100644
index 000000000000..f89d271e4e34
--- /dev/null
+++ b/math/qrupdate/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: qrupdate
+# Date created: 4 August 2009
+# Whom: Robert Jenssen
+#
+# $FreeBSD$
+#
+
+PORTNAME= qrupdate
+PORTVERSION= 1.0.1
+CATEGORIES= math
+MASTER_SITES= http://downloads.sourceforge.net/project/qrupdate/qrupdate/1.0/ \
+ http://transact.dl.sourceforge.net/project/qrupdate/qrupdate/1.0/
+
+MAINTAINER= maho@FreeBSD.org
+COMMENT= Fortran library for fast updates of QR and Cholesky decomposition
+
+FETCH_ARGS= -p
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "sparc64"
+PICFLAG?= -fPIC
+.else
+PICFLAG?= -fpic
+.endif
+
+USE_FORTRAN= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+pre-build:
+ @${REINPLACE_CMD} -e 's+%%FC%%+${FC}+g ; s+%%FFLAGS%%+${FFLAGS}+g ; \
+ s+%%PICFLAG%%+${PICFLAG}+g ; ' \
+ ${WRKSRC}/Makeconf
+
+.include <bsd.port.post.mk>
diff --git a/math/qrupdate/distinfo b/math/qrupdate/distinfo
new file mode 100644
index 000000000000..776f020b2c5d
--- /dev/null
+++ b/math/qrupdate/distinfo
@@ -0,0 +1,3 @@
+MD5 (qrupdate-1.0.1.tar.gz) = 73d87b081e6fb89c9dc5b0ef0773b4dc
+SHA256 (qrupdate-1.0.1.tar.gz) = 45ba0b4e6b15236a219b5b380e15fc9acfe6760a9ca5e53484de9b534969ba0d
+SIZE (qrupdate-1.0.1.tar.gz) = 42179
diff --git a/math/qrupdate/files/patch-Makeconf b/math/qrupdate/files/patch-Makeconf
new file mode 100644
index 000000000000..72b60f78b524
--- /dev/null
+++ b/math/qrupdate/files/patch-Makeconf
@@ -0,0 +1,22 @@
+--- Makeconf.orig 2009-03-11 15:08:32.000000000 +0900
++++ Makeconf 2009-08-06 12:30:47.000000000 +0900
+@@ -1,14 +1,14 @@
+ # set this to your compiler's executable name (e.g. gfortran, g77)
+-FC=gfortran
++FC=%%FC%%
+ # requested flags
+-FFLAGS=-fimplicit-none -O3 -funroll-loops
++FFLAGS=%%FFLAGS%%
+ # set if you need shared library
+-FPICFLAGS=-fPIC
++FPICFLAGS=%%PICFLAG%%
+
+ # BLAS library (only required for tests)
+-BLAS=-lblas
++#BLAS=-L/usr/local/lib -lblas
+ # LAPACK library (only required for tests)
+-LAPACK=-llapack
++#LAPACK=-llapack
+
+ # Library version
+ VERSION=1.0
diff --git a/math/qrupdate/files/patch-Makefile b/math/qrupdate/files/patch-Makefile
new file mode 100644
index 000000000000..b3ad7c4c67d9
--- /dev/null
+++ b/math/qrupdate/files/patch-Makefile
@@ -0,0 +1,37 @@
+--- Makefile.orig 2009-02-06 20:12:00.000000000 +1100
++++ Makefile 2009-08-06 01:20:12.000000000 +1000
+@@ -21,6 +21,8 @@
+
+ include Makeconf
+
++all: solib
++
+ help:
+ @echo
+ @echo "The following targets are available:"
+@@ -34,20 +36,20 @@
+ lib:
+ make -C src/ lib
+ solib:
+- make -C src/ solib
++ gmake -C src/ solib
+ test: lib
+ make -C test/
+
+ clean:
+ rm -f libqrupdate.a libqrupdate.so
+- make -C src/ clean
+- make -C test/ clean
++ gmake -C src/ clean
++ gmake -C test/ clean
+
+ install:
+- make -C src/ install
++ gmake -C src/ install
+
+ install-shlib:
+- make -C src/ install-shlib
++ gmake -C src/ install-shlib
+
+ install-staticlib:
+ make -C src/ install-staticlib
diff --git a/math/qrupdate/files/patch-src-Makefile b/math/qrupdate/files/patch-src-Makefile
new file mode 100644
index 000000000000..a57f0d780a84
--- /dev/null
+++ b/math/qrupdate/files/patch-src-Makefile
@@ -0,0 +1,14 @@
+--- src/Makefile.orig 2009-08-06 01:21:58.000000000 +1000
++++ src/Makefile 2009-08-06 01:28:32.000000000 +1000
+@@ -52,9 +52,9 @@
+ install: install-shlib install-staticlib
+
+ install-shlib: ../libqrupdate.so
+- install -D -m644 ../libqrupdate.so $(PREFIX)/lib/libqrupdate.so.$(VERSION)
++ install -s ../libqrupdate.so $(PREFIX)/lib/libqrupdate.so.$(VERSION)
+ ln -s libqrupdate.so.$(VERSION) $(PREFIX)/lib/libqrupdate.so.$(MAJOR)
+ ln -s libqrupdate.so.$(VERSION) $(PREFIX)/lib/libqrupdate.so
+
+ install-staticlib: ../libqrupdate.a
+- install -D -m644 ../libqrupdate.a $(PREFIX)/lib/libqrupdate.a
++ install -s ../libqrupdate.a $(PREFIX)/lib/libqrupdate.a
diff --git a/math/qrupdate/pkg-descr b/math/qrupdate/pkg-descr
new file mode 100644
index 000000000000..a30f3918b7bc
--- /dev/null
+++ b/math/qrupdate/pkg-descr
@@ -0,0 +1,4 @@
+qrupdate is a Fortran library for fast updates of QR and Cholesky
+decomposition. It was originally part of GNU-Octave.
+
+WWW: http://qrupdate.sourceforge.net/
diff --git a/math/qrupdate/pkg-plist b/math/qrupdate/pkg-plist
new file mode 100644
index 000000000000..50cb181f955b
--- /dev/null
+++ b/math/qrupdate/pkg-plist
@@ -0,0 +1,4 @@
+lib/libqrupdate.so.1.0
+lib/libqrupdate.so.1
+lib/libqrupdate.so
+lib/libqrupdate.a