aboutsummaryrefslogtreecommitdiff
path: root/math/qtiplot
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-07-27 11:03:38 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-07-27 11:03:38 +0000
commit52e8b487f6dc73b0d0baafc955c59e83ab33c41a (patch)
tree167ee4bd8c4cd737246cf4e2c40f36e42042084e /math/qtiplot
parentdbe27c5fd4471209e8b77eecbae08f3a2ad57040 (diff)
downloadports-52e8b487f6dc73b0d0baafc955c59e83ab33c41a.tar.gz
ports-52e8b487f6dc73b0d0baafc955c59e83ab33c41a.zip
Notes
Diffstat (limited to 'math/qtiplot')
-rw-r--r--math/qtiplot/Makefile25
1 files changed, 14 insertions, 11 deletions
diff --git a/math/qtiplot/Makefile b/math/qtiplot/Makefile
index 38c2567415c1..63628143b351 100644
--- a/math/qtiplot/Makefile
+++ b/math/qtiplot/Makefile
@@ -1,6 +1,6 @@
# New ports collection makefile for: qtiplot
-# Date created: 9 May 2005
-# Whom: Jie Gao <gaoj@cpsc.ucalgary.ca>
+# Date created: 2005-05-09
+# Whom: Jie Gao <gaoj@cpsc.ucalgary.ca>
#
# $FreeBSD$
#
@@ -37,14 +37,17 @@ DESKTOP_ENTRIES="QtiPlot" "Data analysis and plotting" \
"${DATADIR}/qtiplot.png" \
"qtiplot" "" false
-OPTIONS= DOCS "Install the QtiPlot Handbook" on \
- PYTHON "Python scripting support" on
+OPTIONS_DEFINE= DOCS PYTHON
+OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
+
+DOCS_DESC= Install the QtiPlot Handbook
+PYTHON_DESC= Python scripting support
STRIP_FILES= bin/qtiplot share/qtiplot/fitPlugins/*.so.1.0.0
.include <bsd.port.options.mk>
-.if defined(WITH_PYTHON)
+.if ${PORT_OPTIONS:MPYTHON}
USE_PYTHON= yes
BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/PyQt4/QtGui.so:${PORTSDIR}/x11-toolkits/py-qt4-gui
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/PyQt4/QtGui.so:${PORTSDIR}/x11-toolkits/py-qt4-gui
@@ -55,12 +58,12 @@ CONFIGURE_ENV+= PYTHON_INCLUDEDIR=${PYTHON_INCLUDEDIR} \
PLIST_SUB+= PYTHON="@comment "
.endif
-.if !defined(WITHOUT_DOCS)
+.if ${PORT_OPTIONS:MDOCS}
RUN_DEPENDS+= qtiplot-doc>=0:${PORTSDIR}/math/qtiplot-doc
USE_QT4+= assistant-adp_run
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_QT4+= linguist_build
PLIST_SUB+= NLS=""
.else
@@ -73,7 +76,7 @@ post-extract:
@${CP} ${FILESDIR}/build.conf ${WRKSRC}
post-patch:
-.if defined(WITH_PYTHON)
+.if ${PORT_OPTIONS:MPYTHON}
@${REINPLACE_CMD} -e \
'/^sys.path.append/s|"\."|"${DATADIR}"|' \
${WRKSRC}/${PORTNAME}/qtiplotrc.py
@@ -95,14 +98,14 @@ post-patch:
"/^CONFIG.*release/s|release|debug|" \
${WRKSRC}/build.conf
.endif
-.if defined(WITHOUT_NLS)
+.if !${PORT_OPTIONS:MNLS}
@${REINPLACE_CMD} -e \
"/INSTALLS.*translations/d" \
${WRKSRC}/${PORTNAME}/qtiplot.pro
.endif
do-configure:
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
@(cd ${WRKSRC}/qtiplot && ${LOCALBASE}/bin/lrelease-qt4 -compress qtiplot.pro)
.endif
@(cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS} ${QMAKE_ARGS} )
@@ -110,7 +113,7 @@ do-configure:
post-install:
${STRIP_CMD} ${STRIP_FILES:S,^,${PREFIX}/,}
${INSTALL_DATA} ${WRKSRC}/qtiplot_logo.png ${DATADIR}/qtiplot.png
-.if defined(WITH_PYTHON)
+.if ${PORT_OPTIONS:MPYTHON}
.for s in qtiplotrc.py qtiUtil.py
@(cd ${WRKSRC}/qtiplot && ${PYTHON_CMD} -c "import py_compile; py_compile.compile('${s}')")
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}/${s}c ${DATADIR}/${s}c