aboutsummaryrefslogtreecommitdiff
path: root/math/qtiplot
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-06 07:50:41 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-06 07:50:41 +0000
commite08f44456daf541032e565cbb085280840863dc3 (patch)
tree5297c1ee2b970f7190ebb064bfe0e5d0c9c3f1c6 /math/qtiplot
parent72ca1466781bef94c18a914bfd5e32a50f9a4995 (diff)
downloadports-e08f44456daf541032e565cbb085280840863dc3.tar.gz
ports-e08f44456daf541032e565cbb085280840863dc3.zip
Notes
Diffstat (limited to 'math/qtiplot')
-rw-r--r--math/qtiplot/Makefile9
-rw-r--r--math/qtiplot/distinfo6
-rw-r--r--math/qtiplot/files/patch-qtiplot__qtiplot.pro2
3 files changed, 7 insertions, 10 deletions
diff --git a/math/qtiplot/Makefile b/math/qtiplot/Makefile
index fb9ac6b9e7c6..a21be9699705 100644
--- a/math/qtiplot/Makefile
+++ b/math/qtiplot/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= qtiplot
-DISTVERSION= 0.9.6.2
-PORTREVISION= 2
+DISTVERSION= 0.9.7
CATEGORIES= math science
MASTER_SITES= BERLIOS http://soft.proindependent.com/src/
@@ -15,7 +14,6 @@ MAINTAINER= makc@issp.ac.ru
COMMENT= An Origin clone for data analysis and scientific plotting
BUILD_DEPENDS= ${LOCALBASE}/lib/libmuparser.a:${PORTSDIR}/math/muparser
-
LIB_DEPENDS= gsl.12:${PORTSDIR}/math/gsl \
qwtplot3d-qt4:${PORTSDIR}/math/qwtplot3d-qt4 \
qwt.5:${PORTSDIR}/x11-toolkits/qwt5
@@ -25,7 +23,7 @@ USE_GMAKE= yes
USE_QT_VER= 4
QT_COMPONENTS= gui moc_build qmake_build opengl svg qt3support network assistantclient
HAS_CONFIGURE= yes
-QMAKE_ARGS+= -unix -recursive LOCALBASE=${LOCALBASE}
+QMAKE_ARGS+= -unix -recursive LOCALBASE=${LOCALBASE} PYTHON_CMD=${PYTHON_CMD}
USE_DOS2UNIX= *.pro
MAN1= qtiplot.1
@@ -57,8 +55,7 @@ RUN_DEPENDS+= qtiplot-doc>=0:${PORTSDIR}/math/qtiplot-doc
.endif
.if !defined(WITHOUT_NLS)
-#QT_COMPONENTS+= linguist
-BUILD_DEPENDS+= ${LOCALBASE}/bin/lupdate-qt4:${PORTSDIR}/devel/qt4-linguist
+QT_COMPONENTS+= linguist_build
PLIST_SUB+= NLS=""
.else
PLIST_SUB+= NLS="@comment "
diff --git a/math/qtiplot/distinfo b/math/qtiplot/distinfo
index f48ac44c1131..fc3969716434 100644
--- a/math/qtiplot/distinfo
+++ b/math/qtiplot/distinfo
@@ -1,3 +1,3 @@
-MD5 (qtiplot-0.9.6.2.tar.bz2) = 6af2b27f678e8215299f3f4a424b11fe
-SHA256 (qtiplot-0.9.6.2.tar.bz2) = 16f624eb6cd5e4d153adcbc1b84598a9fc5028cad4c9d34022839c2805a8dcbb
-SIZE (qtiplot-0.9.6.2.tar.bz2) = 6482625
+MD5 (qtiplot-0.9.7.tar.bz2) = 1a5c13bcaa81b15c2d152f2d47c04a5f
+SHA256 (qtiplot-0.9.7.tar.bz2) = e5e7a5d9a8010245041a38f2c20be6dd254832b588be73ed3718e063c201a4c1
+SIZE (qtiplot-0.9.7.tar.bz2) = 6446993
diff --git a/math/qtiplot/files/patch-qtiplot__qtiplot.pro b/math/qtiplot/files/patch-qtiplot__qtiplot.pro
index d390ab26964c..b3236da78019 100644
--- a/math/qtiplot/files/patch-qtiplot__qtiplot.pro
+++ b/math/qtiplot/files/patch-qtiplot__qtiplot.pro
@@ -55,7 +55,7 @@
LIBS += -lm
system(mkdir -p $${SIP_DIR})
- system($$system(python python-sipcmd.py) -c $${SIP_DIR} src/qti.sip)
-+ SIPCMD = $$(PYTHON_VERSION) python-sipcmd.py
++ SIPCMD = $$PYTHON_CMD python-sipcmd.py
+ system($$system($$SIPCMD) -c $${SIP_DIR} src/qti.sip)
}