aboutsummaryrefslogtreecommitdiff
path: root/math/qtoctave
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-12-21 16:11:53 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-12-21 16:11:53 +0000
commit4c62bb25eee6f900f2bb872d6947e4498c0d9010 (patch)
tree9b262dbe0225c57daa77d3958b9cdf9d8941cbd0 /math/qtoctave
parent99a563929c4d91ea4717c85822275a19fdb418b1 (diff)
- Update to 0.10.1
- Strip Makefile header - Mark MAKE_JOBS_SAFE
Notes
Notes: svn path=/head/; revision=309366
Diffstat (limited to 'math/qtoctave')
-rw-r--r--math/qtoctave/Makefile20
-rw-r--r--math/qtoctave/distinfo4
-rw-r--r--math/qtoctave/files/patch-CMakeLists.txt16
-rw-r--r--math/qtoctave/files/patch-qtinfo__CMakeLists.txt32
-rw-r--r--math/qtoctave/files/patch-qtjs__CMakeLists.txt15
-rw-r--r--math/qtoctave/files/patch-qtoctave__src__scripts_octave__qtinfo.m14
-rw-r--r--math/qtoctave/files/patch-simple_rcs__CMakeLists.txt13
-rw-r--r--math/qtoctave/pkg-plist64
8 files changed, 102 insertions, 76 deletions
diff --git a/math/qtoctave/Makefile b/math/qtoctave/Makefile
index dc71ca98dda6..e93bd7437311 100644
--- a/math/qtoctave/Makefile
+++ b/math/qtoctave/Makefile
@@ -1,25 +1,25 @@
-# New ports collection makefile for: qtoctave
-# Date created: 2009-02-18
-# Whom: Max Brazhnikov <makc@issp.ac.ru>
-#
# $FreeBSD$
-#
PORTNAME= qtoctave
-PORTVERSION= 0.9.1
-PORTREVISION= 1
+PORTVERSION= 0.10.1
CATEGORIES= math
-MASTER_SITES= http://forja.rediris.es/frs/download.php/1760/
+MASTER_SITES= http://forja.rediris.es/frs/download.php/2054/
MAINTAINER= makc@FreeBSD.org
COMMENT= Qt4 frontend for Octave
RUN_DEPENDS= octave:${PORTSDIR}/math/octave
-USE_BZIP2= yes
USE_QT4= designer gui network script svg xml \
- qmake_build moc_build rcc_build uic_build
+ qmake_build moc_build rcc_build uic_build \
+ linguist_build
USE_CMAKE= yes
CMAKE_ARGS+= -DWITH_UseRPMTools:Bool=Off
+MAKE_JOBS_SAFE= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e '/COMMAND "lrelease"/s,lrelease,$${QT_LRELEASE_EXECUTABLE},' \
+ ${WRKSRC}/qtoctave/src/CMakeLists.txt
+ ${RM} ${WRKSRC}/qtoctave/src/scripts_octave/qtinfo.m.orig
.include <bsd.port.mk>
diff --git a/math/qtoctave/distinfo b/math/qtoctave/distinfo
index 83813791a4e4..d5e0e9607cb6 100644
--- a/math/qtoctave/distinfo
+++ b/math/qtoctave/distinfo
@@ -1,2 +1,2 @@
-SHA256 (qtoctave-0.9.1.tar.bz2) = dd54c1dda166811e1ab32043211e37b803135b01d5f7d9101e85300ea9cfc986
-SIZE (qtoctave-0.9.1.tar.bz2) = 3335725
+SHA256 (qtoctave-0.10.1.tar.gz) = 4abd367924964887ea691f93c2c8ec90dcc64eb22827893dfb506ae43331b732
+SIZE (qtoctave-0.10.1.tar.gz) = 4215812
diff --git a/math/qtoctave/files/patch-CMakeLists.txt b/math/qtoctave/files/patch-CMakeLists.txt
deleted file mode 100644
index d53962ac2901..000000000000
--- a/math/qtoctave/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,16 +0,0 @@
---- ./CMakeLists.txt.orig 2010-01-25 16:19:48.000000000 +0300
-+++ ./CMakeLists.txt 2010-11-28 19:09:57.665396912 +0300
-@@ -28,13 +28,6 @@
-
- include(UseQt4)
-
--if( NOT ${QT_VERSION_MAJOR} EQUAL 4 OR NOT ${QT_VERSION_MINOR} EQUAL 6 )
-- MESSAGE (FATAL_ERROR
-- "Qt version 4.6 required.\n"
-- "Qt version installed is: ${QT_VERSION_MAJOR}.${QT_VERSION_MINOR}\n"
-- "Please install required version.\n"
-- )
--endif( NOT ${QT_VERSION_MAJOR} EQUAL 4 OR NOT ${QT_VERSION_MINOR} EQUAL 6 )
-
- add_subdirectory (qtoctave_pkg/src)
- add_subdirectory (xmlwidget/qt4)
diff --git a/math/qtoctave/files/patch-qtinfo__CMakeLists.txt b/math/qtoctave/files/patch-qtinfo__CMakeLists.txt
deleted file mode 100644
index 21a284ac78dc..000000000000
--- a/math/qtoctave/files/patch-qtinfo__CMakeLists.txt
+++ /dev/null
@@ -1,32 +0,0 @@
---- ./qtinfo/CMakeLists.txt.orig 2010-01-25 16:19:51.000000000 +0300
-+++ ./qtinfo/CMakeLists.txt 2010-11-28 19:09:57.667465357 +0300
-@@ -25,17 +25,17 @@
- # run rcc on these files:
- QT4_ADD_RESOURCES ( qtinfo_qrc_sources ${qtinfo_qrc} )
-
--add_executable(qtinfo
-+add_executable(qtoctave_info
- ${qtinfo_sources} ${qtinfo_moc_sources} ${qtinfo_ui_headers} ${qtinfo_moc_headers} ${qtinfo_qrc_sources}
- )
-
--SET_TARGET_PROPERTIES(qtinfo
-+SET_TARGET_PROPERTIES(qtoctave_info
- PROPERTIES INSTALL_RPATH ":usr/lib"
- BUILD_WITH_INSTALL_RPATH true
- INSTALL_RPATH_USE_LINK_PATH true
- )
-
--TARGET_LINK_LIBRARIES(qtinfo
-+TARGET_LINK_LIBRARIES(qtoctave_info
- ${Qt4_LIBRARIES}
- ${QT_QTCORE_LIBRARY}
- ${QT_QTGUI_LIBRARY}
-@@ -43,7 +43,7 @@
-
-
- install (
-- TARGETS qtinfo
-+ TARGETS qtoctave_info
- RUNTIME DESTINATION bin
- )
-
diff --git a/math/qtoctave/files/patch-qtjs__CMakeLists.txt b/math/qtoctave/files/patch-qtjs__CMakeLists.txt
new file mode 100644
index 000000000000..7da80947bc6f
--- /dev/null
+++ b/math/qtoctave/files/patch-qtjs__CMakeLists.txt
@@ -0,0 +1,15 @@
+--- ./qtjs/CMakeLists.txt.orig 2011-01-06 21:48:05.000000000 +0000
++++ ./qtjs/CMakeLists.txt 2012-12-14 22:22:22.999032717 +0000
+@@ -2,10 +2,5 @@
+
+ install(
+ DIRECTORY doc
+- DESTINATION share/doc/qtoctave-utils/qtjs
++ DESTINATION share/doc/qtoctave/utils/qtjs
+ )
+-
+-install(
+- FILES "instalar.txt" "install.txt"
+- DESTINATION share/doc/qtoctave-utils/qtjs
+-)
+\ No newline at end of file
diff --git a/math/qtoctave/files/patch-qtoctave__src__scripts_octave__qtinfo.m b/math/qtoctave/files/patch-qtoctave__src__scripts_octave__qtinfo.m
index 245b1268b074..6826481cd076 100644
--- a/math/qtoctave/files/patch-qtoctave__src__scripts_octave__qtinfo.m
+++ b/math/qtoctave/files/patch-qtoctave__src__scripts_octave__qtinfo.m
@@ -1,11 +1,9 @@
---- ./qtoctave/src/scripts_octave/qtinfo.m.orig 2010-01-25 16:19:50.000000000 +0300
-+++ ./qtoctave/src/scripts_octave/qtinfo.m 2010-11-28 19:09:57.670497066 +0300
+--- ./qtoctave/src/scripts_octave/qtinfo.m.orig 2011-01-06 21:48:08.000000000 +0000
++++ ./qtoctave/src/scripts_octave/qtinfo.m 2012-12-15 22:23:03.542899718 +0000
@@ -1,5 +1,5 @@
function qtinfo()
-- command=sprintf("qtinfo %s > /dev/null", info_file);
-+ command=sprintf("qtoctave_info %s > /dev/null", info_file);
+ command=sprintf("qtoctave-info-reader %s > /dev/null", info_file);
printf("Starting info: %s\n", command);
- system(command, 1, "async");
--endfunction
-\ No newline at end of file
-+endfunction
+- system(command, 1, "async");
++ system(command, "async");
+ endfunction
diff --git a/math/qtoctave/files/patch-simple_rcs__CMakeLists.txt b/math/qtoctave/files/patch-simple_rcs__CMakeLists.txt
new file mode 100644
index 000000000000..4800baa9981d
--- /dev/null
+++ b/math/qtoctave/files/patch-simple_rcs__CMakeLists.txt
@@ -0,0 +1,13 @@
+--- ./simple_rcs/CMakeLists.txt.orig 2011-01-06 21:48:06.000000000 +0000
++++ ./simple_rcs/CMakeLists.txt 2012-12-14 22:49:32.658033064 +0000
+@@ -14,9 +14,3 @@
+ #ADD_DEFINITIONS(-DUSER_CONFIG)
+
+ add_subdirectory (src)
+-
+-install(
+- DIRECTORY design
+- DESTINATION share/doc/qtoctave-utils/simple_rcs
+- PATTERN ".svn" EXCLUDE
+-)
+\ No newline at end of file
diff --git a/math/qtoctave/pkg-plist b/math/qtoctave/pkg-plist
index b3cff5d94e8c..da68d79e0ffc 100644
--- a/math/qtoctave/pkg-plist
+++ b/math/qtoctave/pkg-plist
@@ -1,7 +1,7 @@
bin/easy_plot
bin/qtjs
bin/qtoctave
-bin/qtoctave_info
+bin/qtoctave-info-reader
bin/qtoctave_pkg
bin/simplercs
bin/xmlwidget
@@ -10,6 +10,39 @@ share/applications/qtoctave.desktop
%%DOCSDIR%%/qtoctave_doc/index.html
%%DOCSDIR%%/qtoctave_doc/menu_integrate_easy.png
%%DOCSDIR%%/qtoctave_doc/menus.html
+%%DOCSDIR%%/utils/qtjs/doc/english/building guis with Qt Designer and qtjs.odt
+%%DOCSDIR%%/utils/qtjs/doc/english/examples/readme.txt
+%%DOCSDIR%%/utils/qtjs/doc/english/examples/run_example.sh
+%%DOCSDIR%%/utils/qtjs/doc/english/examples/sombrero.js
+%%DOCSDIR%%/utils/qtjs/doc/english/examples/sombrero.ui
+%%DOCSDIR%%/utils/qtjs/doc/english/examples/sombrero2.js
+%%DOCSDIR%%/utils/qtjs/doc/english/examples/sombrero2.ui
+%%DOCSDIR%%/utils/qtjs/doc/english/examples/sombrero3.js
+%%DOCSDIR%%/utils/qtjs/doc/english/examples/sombrero3.ui
+%%DOCSDIR%%/utils/qtjs/doc/english/examples/sombrero4.js
+%%DOCSDIR%%/utils/qtjs/doc/english/examples/sombrero4.ui
+%%DOCSDIR%%/utils/qtjs/doc/espanol/ejemplos/ejecutar_ejemplo.sh
+%%DOCSDIR%%/utils/qtjs/doc/espanol/ejemplos/leeme.txt
+%%DOCSDIR%%/utils/qtjs/doc/espanol/ejemplos/sombrero/ejecutar_ventana.m
+%%DOCSDIR%%/utils/qtjs/doc/espanol/ejemplos/sombrero/sombrero.js
+%%DOCSDIR%%/utils/qtjs/doc/espanol/ejemplos/sombrero/sombrero.ui
+%%DOCSDIR%%/utils/qtjs/doc/espanol/ejemplos/sombrero2.js
+%%DOCSDIR%%/utils/qtjs/doc/espanol/ejemplos/sombrero2.ui
+%%DOCSDIR%%/utils/qtjs/doc/espanol/ejemplos/sombrero3.js
+%%DOCSDIR%%/utils/qtjs/doc/espanol/ejemplos/sombrero3.ui
+%%DOCSDIR%%/utils/qtjs/doc/espanol/ejemplos/sombrero4.js
+%%DOCSDIR%%/utils/qtjs/doc/espanol/ejemplos/sombrero4.ui
+%%DOCSDIR%%/utils/qtjs/doc/espanol/guis con Qt Designer y qtjs.odt
+%%DOCSDIR%%/utils/qtjs/doc/espanol/images/combobox.png
+%%DOCSDIR%%/utils/qtjs/doc/espanol/images/designer_label.png
+%%DOCSDIR%%/utils/qtjs/doc/espanol/images/designer_new_widget.png
+%%DOCSDIR%%/utils/qtjs/doc/espanol/images/designer_proyecto_vacio.png
+%%DOCSDIR%%/utils/qtjs/doc/espanol/images/designer_ventana_completa.png
+%%DOCSDIR%%/utils/qtjs/doc/espanol/images/lineEdit.png
+%%DOCSDIR%%/utils/qtjs/doc/espanol/images/octave_sombrero.png
+%%DOCSDIR%%/utils/qtjs/doc/espanol/images/qtdesigner.png
+%%DOCSDIR%%/utils/qtjs/doc/espanol/images/qtjs_sombrero.png
+%%DOCSDIR%%/utils/qtjs/doc/espanol/images/slider.png
share/icons/hicolor/64x64/apps/qtoctave.png
%%DATADIR%%/config.rc
%%DATADIR%%/images/back.png
@@ -52,11 +85,11 @@ share/icons/hicolor/64x64/apps/qtoctave.png
%%DATADIR%%/images/undo.png
%%DATADIR%%/images/up.png
%%DATADIR%%/images/xedit.png
-%%DATADIR%%/lang/qtoctave.qph
-%%DATADIR%%/lang/qtoctave_cs.ts
-%%DATADIR%%/lang/qtoctave_es.ts
+%%DATADIR%%/lang/qtoctave.qm
+%%DATADIR%%/lang/qtoctave_cs.qm
+%%DATADIR%%/lang/qtoctave_es.qm
%%DATADIR%%/lang/qtoctave_gl_ES.qm
-%%DATADIR%%/lang/qtoctave_gl_ES.ts
+%%DATADIR%%/lang/qtoctave_pl.qm
%%DATADIR%%/menus/Analysis/Integrate function/Easy integrate.menu
%%DATADIR%%/menus/Analysis/Integrate function/Integrate function.menu
%%DATADIR%%/menus/Analysis/Integrate function/integrate_simpson.menu
@@ -68,13 +101,11 @@ share/icons/hicolor/64x64/apps/qtoctave.png
%%DATADIR%%/menus/Equations/equation_by_bisection.menu
%%DATADIR%%/menus/Equations/linear_equation.menu
%%DATADIR%%/menus/Equations/nonlinear_equation.menu
-%%DATADIR%%/menus/Help/octave_help.menu
%%DATADIR%%/menus/Plot/Export/eps.menu
%%DATADIR%%/menus/Plot/Export/inkscape.menu
%%DATADIR%%/menus/Plot/Export/pdf.menu
%%DATADIR%%/menus/Plot/Export/png.menu
%%DATADIR%%/menus/menus.ts
-%%DATADIR%%/octave.xml
%%DATADIR%%/scripts/clc.m
%%DATADIR%%/scripts/diary.m
%%DATADIR%%/scripts_octave/_ide_completion_matches.m
@@ -82,10 +113,14 @@ share/icons/hicolor/64x64/apps/qtoctave.png
%%DATADIR%%/scripts_octave/_ide_reload_variables_list.m
%%DATADIR%%/scripts_octave/maxima.m
%%DATADIR%%/scripts_octave/qtinfo.m
-%%DATADIR%%/scripts_octave/qtinfo.m.orig
%%DATADIR%%/scripts_octave/svgcanvas_delete_on_load.m
%%DATADIR%%/scripts_octave/svgcanvasload.m
%%DATADIR%%/scripts_octave/svgcanvassave.m
+%%DATADIR%%/syntax_files/cpp.xml
+%%DATADIR%%/syntax_files/h.xml
+%%DATADIR%%/syntax_files/m.xml
+%%DATADIR%%/syntax_files/sh.xml
+@dirrm %%DATADIR%%/syntax_files
@dirrm %%DATADIR%%/scripts_octave
@dirrm %%DATADIR%%/scripts
@dirrm %%DATADIR%%/menus/Statistics
@@ -106,8 +141,21 @@ share/icons/hicolor/64x64/apps/qtoctave.png
@dirrmtry share/icons/hicolor/64x64
@dirrmtry share/icons/hicolor
@dirrmtry share/icons
+@dirrm %%DOCSDIR%%/utils/qtjs/doc/images
+@dirrm %%DOCSDIR%%/utils/qtjs/doc/espanol/images
+@dirrm %%DOCSDIR%%/utils/qtjs/doc/espanol/ejemplos/sombrero
+@dirrm %%DOCSDIR%%/utils/qtjs/doc/espanol/ejemplos
+@dirrm %%DOCSDIR%%/utils/qtjs/doc/espanol
+@dirrm %%DOCSDIR%%/utils/qtjs/doc/english/examples
+@dirrm %%DOCSDIR%%/utils/qtjs/doc/english
+@dirrm %%DOCSDIR%%/utils/qtjs/doc/ejemplos/sombrero
+@dirrm %%DOCSDIR%%/utils/qtjs/doc/ejemplos
+@dirrm %%DOCSDIR%%/utils/qtjs/doc
+@dirrm %%DOCSDIR%%/utils/qtjs
+@dirrm %%DOCSDIR%%/utils
@dirrm %%DOCSDIR%%/qtoctave_doc
@dirrm %%DOCSDIR%%
@dirrmtry share/applications
+@exec mkdir -p %D/%%DATADIR%%/menus/Help
@exec mkdir -p %D/%%DATADIR%%/menus/Matrix
@exec mkdir -p %D/%%DATADIR%%/menus/Statistics