aboutsummaryrefslogtreecommitdiff
path: root/math/qwtplot3d-qt4/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-04-17 18:51:09 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-04-17 18:51:09 +0000
commit1b0d07aaf33cb54468a0683aceaeef669748df0a (patch)
treea1b12837623ba3da87406f2d136262c030b1ee08 /math/qwtplot3d-qt4/Makefile
parent1514ae323815f626efada825028e87da7f2fcf4d (diff)
downloadports-1b0d07aaf33cb54468a0683aceaeef669748df0a.tar.gz
ports-1b0d07aaf33cb54468a0683aceaeef669748df0a.zip
Notes
Diffstat (limited to 'math/qwtplot3d-qt4/Makefile')
-rw-r--r--math/qwtplot3d-qt4/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/math/qwtplot3d-qt4/Makefile b/math/qwtplot3d-qt4/Makefile
index 525a1f5f4643..98fa5be3c3cb 100644
--- a/math/qwtplot3d-qt4/Makefile
+++ b/math/qwtplot3d-qt4/Makefile
@@ -8,6 +8,7 @@
PORTNAME= qwtplot3d
PORTVERSION= 0.2.6
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,11 +20,9 @@ COMMENT= A 3D plotting widget for scientific data and mathematical expressions
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
USE_QT_VER= 3
-USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-MAKE_ENV= QTDIR=${QT_PREFIX} \
- MOC=${MOC}
-INSTALLS_SHLIB= yes
+MAKE_ENV= QTDIR=${QT_PREFIX}
+USE_LDCONFIG= yes
pre-build:
@cd ${WRKSRC}; qmake -spec ${LOCALBASE}/share/qt/mkspecs/freebsd-g++ ${PORTNAME}.pro
@@ -34,12 +33,8 @@ do-install:
${LN} -fs ${PREFIX}/lib/libqwtplot3d.so.${PORTVERSION} ${PREFIX}/lib/libqwtplot3d.so.0
${LN} -fs ${PREFIX}/lib/libqwtplot3d.so.${PORTVERSION} ${PREFIX}/lib/libqwtplot3d.so
.if !defined(NOPORTDOCS)
- @${MKDIR} ${EXAMPLESDIR}
- ${CP} -R ${WRKSRC}/examples/ ${EXAMPLESDIR}
- @${FIND} ${EXAMPLESDIR} ! -type d | \
- ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
- @${FIND} ${EXAMPLESDIR} -type d | ${SORT} -r | \
- ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+ ${MKDIR} ${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
.endif
.include <bsd.port.mk>