aboutsummaryrefslogtreecommitdiff
path: root/math/qwtplot3d-qt4
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-06-15 09:42:02 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-06-15 09:42:02 +0000
commitd82a36e6ac6c9ac970b7528445b16191039188c9 (patch)
treef92bdcb9d795081bc040fb88c91ed16317464c68 /math/qwtplot3d-qt4
parentdd915808eee888870e732a3f44505aad204edd7c (diff)
downloadports-d82a36e6ac6c9ac970b7528445b16191039188c9.tar.gz
ports-d82a36e6ac6c9ac970b7528445b16191039188c9.zip
Notes
Diffstat (limited to 'math/qwtplot3d-qt4')
-rw-r--r--math/qwtplot3d-qt4/Makefile51
-rw-r--r--math/qwtplot3d-qt4/files/patch-qwtplot3d.pro11
-rw-r--r--math/qwtplot3d-qt4/pkg-descr26
-rw-r--r--math/qwtplot3d-qt4/pkg-plist147
4 files changed, 73 insertions, 162 deletions
diff --git a/math/qwtplot3d-qt4/Makefile b/math/qwtplot3d-qt4/Makefile
index 2e4e38ab3f28..792e80c87663 100644
--- a/math/qwtplot3d-qt4/Makefile
+++ b/math/qwtplot3d-qt4/Makefile
@@ -1,42 +1,45 @@
-# ex:ts=8
-# Ports collection makefile for: qwtplot3d
-# Date created: Aug 30, 2004
-# Whom: ijliao
+# New ports collection makefile for: qwtplot3d-qt4
+# Date created: 2007-05-27
+# Whom: Max Brazhnikov <makc@issp.ac.ru>
#
# $FreeBSD$
#
PORTNAME= qwtplot3d
PORTVERSION= 0.2.6
-PORTREVISION= 3
CATEGORIES= math
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
+PKGNAMESUFFIX= -qt4
EXTRACT_SUFX= .tgz
MAINTAINER= makc@issp.ac.ru
-COMMENT= A 3D plotting widget for scientific data and mathematical expressions
+COMMENT= 3D plotting widgets for scientific data and math expressions
-BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
-
-USE_QT_VER= 3
-USE_XLIB= yes
-USE_GL= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}
-MAKE_ENV= QTDIR=${QT_PREFIX}
+USE_QT_VER= 4
+QT_COMPONENTS= gui moc qmake opengl
USE_LDCONFIG= yes
+HAS_CONFIGURE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+do-configure:
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
+ ${QMAKE} -unix ${PORTNAME}.pro
pre-build:
- @cd ${WRKSRC}; qmake -spec ${LOCALBASE}/share/qt/mkspecs/freebsd-g++ ${PORTNAME}.pro
+ cd ${WRKSRC} && ${REINPLACE_CMD} -e \
+ 's|^CC .*|CC=${CC}|; \
+ s|^CXX .*|CXX=${CXX}|; \
+ s|^LINK .*|LINK=${CXX}|; \
+ s|-pipe||; \
+ s|^\(CFLAGS .*= \)|\1${CFLAGS}|; \
+ s|^\(CXXFLAGS = \)|\1${CXXFLAGS}|; \
+ /^INCPATH/s|-I\.|-Iinclude|;' Makefile
do-install:
- ${CP} ${WRKSRC}/include/* ${PREFIX}/include
- ${INSTALL_DATA} ${WRKSRC}/lib/libqwtplot3d.so.${PORTVERSION} ${PREFIX}/lib
- ${LN} -fs ${PREFIX}/lib/libqwtplot3d.so.${PORTVERSION} ${PREFIX}/lib/libqwtplot3d.so.0
- ${LN} -fs ${PREFIX}/lib/libqwtplot3d.so.${PORTVERSION} ${PREFIX}/lib/libqwtplot3d.so
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${EXAMPLESDIR}
- (cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
-.endif
+ (cd ${WRKSRC}/include/ && ${COPYTREE_SHARE} \* ${PREFIX}/include/qwtplot3d-qt4)
+ ${INSTALL_PROGRAM} ${WRKSRC}/lib/libqwtplot3d-qt4.so.${PORTVERSION} ${PREFIX}/lib
+ ${LN} -fs ${PREFIX}/lib/libqwtplot3d-qt4.so.${PORTVERSION} ${PREFIX}/lib/libqwtplot3d-qt4.so.0
+ ${LN} -fs ${PREFIX}/lib/libqwtplot3d-qt4.so.${PORTVERSION} ${PREFIX}/lib/libqwtplot3d-qt4.so
.include <bsd.port.mk>
diff --git a/math/qwtplot3d-qt4/files/patch-qwtplot3d.pro b/math/qwtplot3d-qt4/files/patch-qwtplot3d.pro
new file mode 100644
index 000000000000..93ee14106c97
--- /dev/null
+++ b/math/qwtplot3d-qt4/files/patch-qwtplot3d.pro
@@ -0,0 +1,11 @@
+--- ./qwtplot3d.pro.orig Thu Jul 21 21:00:46 2005
++++ ./qwtplot3d.pro Sun May 27 21:11:49 2007
+@@ -2,7 +2,7 @@
+ #
+
+
+-TARGET = qwtplot3d
++TARGET = qwtplot3d-qt4
+ TEMPLATE = lib
+ CONFIG += qt warn_on opengl thread zlib
+ MOC_DIR = tmp
diff --git a/math/qwtplot3d-qt4/pkg-descr b/math/qwtplot3d-qt4/pkg-descr
index 85e00e3fa14b..49b10055843e 100644
--- a/math/qwtplot3d-qt4/pkg-descr
+++ b/math/qwtplot3d-qt4/pkg-descr
@@ -1,24 +1,4 @@
-QwtPlot3D is not a program, but a feature-rich Qt/OpenGL-based C++ programming
-library. She provides essentially a bunch of 3D-widgets for programmers.
+This is a Qt4 version of QwtPlot3d - a feature-rich Qt/OpenGL-based
+C++ programming library, providing essentially a bunch of 3D-widgets.
-Features
- * Parametric Surfaces
- * Lighting (experimental)
- * User defined visual objects
- * Scaling, rotating, shifting, zooming of data sets and mathematical
- functions
- * Interactive mouse and keyboard handling
- * Resolution changing on the fly
- * Reading from MESH and FEM data files
- * Data structures providing nodes and triangulation
- * Flat (2D) labeling
- * Wireframe, filled polygons, hidden line
- * Floor projections (Isolines, Data)
- * Free configurable (labeling, numbering; linear, log or user-defined
- transformations) and autoscalable axes
- * Free color model, and color legends
- * Flat/Gouraud shading
- * Pixmap output (all Qt supported formats)
- * Vector output (PostScript, EPS and PDF) via gl2ps
-
-WWW: http://qwtplot3d.sourceforge.net/
+WWW: http://qwtplot3d.sourceforge.net/
diff --git a/math/qwtplot3d-qt4/pkg-plist b/math/qwtplot3d-qt4/pkg-plist
index 7c9206dd4c52..91b9328973fd 100644
--- a/math/qwtplot3d-qt4/pkg-plist
+++ b/math/qwtplot3d-qt4/pkg-plist
@@ -1,115 +1,32 @@
-include/qwt3d_autoptr.h
-include/qwt3d_autoscaler.h
-include/qwt3d_axis.h
-include/qwt3d_color.h
-include/qwt3d_colorlegend.h
-include/qwt3d_coordsys.h
-include/qwt3d_drawable.h
-include/qwt3d_enrichment.h
-include/qwt3d_enrichment_std.h
-include/qwt3d_function.h
-include/qwt3d_global.h
-include/qwt3d_graphplot.h
-include/qwt3d_gridmapping.h
-include/qwt3d_helper.h
-include/qwt3d_io.h
-include/qwt3d_io_gl2ps.h
-include/qwt3d_io_reader.h
-include/qwt3d_label.h
-include/qwt3d_mapping.h
-include/qwt3d_multiplot.h
-include/qwt3d_openglhelper.h
-include/qwt3d_parametricsurface.h
-include/qwt3d_plot.h
-include/qwt3d_portability.h
-include/qwt3d_scale.h
-include/qwt3d_surfaceplot.h
-include/qwt3d_types.h
-include/qwt3d_volumeplot.h
-lib/libqwtplot3d.so
-lib/libqwtplot3d.so.0
-lib/libqwtplot3d.so.0.2.6
-%%PORTDOCS%%%%EXAMPLESDIR%%/autoswitch/autoswitch.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/autoswitch/autoswitch.h
-%%PORTDOCS%%%%EXAMPLESDIR%%/autoswitch/autoswitch.pro
-%%PORTDOCS%%%%EXAMPLESDIR%%/axes/axes.pro
-%%PORTDOCS%%%%EXAMPLESDIR%%/axes/src/axes.h
-%%PORTDOCS%%%%EXAMPLESDIR%%/axes/src/axesmainwindow.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/axes/src/axesmainwindow.h
-%%PORTDOCS%%%%EXAMPLESDIR%%/axes/src/axesmainwindowbase.ui
-%%PORTDOCS%%%%EXAMPLESDIR%%/axes/src/axesmainwindowbase4.ui
-%%PORTDOCS%%%%EXAMPLESDIR%%/axes/src/main.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/box.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/common.pro
-%%PORTDOCS%%%%EXAMPLESDIR%%/dsp.bat
-%%PORTDOCS%%%%EXAMPLESDIR%%/enrichments/enrichments.pro
-%%PORTDOCS%%%%EXAMPLESDIR%%/enrichments/src/enrichmentmainwindow.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/enrichments/src/enrichmentmainwindow.h
-%%PORTDOCS%%%%EXAMPLESDIR%%/enrichments/src/enrichmentmainwindowbase.ui
-%%PORTDOCS%%%%EXAMPLESDIR%%/enrichments/src/enrichmentmainwindowbase4.ui
-%%PORTDOCS%%%%EXAMPLESDIR%%/enrichments/src/enrichments.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/enrichments/src/enrichments.h
-%%PORTDOCS%%%%EXAMPLESDIR%%/enrichments/src/main.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/examples.dsw
-%%PORTDOCS%%%%EXAMPLESDIR%%/examples.pro
-%%PORTDOCS%%%%EXAMPLESDIR%%/examples.sln
-%%PORTDOCS%%%%EXAMPLESDIR%%/filecell.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/fileopen.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/filledmesh.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/floordata.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/floorempty.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/flooriso.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/floormesh.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/frame.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/grid.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/gridb.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/gridc.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/gridf.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/gridfr.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/gridl.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/gridr.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/hiddenline.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/icon.ico
-%%PORTDOCS%%%%EXAMPLESDIR%%/icon.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/icon.rc
-%%PORTDOCS%%%%EXAMPLESDIR%%/images.qrc
-%%PORTDOCS%%%%EXAMPLESDIR%%/mesh2/mesh2.pro
-%%PORTDOCS%%%%EXAMPLESDIR%%/mesh2/src/colormapreader.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/mesh2/src/colormapreader.h
-%%PORTDOCS%%%%EXAMPLESDIR%%/mesh2/src/designerworkaround.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/mesh2/src/designerworkaround.h
-%%PORTDOCS%%%%EXAMPLESDIR%%/mesh2/src/femreader.h
-%%PORTDOCS%%%%EXAMPLESDIR%%/mesh2/src/functions.h
-%%PORTDOCS%%%%EXAMPLESDIR%%/mesh2/src/lightingdlg.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/mesh2/src/lightingdlg.h
-%%PORTDOCS%%%%EXAMPLESDIR%%/mesh2/src/lightingdlgbase.ui
-%%PORTDOCS%%%%EXAMPLESDIR%%/mesh2/src/lightingdlgbase4.ui
-%%PORTDOCS%%%%EXAMPLESDIR%%/mesh2/src/lightingdlgbaseimpl.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/mesh2/src/lightingdlgbaseimpl.h
-%%PORTDOCS%%%%EXAMPLESDIR%%/mesh2/src/main.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/mesh2/src/mesh.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/mesh2/src/mesh2mainwindow.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/mesh2/src/mesh2mainwindow.h
-%%PORTDOCS%%%%EXAMPLESDIR%%/mesh2/src/mesh2mainwindowbase.ui
-%%PORTDOCS%%%%EXAMPLESDIR%%/mesh2/src/mesh2mainwindowbase4.ui
-%%PORTDOCS%%%%EXAMPLESDIR%%/mesh2/src/thesis.tex
-%%PORTDOCS%%%%EXAMPLESDIR%%/movie.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/nodata.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/none.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/normals.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/polygon.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/qwtplot.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/savecontent.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/scattered.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/simpleplot/simpleplot.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/simpleplot/simpleplot.pro
-%%PORTDOCS%%%%EXAMPLESDIR%%/wireframe.png
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/simpleplot
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/mesh2/src
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/mesh2
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/enrichments/src
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/enrichments
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/axes/src
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/axes
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/autoswitch
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+include/qwtplot3d-qt4/qwt3d_autoptr.h
+include/qwtplot3d-qt4/qwt3d_autoscaler.h
+include/qwtplot3d-qt4/qwt3d_axis.h
+include/qwtplot3d-qt4/qwt3d_color.h
+include/qwtplot3d-qt4/qwt3d_colorlegend.h
+include/qwtplot3d-qt4/qwt3d_coordsys.h
+include/qwtplot3d-qt4/qwt3d_drawable.h
+include/qwtplot3d-qt4/qwt3d_enrichment.h
+include/qwtplot3d-qt4/qwt3d_enrichment_std.h
+include/qwtplot3d-qt4/qwt3d_function.h
+include/qwtplot3d-qt4/qwt3d_global.h
+include/qwtplot3d-qt4/qwt3d_graphplot.h
+include/qwtplot3d-qt4/qwt3d_gridmapping.h
+include/qwtplot3d-qt4/qwt3d_helper.h
+include/qwtplot3d-qt4/qwt3d_io.h
+include/qwtplot3d-qt4/qwt3d_io_gl2ps.h
+include/qwtplot3d-qt4/qwt3d_io_reader.h
+include/qwtplot3d-qt4/qwt3d_label.h
+include/qwtplot3d-qt4/qwt3d_mapping.h
+include/qwtplot3d-qt4/qwt3d_multiplot.h
+include/qwtplot3d-qt4/qwt3d_openglhelper.h
+include/qwtplot3d-qt4/qwt3d_parametricsurface.h
+include/qwtplot3d-qt4/qwt3d_plot.h
+include/qwtplot3d-qt4/qwt3d_portability.h
+include/qwtplot3d-qt4/qwt3d_scale.h
+include/qwtplot3d-qt4/qwt3d_surfaceplot.h
+include/qwtplot3d-qt4/qwt3d_types.h
+include/qwtplot3d-qt4/qwt3d_volumeplot.h
+lib/libqwtplot3d-qt4.so
+lib/libqwtplot3d-qt4.so.0
+lib/libqwtplot3d-qt4.so.0.2.6
+@dirrm include/qwtplot3d-qt4