aboutsummaryrefslogtreecommitdiff
path: root/math/qwtplot3d
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-09-23 23:16:24 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-09-23 23:16:24 +0000
commitb6bad142212afc368024783c129e3ae048be79d5 (patch)
tree58333609659bbd0524cd0324402aa7658e3af9a9 /math/qwtplot3d
parent31eaed2ac26ea5d33e1a9820bd77d893088dc3db (diff)
downloadports-b6bad142212afc368024783c129e3ae048be79d5.tar.gz
ports-b6bad142212afc368024783c129e3ae048be79d5.zip
Notes
Diffstat (limited to 'math/qwtplot3d')
-rw-r--r--math/qwtplot3d/Makefile11
-rw-r--r--math/qwtplot3d/distinfo6
-rw-r--r--math/qwtplot3d/files/patch-qwtplot3d.pro20
-rw-r--r--math/qwtplot3d/pkg-plist4
4 files changed, 32 insertions, 9 deletions
diff --git a/math/qwtplot3d/Makefile b/math/qwtplot3d/Makefile
index 2e4e38ab3f28..864376455816 100644
--- a/math/qwtplot3d/Makefile
+++ b/math/qwtplot3d/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= qwtplot3d
-PORTVERSION= 0.2.6
-PORTREVISION= 3
+PORTVERSION= 0.2.7
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,14 +19,18 @@ COMMENT= A 3D plotting widget for scientific data and mathematical expressions
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
USE_QT_VER= 3
-USE_XLIB= yes
USE_GL= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
MAKE_ENV= QTDIR=${QT_PREFIX}
USE_LDCONFIG= yes
+USE_DOS2UNIX= yes
pre-build:
- @cd ${WRKSRC}; qmake -spec ${LOCALBASE}/share/qt/mkspecs/freebsd-g++ ${PORTNAME}.pro
+ cd ${WRKSRC}; qmake -spec ${LOCALBASE}/share/qt/mkspecs/freebsd-g++ ${PORTNAME}.pro
+ cd ${WRKSRC} && ${REINPLACE_CMD} -e \
+ 's|^CC .*|CC=${CC}|; \
+ s|^CXX .*|CXX=${CXX}|; \
+ s|^LINK .*|LINK=${CXX}|' Makefile
do-install:
${CP} ${WRKSRC}/include/* ${PREFIX}/include
diff --git a/math/qwtplot3d/distinfo b/math/qwtplot3d/distinfo
index 63b14748575d..19d9985fdd4c 100644
--- a/math/qwtplot3d/distinfo
+++ b/math/qwtplot3d/distinfo
@@ -1,3 +1,3 @@
-MD5 (qwtplot3d-0.2.6.tgz) = 7ef960d7874f78162d6c9d241de2843e
-SHA256 (qwtplot3d-0.2.6.tgz) = ea7c2ea3d55960ee60019e0a5a5a63385bdcf7026a6385099fd8b31350803125
-SIZE (qwtplot3d-0.2.6.tgz) = 148834
+MD5 (qwtplot3d-0.2.7.tgz) = 2f14660152e2e26bfeaaeec479ed9f2b
+SHA256 (qwtplot3d-0.2.7.tgz) = 1208336b15e82e7a9d22cbc743e46f27e2fad716094a9c133138f259fa299a42
+SIZE (qwtplot3d-0.2.7.tgz) = 183836
diff --git a/math/qwtplot3d/files/patch-qwtplot3d.pro b/math/qwtplot3d/files/patch-qwtplot3d.pro
new file mode 100644
index 000000000000..e56ade8e24b0
--- /dev/null
+++ b/math/qwtplot3d/files/patch-qwtplot3d.pro
@@ -0,0 +1,20 @@
+--- ./qwtplot3d.pro.orig Tue Jun 26 18:33:59 2007
++++ ./qwtplot3d.pro Tue Jun 26 18:34:38 2007
+@@ -3,7 +3,7 @@
+
+ TARGET = qwtplot3d
+ TEMPLATE = lib
+-CONFIG += qt warn_on opengl thread zlib debug
++CONFIG += qt warn_on opengl thread zlib
+ MOC_DIR = tmp
+ OBJECTS_DIR = tmp
+ INCLUDEPATH = include
+@@ -21,7 +21,7 @@
+ win32:CONFIG -= zlib
+
+ linux-g++:TMAKE_CXXFLAGS += -fno-exceptions
+-unix:VERSION = 0.2.6
++unix:VERSION = 0.2.7
+
+ # Input
+ SOURCES += src/qwt3d_axis.cpp \
diff --git a/math/qwtplot3d/pkg-plist b/math/qwtplot3d/pkg-plist
index 7c9206dd4c52..f35f2fd7bf47 100644
--- a/math/qwtplot3d/pkg-plist
+++ b/math/qwtplot3d/pkg-plist
@@ -28,7 +28,7 @@ include/qwt3d_types.h
include/qwt3d_volumeplot.h
lib/libqwtplot3d.so
lib/libqwtplot3d.so.0
-lib/libqwtplot3d.so.0.2.6
+lib/libqwtplot3d.so.0.2.7
%%PORTDOCS%%%%EXAMPLESDIR%%/autoswitch/autoswitch.cpp
%%PORTDOCS%%%%EXAMPLESDIR%%/autoswitch/autoswitch.h
%%PORTDOCS%%%%EXAMPLESDIR%%/autoswitch/autoswitch.pro
@@ -50,7 +50,6 @@ lib/libqwtplot3d.so.0.2.6
%%PORTDOCS%%%%EXAMPLESDIR%%/enrichments/src/enrichments.cpp
%%PORTDOCS%%%%EXAMPLESDIR%%/enrichments/src/enrichments.h
%%PORTDOCS%%%%EXAMPLESDIR%%/enrichments/src/main.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/examples.dsw
%%PORTDOCS%%%%EXAMPLESDIR%%/examples.pro
%%PORTDOCS%%%%EXAMPLESDIR%%/examples.sln
%%PORTDOCS%%%%EXAMPLESDIR%%/filecell.png
@@ -69,6 +68,7 @@ lib/libqwtplot3d.so.0.2.6
%%PORTDOCS%%%%EXAMPLESDIR%%/gridl.png
%%PORTDOCS%%%%EXAMPLESDIR%%/gridr.png
%%PORTDOCS%%%%EXAMPLESDIR%%/hiddenline.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/icon.gif
%%PORTDOCS%%%%EXAMPLESDIR%%/icon.ico
%%PORTDOCS%%%%EXAMPLESDIR%%/icon.png
%%PORTDOCS%%%%EXAMPLESDIR%%/icon.rc