aboutsummaryrefslogtreecommitdiff
path: root/math/rascal
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-06-26 17:12:39 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-06-26 17:12:39 +0000
commit174b85161b62e5038348b2bbd636d29fd280eb19 (patch)
tree638cfe6be0b18e61bd6cf192e0971e5db785464f /math/rascal
parent2d05aa1267974f9682465111d1d6d71035ca411a (diff)
downloadports-174b85161b62e5038348b2bbd636d29fd280eb19.tar.gz
ports-174b85161b62e5038348b2bbd636d29fd280eb19.zip
Notes
Diffstat (limited to 'math/rascal')
-rw-r--r--math/rascal/files/patch-Makefile27
-rw-r--r--math/rascal/pkg-plist2
2 files changed, 22 insertions, 7 deletions
diff --git a/math/rascal/files/patch-Makefile b/math/rascal/files/patch-Makefile
index c408a868e90c..d7f728097898 100644
--- a/math/rascal/files/patch-Makefile
+++ b/math/rascal/files/patch-Makefile
@@ -1,27 +1,40 @@
---- Makefile.orig Mon Jun 25 19:38:33 2001
-+++ Makefile Mon Jun 25 19:40:33 2001
+--- Makefile.orig Sat Jun 23 08:05:50 2001
++++ Makefile Wed Jun 27 01:10:23 2001
@@ -21,4 +21,3 @@
-CC=g++
-CFLAGS=-O0 -g -DVERSION=\"$(VERSION)\"
-+CXXFLAGS+=-DVERSION=\"$(VERSION)\" -I%%LOCALBASE%%/include
++CXXFLAGS=-O0 -DVERSION=\"$(VERSION)\" -I%%LOCALBASE%%/include
# with the following options you might be able to optimize
@@ -33,3 +32,3 @@
-LIBS=-lm -lreadline -lcurses
+LIBS=-lm -lreadline -lcurses -L%%LOCALBASE%%/lib -lgnugetopt
OBJS=y.tab.o lex.yy.o symtab.o value.o
-@@ -38,2 +37,6 @@
+@@ -38,4 +37,8 @@
+.SUFFIXES: .o .c
+
+.c.o: ; ${CXX} ${CXXFLAGS} -c $*.c
+
rascal: $(OBJS)
-@@ -74,6 +77,4 @@
+- g++ -o rascal $(CFLAGS) $(OBJS) $(LIBS)
++ g++ -o rascal $(CXXFLAGS) $(OBJS) $(LIBS)
+ test: rascal
+@@ -73,7 +76,7 @@
+ $(INSTALL) ./rascal.rc $(PREFIX)/bin/
++ $(INSTDIR) $(PREFIX)/share/doc/rascal
$(STRIP) $(PREFIX)/bin/rascal
- $(INSTDIR) $(PREFIX)/doc/rascal
- $(INSTALL) rascal.ps $(PREFIX)/doc/rascal
- $(INSTALL) rascal.pdf $(PREFIX)/doc/rascal
+- $(INSTALL) rascal.ps $(PREFIX)/doc/rascal
+- $(INSTALL) rascal.pdf $(PREFIX)/doc/rascal
- -$(INSTDIR) $(PREFIX)/doc/rascal/html
++ $(INSTALL) rascal.ps $(PREFIX)/share/doc/rascal
++ $(INSTALL) rascal.pdf $(PREFIX)/share/doc/rascal
++ -$(INSTDIR) $(PREFIX)/share/doc/rascal/html
-$(INSTALL) rascal_html/index.html rascal_html/rascal.html rascal_html/*.gif rascal_html/*.css $(PREFIX)/doc/rascal/html
+@@ -112,3 +115,3 @@
+ value.o: value.hpp value.out value.cpp modules/*.cpp modules/*.hpp
+- g++ $(CFLAGS) -c -o value.o value.cpp
++ g++ $(CXXFLAGS) -c -o value.o value.cpp
+ parsevalue: parsevalue.cpp
diff --git a/math/rascal/pkg-plist b/math/rascal/pkg-plist
index 4e17b5679be8..8a9b6a0d7a99 100644
--- a/math/rascal/pkg-plist
+++ b/math/rascal/pkg-plist
@@ -1,4 +1,6 @@
bin/rascal
+bin/rascal.rc
share/doc/rascal/rascal.pdf
share/doc/rascal/rascal.ps
+@dirrm share/doc/rascal/html
@dirrm share/doc/rascal