aboutsummaryrefslogtreecommitdiff
path: root/math/rcalc/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-11-01 02:23:52 +0000
committerSteve Price <steve@FreeBSD.org>1999-11-01 02:23:52 +0000
commita9a5267e924e75c2fea4f50cfdd8b7c1b0899416 (patch)
treeb3da8015c673f330f4a426dda2c73991977e62d9 /math/rcalc/Makefile
parent302c17facca194ccd9af651045f96aeb8e6fc136 (diff)
downloadports-a9a5267e924e75c2fea4f50cfdd8b7c1b0899416.tar.gz
ports-a9a5267e924e75c2fea4f50cfdd8b7c1b0899416.zip
Notes
Diffstat (limited to 'math/rcalc/Makefile')
-rw-r--r--math/rcalc/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/math/rcalc/Makefile b/math/rcalc/Makefile
new file mode 100644
index 000000000000..a64f6cad349c
--- /dev/null
+++ b/math/rcalc/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: rcalc
+# Version required: 0.1
+# Date created: 28 October 1999
+# Whom: Chris D. Faulhaber <jedgar@fxp.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= rCalc-0.1
+PKGNAME= rcalc-0.1
+CATEGORIES= math gnome
+MASTER_SITES= http://members.xoom.com/ratsoft/download/
+
+MAINTAINER= jedgar@fxp.org
+
+LIB_DEPENDS= gnome.3:${PORTSDIR}/x11/gnomelibs
+
+FETCH_BEFORE_ARGS+= -b # members.xoom.com is broken
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-x
+CONFIGURE_ENV+= CFLAGS="-I${LOCALBASE}/include ${CFLAGS}" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>