aboutsummaryrefslogtreecommitdiff
path: root/math/rexx-regmath
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-04-08 17:42:15 +0000
committerSteve Wills <swills@FreeBSD.org>2019-04-08 17:42:15 +0000
commit839c5ac9938da6e78acf8045dc0f3c36bab37661 (patch)
treed7aff3b429bbc0af05851dc0eb167f5cf5c9ec0c /math/rexx-regmath
parentc2caa41e891e8809efd84b6035ff80244188bf39 (diff)
downloadports-839c5ac9938da6e78acf8045dc0f3c36bab37661.tar.gz
ports-839c5ac9938da6e78acf8045dc0f3c36bab37661.zip
math/rexx-regmath: fix LLD_UNSAFE
PR: 237082 Submitted by: bob@eager.cx (maintainer)
Notes
Notes: svn path=/head/; revision=498398
Diffstat (limited to 'math/rexx-regmath')
-rw-r--r--math/rexx-regmath/Makefile4
-rw-r--r--math/rexx-regmath/files/patch-Makefile.bsd8
2 files changed, 7 insertions, 5 deletions
diff --git a/math/rexx-regmath/Makefile b/math/rexx-regmath/Makefile
index a12c7db5a09a..71335a1d4fe1 100644
--- a/math/rexx-regmath/Makefile
+++ b/math/rexx-regmath/Makefile
@@ -3,6 +3,7 @@
PORTNAME= regmath
PORTVERSION= 1.00
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= http://home.interlog.com/~ptjm/ \
http://www.ancientgeek.org.uk/distfiles/
@@ -14,13 +15,12 @@ COMMENT= Two mathematics libraries for Rexx
LICENSE= MPL10
-BUILD_DEPENDS= ${LOCALBASE}/include/rexxsaa.h:lang/rexx-regina
+BUILD_DEPENDS= rexx:lang/rexx-regina
USES= zip
WRKSRC= ${WRKDIR}/math
USE_LDCONFIG= yes
-LLD_UNSAFE= yes
MAKEFILE= Makefile.bsd
PLIST_FILES= lib/librexxmath.so lib/librxmath.so man/man1/regmath.1.gz
diff --git a/math/rexx-regmath/files/patch-Makefile.bsd b/math/rexx-regmath/files/patch-Makefile.bsd
index ca52af08705e..ad5d61a942d6 100644
--- a/math/rexx-regmath/files/patch-Makefile.bsd
+++ b/math/rexx-regmath/files/patch-Makefile.bsd
@@ -1,11 +1,13 @@
---- Makefile.bsd.orig 2001-11-04 17:09:04 UTC
+--- Makefile.bsd.orig 2001-11-04 18:09:04 UTC
+++ Makefile.bsd
-@@ -9,7 +9,7 @@
+@@ -9,8 +9,8 @@
POPT=-O -fomit-frame-pointer
PLFL=-s
DEBUG=-g
-CFLAGS=$(OPT) $(DEBUG) -pipe -fpic -I $$HOME/regina -pipe
+-LDFLAGS=-Bdynamic -Bshareable $(LFL)
+CFLAGS+=$(OPT) $(DEBUG) -pipe -fpic -I $$HOME/regina -pipe -I/usr/local/include
- LDFLAGS=-Bdynamic -Bshareable $(LFL)
++LDFLAGS=-Bdynamic -Bshareable $(LFL) -L/usr/lib
LIBS=-lm
so=so
+ o=o