aboutsummaryrefslogtreecommitdiff
path: root/math/rocs/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-04-09 18:13:24 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-04-09 18:13:24 +0000
commit2415bff2912c7ead959fe11d9b6dc97b940c820d (patch)
tree6bb660b2370ef4a28fd556e621311745129c03c4 /math/rocs/Makefile
parentd7a8f169f07938dcb72eddf5f0718b46e8cf285f (diff)
downloadports-2415bff2912c7ead959fe11d9b6dc97b940c820d.tar.gz
ports-2415bff2912c7ead959fe11d9b6dc97b940c820d.zip
Notes
Diffstat (limited to 'math/rocs/Makefile')
-rw-r--r--math/rocs/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/math/rocs/Makefile b/math/rocs/Makefile
new file mode 100644
index 000000000000..da77f1845ceb
--- /dev/null
+++ b/math/rocs/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= rocs
+DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+CATEGORIES= math kde kde-applications
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE Graph theory IDE
+
+LIB_DEPENDS= libboost_thread.so:devel/boost-libs
+
+USES= cmake:outsource gettext grantlee:5 kde:5 tar:xz
+USE_KDE= archive auth codecs completion config configwidgets coreaddons \
+ crash doctools ecm i18n itemviews jobwidgets kdeclarative \
+ kio package parts service sonnet texteditor textwidgets \
+ widgetsaddons xmlgui
+USE_QT5= core dbus gui network qml script quick scripttools svg webkit \
+ widgets xml xmlpatterns \
+ buildtools_build qmake_build
+
+USE_LDCONFIG= yes
+
+# clang 6.0 defaults to -std=gnu++14, which breaks the build:
+# /wrkdirs/usr/ports/math/rocs/work/rocs-4.14.3/VisualEditor/Actions/SelectMoveHandAction.cpp:86:52: error: no viable conversion from 'int' to 'QPainter::RenderHints' (aka 'QFlags<QPainter::RenderHint>')
+# _graphScene->views().at(0)->setRenderHints(QPainter::Antialiasing
+USE_CXXSTD= gnu++98
+
+.include <bsd.port.mk>