aboutsummaryrefslogtreecommitdiff
path: root/math/rocs
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2011-10-17 00:03:42 +0000
committerAlberto Villa <avilla@FreeBSD.org>2011-10-17 00:03:42 +0000
commita2d3b5a4bc5047210b788a128596ec34749ffa11 (patch)
treec3c20b47c3435ddcaf02b8570db6aab5b70011af /math/rocs
parentda6ade2349d0bdc372133d4d97bc6988aee94238 (diff)
Notes
Diffstat (limited to 'math/rocs')
-rw-r--r--math/rocs/Makefile30
-rw-r--r--math/rocs/distinfo2
-rw-r--r--math/rocs/pkg-descr12
-rw-r--r--math/rocs/pkg-plist108
4 files changed, 152 insertions, 0 deletions
diff --git a/math/rocs/Makefile b/math/rocs/Makefile
new file mode 100644
index 000000000000..9316e4cd9505
--- /dev/null
+++ b/math/rocs/Makefile
@@ -0,0 +1,30 @@
+# New ports collection Makefile for: rocs
+# Date created: 6 September 2011
+# Whom: Alberto Villa <avilla@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rocs
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= math kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Graph teory IDE for KDE 4
+
+LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs
+
+CONFLICTS= kdeedu-4.[0-6].*
+
+USE_KDE4= kdehier kdelibs kdeprefix automoc4
+KDE4_BUILDENV= yes
+USE_QT_VER= 4
+QT_COMPONENTS= script scripttools \
+ moc_build qmake_build rcc_build uic_build
+USE_BZIP2= yes
+MAKE_JOBS_SAFE= yes
+
+.include <bsd.port.mk>
diff --git a/math/rocs/distinfo b/math/rocs/distinfo
new file mode 100644
index 000000000000..a1ae6623ebe1
--- /dev/null
+++ b/math/rocs/distinfo
@@ -0,0 +1,2 @@
+SHA256 (KDE/rocs-4.7.2.tar.bz2) = 3f08af8f569e357fec557122b63fec945cbbe85ad5ea8f0d65063f0f38dff3d3
+SIZE (KDE/rocs-4.7.2.tar.bz2) = 344088
diff --git a/math/rocs/pkg-descr b/math/rocs/pkg-descr
new file mode 100644
index 000000000000..eefccd1a79ff
--- /dev/null
+++ b/math/rocs/pkg-descr
@@ -0,0 +1,12 @@
+Rocs aims to be a graph theory IDE for helping professors to show the
+results of a graph algorithm and also helping students to do the
+algorithms.
+
+FEATURES
+- Canvas for graph drawing.
+- IDE for graph related programming, using JavaScript as its main
+ language, plus the graph library.
+- Nodes, graphs and edges are extensible from the scripting interface,
+ so you can do anything you want.
+
+WWW: http://www.kde.org/applications/education/rocs
diff --git a/math/rocs/pkg-plist b/math/rocs/pkg-plist
new file mode 100644
index 000000000000..a9c5a9c5c871
--- /dev/null
+++ b/math/rocs/pkg-plist
@@ -0,0 +1,108 @@
+bin/rocs
+include/rocs/Data.h
+include/rocs/DataItem.h
+include/rocs/DataStructure.h
+include/rocs/Document.h
+include/rocs/DynamicPropertiesList.h
+include/rocs/FilePluginInterface.h
+include/rocs/GraphicsLayout.h
+include/rocs/KrossBackend.h
+include/rocs/PluginManager.h
+include/rocs/Pointer.h
+include/rocs/PointerItem.h
+include/rocs/QtScriptBackend.h
+include/rocs/Rocs_Typedefs.h
+include/rocs/ToolsPluginInterface.h
+include/rocs/rocslib_export.h
+lib/kde4/rocs_GraphStructure.so
+lib/kde4/rocs_ListStructure.so
+lib/kde4/rocs_assignvaluesplugin.so
+lib/kde4/rocs_generategraphplugin.so
+lib/kde4/rocs_plaintxt.so
+lib/kde4/rocs_transformedgesplugin.so
+lib/librocslib.so
+lib/librocslib.so.5
+lib/librocslib.so.5.0.1
+share/applications/kde4/rocs.desktop
+share/apps/rocs/examples/AdjustProjection.js
+share/apps/rocs/examples/NameAndNodes.js
+share/apps/rocs/examples/NamesValues.js
+share/apps/rocs/examples/arrangeNodes.js
+share/apps/rocs/examples/broadWalk.js
+share/apps/rocs/examples/coloring.js
+share/apps/rocs/iconpacks/default.svg
+share/apps/rocs/icons/hicolor/16x16/actions/rocsaddedge.png
+share/apps/rocs/icons/hicolor/16x16/actions/rocsaddnode.png
+share/apps/rocs/icons/hicolor/16x16/actions/rocsallignbottom.png
+share/apps/rocs/icons/hicolor/16x16/actions/rocsallignhmiddle.png
+share/apps/rocs/icons/hicolor/16x16/actions/rocsallignleft.png
+share/apps/rocs/icons/hicolor/16x16/actions/rocsallignright.png
+share/apps/rocs/icons/hicolor/16x16/actions/rocsalligntop.png
+share/apps/rocs/icons/hicolor/16x16/actions/rocsallignvmiddle.png
+share/apps/rocs/icons/hicolor/16x16/actions/rocsdelete.png
+share/apps/rocs/icons/hicolor/16x16/actions/rocsselect.png
+share/apps/rocs/icons/hicolor/22x22/actions/rocsallignbottom.png
+share/apps/rocs/icons/hicolor/22x22/actions/rocsallignhmiddle.png
+share/apps/rocs/icons/hicolor/22x22/actions/rocsallignleft.png
+share/apps/rocs/icons/hicolor/22x22/actions/rocsallignright.png
+share/apps/rocs/icons/hicolor/22x22/actions/rocsalligntop.png
+share/apps/rocs/icons/hicolor/22x22/actions/rocsallignvmiddle.png
+share/apps/rocs/icons/hicolor/32x32/actions/rocsaddedge.png
+share/apps/rocs/icons/hicolor/32x32/actions/rocsaddnode.png
+share/apps/rocs/icons/hicolor/32x32/actions/rocsallignbottom.png
+share/apps/rocs/icons/hicolor/32x32/actions/rocsallignhmiddle.png
+share/apps/rocs/icons/hicolor/32x32/actions/rocsallignleft.png
+share/apps/rocs/icons/hicolor/32x32/actions/rocsallignright.png
+share/apps/rocs/icons/hicolor/32x32/actions/rocsalligntop.png
+share/apps/rocs/icons/hicolor/32x32/actions/rocsallignvmiddle.png
+share/apps/rocs/icons/hicolor/32x32/actions/rocsdelete.png
+share/apps/rocs/icons/hicolor/32x32/actions/rocsselect.png
+share/apps/rocs/icons/hicolor/48x48/actions/rocsaddnode.png
+share/apps/rocs/icons/hicolor/48x48/actions/rocsallignbottom.png
+share/apps/rocs/icons/hicolor/48x48/actions/rocsallignhmiddle.png
+share/apps/rocs/icons/hicolor/48x48/actions/rocsallignleft.png
+share/apps/rocs/icons/hicolor/48x48/actions/rocsallignright.png
+share/apps/rocs/icons/hicolor/48x48/actions/rocsalligntop.png
+share/apps/rocs/icons/hicolor/48x48/actions/rocsallignvmiddle.png
+share/apps/rocs/icons/hicolor/64x64/actions/rocsaddedge.png
+share/apps/rocs/icons/hicolor/64x64/actions/rocsaddnode.png
+share/apps/rocs/icons/hicolor/64x64/actions/rocsallignbottom.png
+share/apps/rocs/icons/hicolor/64x64/actions/rocsallignhmiddle.png
+share/apps/rocs/icons/hicolor/64x64/actions/rocsallignleft.png
+share/apps/rocs/icons/hicolor/64x64/actions/rocsallignright.png
+share/apps/rocs/icons/hicolor/64x64/actions/rocsalligntop.png
+share/apps/rocs/icons/hicolor/64x64/actions/rocsallignvmiddle.png
+share/apps/rocs/icons/hicolor/64x64/actions/rocsdelete.png
+share/apps/rocs/icons/hicolor/64x64/actions/rocsselect.png
+share/apps/rocs/rocsui.rc
+share/config.kcfg/rocs.kcfg
+share/config/rocs.knsrc
+share/doc/HTML/en/rocs/common
+share/doc/HTML/en/rocs/index.cache.bz2
+share/doc/HTML/en/rocs/index.docbook
+share/kde4/services/rocs_GraphStructure.desktop
+share/kde4/services/rocs_ListStructure.desktop
+share/kde4/services/rocs_assignvaluesplugin.desktop
+share/kde4/services/rocs_generategraphplugin.desktop
+share/kde4/services/rocs_plaintxtplugin.desktop
+share/kde4/services/rocs_transformedgesplugin.desktop
+share/kde4/servicetypes/RocsDataStructurePlugin.desktop
+share/kde4/servicetypes/RocsFilePlugin.desktop
+share/kde4/servicetypes/RocsToolsPlugin.desktop
+@dirrm share/doc/HTML/en/rocs
+@dirrm share/apps/rocs/icons/hicolor/64x64/actions
+@dirrm share/apps/rocs/icons/hicolor/64x64
+@dirrm share/apps/rocs/icons/hicolor/48x48/actions
+@dirrm share/apps/rocs/icons/hicolor/48x48
+@dirrm share/apps/rocs/icons/hicolor/32x32/actions
+@dirrm share/apps/rocs/icons/hicolor/32x32
+@dirrm share/apps/rocs/icons/hicolor/22x22/actions
+@dirrm share/apps/rocs/icons/hicolor/22x22
+@dirrm share/apps/rocs/icons/hicolor/16x16/actions
+@dirrm share/apps/rocs/icons/hicolor/16x16
+@dirrm share/apps/rocs/icons/hicolor
+@dirrm share/apps/rocs/icons
+@dirrm share/apps/rocs/iconpacks
+@dirrm share/apps/rocs/examples
+@dirrm share/apps/rocs
+@dirrm include/rocs