aboutsummaryrefslogtreecommitdiff
path: root/math/rocs
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2018-01-09 20:53:24 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2018-01-09 20:53:24 +0000
commit1e962ef33d8d72a48904d38b82815ebe3ba672a1 (patch)
treeaba9f7c263cb31da3a7498f81374aedf9cffd6ef /math/rocs
parentbd166fa1a30486144161f9985d5a1b1335a16890 (diff)
Notes
Diffstat (limited to 'math/rocs')
-rw-r--r--math/rocs/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/math/rocs/Makefile b/math/rocs/Makefile
index a8a4f414e690..81c959c08b39 100644
--- a/math/rocs/Makefile
+++ b/math/rocs/Makefile
@@ -16,4 +16,9 @@ USE_QT4= gui qtestlib script scripttools webkit xml \
moc_build qmake_build rcc_build uic_build
USE_LDCONFIG= yes
+# clang 6.0 defaults to -std=gnu++14, which breaks the build:
+# /wrkdirs/usr/ports/math/rocs/work/rocs-4.14.3/VisualEditor/Actions/SelectMoveHandAction.cpp:86:52: error: no viable conversion from 'int' to 'QPainter::RenderHints' (aka 'QFlags<QPainter::RenderHint>')
+# _graphScene->views().at(0)->setRenderHints(QPainter::Antialiasing
+USE_CXXSTD= gnu++98
+
.include <bsd.port.mk>