aboutsummaryrefslogtreecommitdiff
path: root/math/rocs
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-03-27 11:55:25 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-03-27 11:55:25 +0000
commit24482eebf1b38a1d781b1f6c16bb588f5e652980 (patch)
treebcb09269855487369fcfd28040255e86e37e1362 /math/rocs
parente9088ff192d5f032b73c9b2e3386bbc9bf25136b (diff)
downloadports-24482eebf1b38a1d781b1f6c16bb588f5e652980.tar.gz
ports-24482eebf1b38a1d781b1f6c16bb588f5e652980.zip
Notes
Diffstat (limited to 'math/rocs')
-rw-r--r--math/rocs/Makefile6
-rw-r--r--math/rocs/distinfo4
-rw-r--r--math/rocs/pkg-plist59
3 files changed, 43 insertions, 26 deletions
diff --git a/math/rocs/Makefile b/math/rocs/Makefile
index b8de638150b6..e47b29d2c1cd 100644
--- a/math/rocs/Makefile
+++ b/math/rocs/Makefile
@@ -5,7 +5,7 @@ PORTVERSION= ${KDE4_VERSION}
CATEGORIES= math kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
-DIST_SUBDIR= KDE
+DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Graph teory IDE for KDE 4
@@ -16,9 +16,9 @@ CONFLICTS= kdeedu-4.[0-6].*
USE_KDE4= kdehier kdelibs kdeprefix automoc4
USES= cmake:outsource
-USE_QT4= script scripttools \
+USE_QT4= gui qtestlib script scripttools webkit xml \
moc_build qmake_build rcc_build uic_build
-USE_XZ= yes
+USE_XZ= yes
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
diff --git a/math/rocs/distinfo b/math/rocs/distinfo
index 1b8f1fba317a..2dab1d44f181 100644
--- a/math/rocs/distinfo
+++ b/math/rocs/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/rocs-4.9.5.tar.xz) = ca046fe404c6e5aa9088112ddc7fbedf11eb5a936d27f10d4d8ee37165025af9
-SIZE (KDE/rocs-4.9.5.tar.xz) = 1208540
+SHA256 (KDE/4.10.1/rocs-4.10.1.tar.xz) = 9f2dea23d5d287ded8a05f3f6e0c4f81143d8eeb44f33ada4a1b8e71ca2895df
+SIZE (KDE/4.10.1/rocs-4.10.1.tar.xz) = 1141576
diff --git a/math/rocs/pkg-plist b/math/rocs/pkg-plist
index 02c47d39671c..dab10db11d91 100644
--- a/math/rocs/pkg-plist
+++ b/math/rocs/pkg-plist
@@ -1,35 +1,35 @@
bin/rocs
+include/rocs/CoreTypes.h
include/rocs/Data.h
include/rocs/DataItem.h
include/rocs/DataStructure.h
+include/rocs/DataStructureBackendManager.h
include/rocs/DataStructurePluginInterface.h
-include/rocs/DataStructurePluginManager.h
include/rocs/Document.h
-include/rocs/DynamicPropertiesList.h
-include/rocs/FilePluginInterface.h
-include/rocs/GraphicsLayout.h
-include/rocs/IncludeManager.h
-include/rocs/KrossBackend.h
-include/rocs/PluginManager.h
+include/rocs/GraphFileBackendManager.h
+include/rocs/GraphFilePluginInterface.h
+include/rocs/GraphVisualEditor.h
include/rocs/Pointer.h
include/rocs/PointerItem.h
-include/rocs/QtScriptBackend.h
-include/rocs/Rocs_Typedefs.h
-include/rocs/ToolsPluginInterface.h
+include/rocs/RocsCoreExport.h
include/rocs/Topology.h
-include/rocs/rocslib_export.h
-lib/kde4/rocs_GMLParser.so
lib/kde4/rocs_GraphStructure.so
lib/kde4/rocs_ListStructure.so
lib/kde4/rocs_RootedTreeStructure.so
lib/kde4/rocs_assignvaluesplugin.so
-lib/kde4/rocs_dotFilePlugin.so
+lib/kde4/rocs_dotfileformat.so
lib/kde4/rocs_generategraphplugin.so
-lib/kde4/rocs_plaintxt.so
+lib/kde4/rocs_gmlfileformat.so
+lib/kde4/rocs_kmlfileformat.so
+lib/kde4/rocs_tgffileformat.so
+lib/kde4/rocs_tikzfileformat.so
lib/kde4/rocs_transformedgesplugin.so
-lib/librocslib.so
-lib/librocslib.so.5
-lib/librocslib.so.5.0.1
+lib/librocscore.so
+lib/librocscore.so.5
+lib/librocscore.so.5.0.1
+lib/librocsvisualeditor.so
+lib/librocsvisualeditor.so.5
+lib/librocsvisualeditor.so.5.0.1
share/applications/kde4/rocs.desktop
share/apps/rocs/examples/AdjustProjection.js
share/apps/rocs/examples/NameAndNodes.js
@@ -49,6 +49,7 @@ share/apps/rocs/icons/hicolor/16x16/actions/rocsaligntree.png
share/apps/rocs/icons/hicolor/16x16/actions/rocsalignvmiddle.png
share/apps/rocs/icons/hicolor/16x16/actions/rocsselect.png
share/apps/rocs/icons/hicolor/16x16/actions/rocsselectmove.png
+share/apps/rocs/icons/hicolor/16x16/apps/rocs.png
share/apps/rocs/icons/hicolor/22x22/actions/rocsaddedge.png
share/apps/rocs/icons/hicolor/22x22/actions/rocsaddnode.png
share/apps/rocs/icons/hicolor/22x22/actions/rocsalignbottom.png
@@ -71,6 +72,7 @@ share/apps/rocs/icons/hicolor/32x32/actions/rocsaligntree.png
share/apps/rocs/icons/hicolor/32x32/actions/rocsalignvmiddle.png
share/apps/rocs/icons/hicolor/32x32/actions/rocsselect.png
share/apps/rocs/icons/hicolor/32x32/actions/rocsselectmove.png
+share/apps/rocs/icons/hicolor/32x32/apps/rocs.png
share/apps/rocs/icons/hicolor/48x48/actions/rocsaddedge.png
share/apps/rocs/icons/hicolor/48x48/actions/rocsalignbottom.png
share/apps/rocs/icons/hicolor/48x48/actions/rocsaligncircle.png
@@ -81,6 +83,7 @@ share/apps/rocs/icons/hicolor/48x48/actions/rocsaligntop.png
share/apps/rocs/icons/hicolor/48x48/actions/rocsaligntree.png
share/apps/rocs/icons/hicolor/48x48/actions/rocsalignvmiddle.png
share/apps/rocs/icons/hicolor/48x48/actions/rocsselectmove.png
+share/apps/rocs/icons/hicolor/48x48/apps/rocs.png
share/apps/rocs/icons/hicolor/64x64/actions/rocsaddedge.png
share/apps/rocs/icons/hicolor/64x64/actions/rocsalignbottom.png
share/apps/rocs/icons/hicolor/64x64/actions/rocsaligncircle.png
@@ -105,6 +108,9 @@ share/apps/rocs_rootedtree/RootedTreeui.rc
share/config.kcfg/rocs.kcfg
share/config/rocs.knsrc
share/doc/HTML/en/rocs/common
+share/doc/HTML/en/rocs/document-selector.png
+share/doc/HTML/en/rocs/hi22-action-rocsadddata.png
+share/doc/HTML/en/rocs/hi22-action-rocsaddedge.png
share/doc/HTML/en/rocs/hi22-action-rocsalignbottom.png
share/doc/HTML/en/rocs/hi22-action-rocsaligncircle.png
share/doc/HTML/en/rocs/hi22-action-rocsalignhmiddle.png
@@ -113,6 +119,12 @@ share/doc/HTML/en/rocs/hi22-action-rocsalignright.png
share/doc/HTML/en/rocs/hi22-action-rocsaligntop.png
share/doc/HTML/en/rocs/hi22-action-rocsaligntree.png
share/doc/HTML/en/rocs/hi22-action-rocsalignvmiddle.png
+share/doc/HTML/en/rocs/hi22-action-rocsdelete.png
+share/doc/HTML/en/rocs/hi22-action-rocsdeletedata.png
+share/doc/HTML/en/rocs/hi22-action-rocsnew.png
+share/doc/HTML/en/rocs/hi22-action-rocsproperties.png
+share/doc/HTML/en/rocs/hi22-action-rocsselectmove.png
+share/doc/HTML/en/rocs/hi22-action-rocszoom.png
share/doc/HTML/en/rocs/index.cache.bz2
share/doc/HTML/en/rocs/index.docbook
share/doc/HTML/en/rocs/rocs-control-engine-debug.png
@@ -123,17 +135,19 @@ share/doc/HTML/en/rocs/rocs-interfaces.png
share/doc/HTML/en/rocs/rocs-screenshot.png
share/doc/HTML/en/rocs/rocs-toolbar-alignment.png
share/doc/HTML/en/rocs/rocs-toolbar-main.png
-share/kde4/services/rocs_GMLParser.desktop
share/kde4/services/rocs_GraphStructure.desktop
share/kde4/services/rocs_ListStructure.desktop
share/kde4/services/rocs_RootedTreeStructure.desktop
share/kde4/services/rocs_assignvaluesplugin.desktop
-share/kde4/services/rocs_dotFilePlugin.desktop
+share/kde4/services/rocs_dotfileformatplugin.desktop
share/kde4/services/rocs_generategraphplugin.desktop
-share/kde4/services/rocs_plaintxtplugin.desktop
+share/kde4/services/rocs_gmlfileformatplugin.desktop
+share/kde4/services/rocs_kmlfileformatplugin.desktop
+share/kde4/services/rocs_tgffileformatplugin.desktop
+share/kde4/services/rocs_tikzfileformatplugin.desktop
share/kde4/services/rocs_transformedgesplugin.desktop
share/kde4/servicetypes/RocsDataStructurePlugin.desktop
-share/kde4/servicetypes/RocsFilePlugin.desktop
+share/kde4/servicetypes/RocsGraphFilePlugin.desktop
share/kde4/servicetypes/RocsToolsPlugin.desktop
@dirrm share/doc/HTML/en/rocs
@dirrm share/apps/rocs_rootedtree
@@ -141,12 +155,15 @@ share/kde4/servicetypes/RocsToolsPlugin.desktop
@dirrm share/apps/rocs/icons/hicolor/scalable
@dirrm share/apps/rocs/icons/hicolor/64x64/actions
@dirrm share/apps/rocs/icons/hicolor/64x64
+@dirrm share/apps/rocs/icons/hicolor/48x48/apps
@dirrm share/apps/rocs/icons/hicolor/48x48/actions
@dirrm share/apps/rocs/icons/hicolor/48x48
+@dirrm share/apps/rocs/icons/hicolor/32x32/apps
@dirrm share/apps/rocs/icons/hicolor/32x32/actions
@dirrm share/apps/rocs/icons/hicolor/32x32
@dirrm share/apps/rocs/icons/hicolor/22x22/actions
@dirrm share/apps/rocs/icons/hicolor/22x22
+@dirrm share/apps/rocs/icons/hicolor/16x16/apps
@dirrm share/apps/rocs/icons/hicolor/16x16/actions
@dirrm share/apps/rocs/icons/hicolor/16x16
@dirrm share/apps/rocs/icons/hicolor