aboutsummaryrefslogtreecommitdiff
path: root/math/rpy2/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-06-27 02:59:51 +0000
committerWen Heping <wen@FreeBSD.org>2010-06-27 02:59:51 +0000
commit9c305184ae1965d5d572315640c5c33cfbafe0ee (patch)
tree440f7d4b3428767a4682138597c7a1ada7b5e413 /math/rpy2/Makefile
parentdc9e332b0d225d14da05e052d0ea93d60c4f26e0 (diff)
Notes
Diffstat (limited to 'math/rpy2/Makefile')
-rw-r--r--math/rpy2/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/math/rpy2/Makefile b/math/rpy2/Makefile
index 59139f2ba7c6..03a51c3477e2 100644
--- a/math/rpy2/Makefile
+++ b/math/rpy2/Makefile
@@ -6,13 +6,13 @@
# $FreeBSD$
#
-PORTNAME= rpy
-PORTVERSION= 1.0.3
-PORTREVISION= 13
+PORTNAME= rpy2
+PORTVERSION= 2.1.3
CATEGORIES= math
-MASTER_SITES= SF
+MASTER_SITES= CHEESESHOP \
+ SF
-MAINTAINER= wenheping@gmail.com
+MAINTAINER= wen@FreeBSD.org
COMMENT= Python interface to the R Programming Language
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy \
@@ -21,10 +21,8 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
USE_PYTHON= yes
USE_PYDISTUTILS= yes
-MAKE_ENV= LDFLAGS="-L${LOCALBASE}/lib/R/modules -L${LOCALBASE}/lib/R/lib"
post-patch:
- @${REINPLACE_CMD} -e 's,^statichere ,,' ${WRKSRC}/src/rpymodule.c
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/setup.py
.include <bsd.port.mk>