aboutsummaryrefslogtreecommitdiff
path: root/math/ruby-bitvector/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-11-23 14:13:42 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-11-23 14:13:42 +0000
commitfcbca89be5023aa51e8e2fc9d1c58eeb9f2375b3 (patch)
treeb84bbd54f44b850257d772f08447d48bd458d9c7 /math/ruby-bitvector/Makefile
parent62ef405dc557524ae4e2534d39a846d397e95820 (diff)
downloadports-fcbca89be5023aa51e8e2fc9d1c58eeb9f2375b3.tar.gz
ports-fcbca89be5023aa51e8e2fc9d1c58eeb9f2375b3.zip
Notes
Diffstat (limited to 'math/ruby-bitvector/Makefile')
-rw-r--r--math/ruby-bitvector/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/math/ruby-bitvector/Makefile b/math/ruby-bitvector/Makefile
new file mode 100644
index 000000000000..fadc4b956e81
--- /dev/null
+++ b/math/ruby-bitvector/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: Ruby/BitVector
+# Date created: 23 Nov 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bitvector
+PORTVERSION= 0.1.6
+CATEGORIES= math ruby
+MASTER_SITES= http://www.ce.chalmers.se/~feldt/ruby/extensions/bitvector/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}_${PORTVERSION:S/./-/g}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/bitvector
+ ${INSTALL_DATA} ${WRKSRC}/tests/* ${RUBY_EXAMPLESDIR}/bitvector/
+ ${MKDIR} ${RUBY_DOCDIR}/bitvector
+.for f in NOTWRAPPED README TODO
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/bitvector/
+.endfor
+.endif
+
+.include <bsd.port.mk>