aboutsummaryrefslogtreecommitdiff
path: root/math/ruby-gnuplot/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-10-27 23:03:15 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-10-27 23:03:15 +0000
commit24cee1bfb149e5b2a6bfe4c1aba37ebcb3ab2883 (patch)
tree4490aa4f0185a53cb7b7ebdf682ff099ed03a861 /math/ruby-gnuplot/Makefile
parent4c98e3a5d150a579640223ee21be85c70e005b9c (diff)
Notes
Diffstat (limited to 'math/ruby-gnuplot/Makefile')
-rw-r--r--math/ruby-gnuplot/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/math/ruby-gnuplot/Makefile b/math/ruby-gnuplot/Makefile
index 35a717918c0c..e025d6639e66 100644
--- a/math/ruby-gnuplot/Makefile
+++ b/math/ruby-gnuplot/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnuplot
-PORTVERSION= 0.3
+PORTVERSION= 0.4
CATEGORIES= math ruby
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= r${PORTNAME}
@@ -25,21 +25,24 @@ RUBY_SHEBANG_FILES= ${WRKSRC}/*.rb
NO_BUILD= yes
-WRKSRC= ${WRKDIR}/r${PORTNAME}
+WRKSRC= ${WRKDIR}/gplot
post-patch:
${RUBY} -i.orig -p \
- -e 'gsub %r:/usr/bin/gnuplot:, "${LOCALBASE}/bin/gnuplot"' \
- ${WRKSRC}/*.rb
+ -e 'gsub %r:#!/bin/env:, "#!/usr/bin/env"' \
+ ${WRKSRC}/Gnuplot.rb
+ ${RUBY} -i.orig -p \
+ -e 'gsub %r:gplot/Gnuplot:, "Gnuplot"' \
+ ${WRKSRC}/demo.rb
do-install:
${MKDIR} ${RUBY_SITELIBDIR}/gplot
- ${INSTALL_DATA} ${WRKSRC}/[A-Z]*.rb ${RUBY_SITELIBDIR}/gplot/
+ ${INSTALL_DATA} ${WRKSRC}/Gnuplot.rb ${RUBY_SITELIBDIR}/gplot/
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/demo.rb ${RUBY_MODEXAMPLESDIR}/
${MKDIR} ${RUBY_MODDOCDIR}
-.for f in README TODO
+.for f in README
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
.endfor
.endif