aboutsummaryrefslogtreecommitdiff
path: root/math/ruby-gnuplot
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-02-01 16:18:07 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-02-01 16:18:07 +0000
commit373bbb0312a37f219b6980b18b4b10becd6870d8 (patch)
tree196898d684be19ce4bfe9cfe54d6151abba4da27 /math/ruby-gnuplot
parent4c9b8c2d215a8bdf45f44b8a192c17440716e978 (diff)
downloadports-373bbb0312a37f219b6980b18b4b10becd6870d8.tar.gz
ports-373bbb0312a37f219b6980b18b4b10becd6870d8.zip
Notes
Diffstat (limited to 'math/ruby-gnuplot')
-rw-r--r--math/ruby-gnuplot/Makefile41
-rw-r--r--math/ruby-gnuplot/distinfo1
-rw-r--r--math/ruby-gnuplot/pkg-comment1
-rw-r--r--math/ruby-gnuplot/pkg-descr24
-rw-r--r--math/ruby-gnuplot/pkg-plist7
5 files changed, 74 insertions, 0 deletions
diff --git a/math/ruby-gnuplot/Makefile b/math/ruby-gnuplot/Makefile
new file mode 100644
index 000000000000..fc886dcbbf21
--- /dev/null
+++ b/math/ruby-gnuplot/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: Ruby/Gnuplot
+# Date created: 1 Feb 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnuplot
+PORTVERSION= 0
+CATEGORIES= math ruby
+MASTER_SITES= http://physci.gmu.edu/~gmiller/gnuplot/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/bin/gnuplot:${PORTSDIR}/math/gnuplot \
+ ${RUBY_SITEARCHLIBDIR}/narray.so:${PORTSDIR}/math/ruby-narray
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/gplot
+
+post-patch:
+ ${RUBY} -i.orig -p \
+ -e 'gsub %r:/bin/env:, "/usr/bin/env"' \
+ -e 'gsub %r:/usr/bin/gnuplot:, "${LOCALBASE}/bin/gnuplot"' \
+ ${WRKSRC}/*.rb
+
+do-install:
+ ${MKDIR} ${RUBY_SITELIBDIR}/gplot
+ ${INSTALL_DATA} ${WRKSRC}/*.rb ${RUBY_SITELIBDIR}/gplot/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_DOCDIR}/gnuplot
+ ${INSTALL_DATA} ${WRKSRC}/README ${RUBY_DOCDIR}/gnuplot/
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/ruby-gnuplot/distinfo b/math/ruby-gnuplot/distinfo
new file mode 100644
index 000000000000..138da794a773
--- /dev/null
+++ b/math/ruby-gnuplot/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/gnuplot.tar.gz) = 116aee9fa199a944fe7794856a329fa1
diff --git a/math/ruby-gnuplot/pkg-comment b/math/ruby-gnuplot/pkg-comment
new file mode 100644
index 000000000000..7bebed0801c4
--- /dev/null
+++ b/math/ruby-gnuplot/pkg-comment
@@ -0,0 +1 @@
+A pipe-based interface to the gnuplot package for Ruby
diff --git a/math/ruby-gnuplot/pkg-descr b/math/ruby-gnuplot/pkg-descr
new file mode 100644
index 000000000000..7a18448c9478
--- /dev/null
+++ b/math/ruby-gnuplot/pkg-descr
@@ -0,0 +1,24 @@
+Ruby/Gnuplot is a pipe-based interface to the gnuplot package.
+Provides the full capabilities of the gnuplot package to Ruby
+programs. Inspired by the Python Gnuplot package that works on the
+same principle. Here's an example usage of Ruby/Gnuplot:
+
+ require 'narray'
+ require 'gplot/Gnuplot'
+
+ x = NArray.sfloat(100).indgen!
+ y = x.collect { |i| i*i }
+
+ plot = Plot.new ()
+
+ plot.setTitle ("Demo 1");
+ plot.setXlabel ("X");
+ plot.setYlabel ("X^2");
+
+ ds = DataSet.new (y, {"with"=> "lines", "title"=>"Data"})
+ ds.setGrid (x)
+
+ plot.draw ( ds )
+
+Author: Gordon Miller <gmiller@bittwiddlers.com>
+WWW: http://physci.gmu.edu/~gmiller/gnuplot/
diff --git a/math/ruby-gnuplot/pkg-plist b/math/ruby-gnuplot/pkg-plist
new file mode 100644
index 000000000000..f6c9341541c6
--- /dev/null
+++ b/math/ruby-gnuplot/pkg-plist
@@ -0,0 +1,7 @@
+%%RUBY_SITELIBDIR%%/gplot/Gnuplot.rb
+%%RUBY_SITELIBDIR%%/gplot/Plot.rb
+%%RUBY_SITELIBDIR%%/gplot/PlotItem.rb
+%%RUBY_SITELIBDIR%%/gplot/Stream.rb
+@dirrm %%RUBY_SITELIBDIR%%/gplot
+%%RUBY_DOCDIR%%/gnuplot/README
+@dirrm %%RUBY_DOCDIR%%/gnuplot