aboutsummaryrefslogtreecommitdiff
path: root/math/ruby-narray/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-02-01 13:25:14 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-02-01 13:25:14 +0000
commit9f96169d68ea1c014128be801b6b15e2454af5c1 (patch)
tree587e4364dc810a1bda40558d61d3826e99d0b69d /math/ruby-narray/Makefile
parentbe5f6df8ca9fd3c2ff2652ecead44ba619f7b0e2 (diff)
downloadports-9f96169d68ea1c014128be801b6b15e2454af5c1.tar.gz
ports-9f96169d68ea1c014128be801b6b15e2454af5c1.zip
Notes
Diffstat (limited to 'math/ruby-narray/Makefile')
-rw-r--r--math/ruby-narray/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/math/ruby-narray/Makefile b/math/ruby-narray/Makefile
new file mode 100644
index 000000000000..b6ea54b5ae0d
--- /dev/null
+++ b/math/ruby-narray/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: Ruby-NArray
+# Date created: 1 Feb 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= narray
+PORTVERSION= 0.5.2
+CATEGORIES= math ruby
+MASTER_SITES= http://www.ir.isas.ac.jp/~masa/ruby/dist/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+LIB_DEPENDS= fftw.2:${PORTSDIR}/math/fftw
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+DOC_EN= ChangeLog README.en SPEC.en
+DOC_JA= README.jp SPEC.jp
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_DOCDIR}/narray/ja
+.for f in ${DOC_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/narray/
+.endfor
+.for f in ${DOC_JA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/narray/ja/
+.endfor
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/narray
+ ${INSTALL_DATA} ${WRKSRC}/speed/*.rb ${RUBY_EXAMPLESDIR}/narray/
+.endif
+
+.include <bsd.port.mk>