aboutsummaryrefslogtreecommitdiff
path: root/math/rubygem-narray
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2014-03-25 20:20:23 +0000
committerSteve Wills <swills@FreeBSD.org>2014-03-25 20:20:23 +0000
commite3f2dc403e1f2ed61e27a9e99291979b51707fa1 (patch)
tree13cd5bff1b4df1183a9557b2abf5a67dd56b1555 /math/rubygem-narray
parentfe24f9418861f9c682414807079eadaae3fe9fff (diff)
NArray is an Numerical N-dimensional Array class. Supported element types are
1/2/4-byte Integer, single/double-precision Real/Complex, and Ruby Object. This extension library incorporates fast calculation and easy manipulation of large numerical arrays into the Ruby language. NArray has features similar to NumPy, but NArray has vector and matrix subclasses. WWW: http://narray.rubyforge.org/ PR: ports/187917 Submitted by: Shin-ya MURAKAMI <murashin@gfd-dennou.org>
Notes
Notes: svn path=/head/; revision=349189
Diffstat (limited to 'math/rubygem-narray')
-rw-r--r--math/rubygem-narray/Makefile17
-rw-r--r--math/rubygem-narray/distinfo2
-rw-r--r--math/rubygem-narray/pkg-descr7
3 files changed, 26 insertions, 0 deletions
diff --git a/math/rubygem-narray/Makefile b/math/rubygem-narray/Makefile
new file mode 100644
index 000000000000..3c8616ea0913
--- /dev/null
+++ b/math/rubygem-narray/Makefile
@@ -0,0 +1,17 @@
+# Created by: Shin-ya MURAKAMI <murashin@gfd-dennou.org>
+# $FreeBSD$
+
+PORTNAME= narray
+PORTVERSION= 0.6.0.8
+CATEGORIES= math rubygems
+MASTER_SITES= RG
+
+MAINTAINER= murashin@gfd-dennou.org
+COMMENT= Numerical N-dimensional array library for Ruby
+
+USE_RUBY= yes
+USE_RAKE= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/math/rubygem-narray/distinfo b/math/rubygem-narray/distinfo
new file mode 100644
index 000000000000..3ebf801c31f2
--- /dev/null
+++ b/math/rubygem-narray/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/narray-0.6.0.8.gem) = 6ebe71c6047b2058fd456041ce29ba4bcc91615bfa8a87b0c4f60cdd82a7275d
+SIZE (rubygem/narray-0.6.0.8.gem) = 65024
diff --git a/math/rubygem-narray/pkg-descr b/math/rubygem-narray/pkg-descr
new file mode 100644
index 000000000000..43a6192266dc
--- /dev/null
+++ b/math/rubygem-narray/pkg-descr
@@ -0,0 +1,7 @@
+NArray is an Numerical N-dimensional Array class. Supported element types are
+1/2/4-byte Integer, single/double-precision Real/Complex, and Ruby Object. This
+extension library incorporates fast calculation and easy manipulation of large
+numerical arrays into the Ruby language. NArray has features similar to NumPy,
+but NArray has vector and matrix subclasses.
+
+WWW: http://narray.rubyforge.org/