aboutsummaryrefslogtreecommitdiff
path: root/math/saga/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-11-17 09:12:08 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-11-17 09:12:08 +0000
commit436b3fc51827a83b6d3d0e1643f28979bad00727 (patch)
tree4e7b782b58a2dea1213b85b84597fe6e47c0b9e3 /math/saga/Makefile
parentcaa2a4d515ad580de8fe9e7a4da95e839f021b07 (diff)
downloadports-436b3fc51827a83b6d3d0e1643f28979bad00727.tar.gz
ports-436b3fc51827a83b6d3d0e1643f28979bad00727.zip
Notes
Diffstat (limited to 'math/saga/Makefile')
-rw-r--r--math/saga/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/math/saga/Makefile b/math/saga/Makefile
new file mode 100644
index 000000000000..6cf4980efd5b
--- /dev/null
+++ b/math/saga/Makefile
@@ -0,0 +1,42 @@
+# Ports collection makefile for: saga
+# Date created: 13 November 2009
+# Whom: rhurlin
+#
+# $FreeBSD$
+#
+
+PORTNAME= saga
+PORTVERSION= 2.0.4
+CATEGORIES= math
+MASTER_SITES= SF/saga-gis/SAGA%20-%20${PORTVERSION:C/\.[[:digit:]]*$//}/SAGA%20${PORTVERSION}
+DISTNAME= ${PORTNAME}_${PORTVERSION}_src_linux
+
+MAINTAINER= rhurlin@gwdg.de
+COMMENT= System for Automated Geoscientific Analyses
+
+LIB_DEPENDS= proj.5:${PORTSDIR}/graphics/proj \
+ gdal.14:${PORTSDIR}/graphics/gdal \
+ jasper.4:${PORTSDIR}/graphics/jasper \
+ tiff.4:${PORTSDIR}/graphics/tiff
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-2.0
+
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CFLAGS+= -I${LOCALBASE}/include
+
+USE_WX= 2.8
+
+post-patch:
+ @for f in `${FIND} '${WRKSRC}' -name Makefile.in` \
+ ${WRKSRC}/configure; do \
+ ${REINPLACE_CMD} -e's|wx-config |${WX_CONFIG} |g' "$$f"; \
+ done
+ @${REINPLACE_CMD} -e 's,malloc.h,stdlib.h,' \
+ ${WRKSRC}/src/saga_core/saga_api/api_memory.cpp \
+ ${WRKSRC}/src/modules_projection/pj_georeference/pj_georeference/lmdif0.c
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>