aboutsummaryrefslogtreecommitdiff
path: root/math/sage
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2013-05-02 03:15:15 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2013-05-02 03:15:15 +0000
commit9341cd15fced9bd0c6d1bee12e366d644610116f (patch)
tree0c3ed030628b81f0386fc2f55986496d7d8b79d8 /math/sage
parentf2ec55247e20aa68e7d9e1a25f43779e8d9f4897 (diff)
- Update to 5.9.
Notes
Notes: svn path=/head/; revision=317071
Diffstat (limited to 'math/sage')
-rw-r--r--math/sage/Makefile5
-rw-r--r--math/sage/distinfo4
-rw-r--r--math/sage/files/spkg-patch-cephes_-_spkg-install11
-rw-r--r--math/sage/files/spkg-patch-eclib_-_src_libsrc_eclib_interface.h10
-rw-r--r--math/sage/files/spkg-patch-python_-_src_Doc_library_fcntl.rst2
-rw-r--r--math/sage/files/spkg-patch-python_-_src_Modules__ctypes_libffi_configure2
-rw-r--r--math/sage/files/spkg-patch-python_-_src_Modules_fcntlmodule.c2
-rw-r--r--math/sage/files/spkg-patch-python_-_src_Python_thread_pthread.h2
-rw-r--r--math/sage/files/spkg-patch-python_-_src_setup.py87
-rw-r--r--math/sage/files/spkg-patch-sage_-_doc_common_builder.py2
-rw-r--r--math/sage/files/spkg-patch-sage_-_sage_misc_getusage.py40
11 files changed, 113 insertions, 54 deletions
diff --git a/math/sage/Makefile b/math/sage/Makefile
index aba23670b4ae..9b4f6c2e1212 100644
--- a/math/sage/Makefile
+++ b/math/sage/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= sage
-PORTVERSION= 5.8
+PORTVERSION= 5.9
CATEGORIES= math
MASTER_SITES= http://boxen.math.washington.edu/home/sagemath/sage-mirror/src/ \
http://mirrors.xmission.com/sage/src/ \
@@ -30,9 +30,10 @@ OPTIONS_DEFINE_amd64= 387
PLIST_FILES= bin/sage
USE_FORTRAN= yes
+USE_GCC= 4.7+
USE_TK= yes
USE_GMAKE= yes
-USES= iconv
+USE_ICONV= yes
MAKE_JOBS_SAFE= yes
LDFLAGS:= -Wl,-rpath=${WRKSRC}/local/lib ${LDFLAGS}
FFLAGS+= -Wl,-rpath=${WRKSRC}/local/lib ${FPM_FLAG}
diff --git a/math/sage/distinfo b/math/sage/distinfo
index 136596db9378..57a37d1dc2a2 100644
--- a/math/sage/distinfo
+++ b/math/sage/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sage-5.8.tar) = 4c34f4533a518e0ef8b34b2ed51443beae57e00d2f9ef31fa2811338610619ba
-SIZE (sage-5.8.tar) = 329318400
+SHA256 (sage-5.9.tar) = 56fdb8272b49eb8bed4e3068416ff2ba6cb95bcd4abea82c5fb639f7c7cfea20
+SIZE (sage-5.9.tar) = 328867840
diff --git a/math/sage/files/spkg-patch-cephes_-_spkg-install b/math/sage/files/spkg-patch-cephes_-_spkg-install
new file mode 100644
index 000000000000..237c4ce412cc
--- /dev/null
+++ b/math/sage/files/spkg-patch-cephes_-_spkg-install
@@ -0,0 +1,11 @@
+--- cephes-2.8.p1/spkg-install-orig 2013-03-30 20:48:35.000000000 +0000
++++ cephes-2.8.p1/spkg-install 2013-03-30 20:48:57.000000000 +0000
+@@ -24,6 +24,8 @@
+ fi
+ done
+
++sed -i .orig 's|.*printf|//&1|' */mtherr.c
++
+ echo "Building Cephes..."
+ $MAKE
+ if [ $? -ne 0 ]; then
diff --git a/math/sage/files/spkg-patch-eclib_-_src_libsrc_eclib_interface.h b/math/sage/files/spkg-patch-eclib_-_src_libsrc_eclib_interface.h
new file mode 100644
index 000000000000..bd8b9851170d
--- /dev/null
+++ b/math/sage/files/spkg-patch-eclib_-_src_libsrc_eclib_interface.h
@@ -0,0 +1,10 @@
+--- eclib-20120830/src/libsrc/eclib/interface.h-orig 2013-04-26 23:46:24.000000000 +0000
++++ eclib-20120830/src/libsrc/eclib/interface.h 2013-04-26 23:47:09.000000000 +0000
+@@ -48,6 +48,7 @@
+ #include <iterator>
+ using namespace std;
+ #include "templates.h"
++#include <stdint.h>
+
+ #ifndef MININT
+ #define MININT numeric_limits<int>::min()
diff --git a/math/sage/files/spkg-patch-python_-_src_Doc_library_fcntl.rst b/math/sage/files/spkg-patch-python_-_src_Doc_library_fcntl.rst
index 5c7f4bd46a5f..772ab39a43f3 100644
--- a/math/sage/files/spkg-patch-python_-_src_Doc_library_fcntl.rst
+++ b/math/sage/files/spkg-patch-python_-_src_Doc_library_fcntl.rst
@@ -1,5 +1,5 @@
--- python-2.7.3.p0/src/Doc/library/fcntl.rst.orig 2011-06-11 15:46:23.000000000 +0000
-+++ python-2.7.3.p5/src/Doc/library/fcntl.rst 2012-04-22 00:31:48.000000000 +0000
++++ python-2.7.3.p6/src/Doc/library/fcntl.rst 2012-04-22 00:31:48.000000000 +0000
@@ -50,8 +50,6 @@
operations are typically defined in the library module :mod:`termios` and the
argument handling is even more complicated.
diff --git a/math/sage/files/spkg-patch-python_-_src_Modules__ctypes_libffi_configure b/math/sage/files/spkg-patch-python_-_src_Modules__ctypes_libffi_configure
index cca0cfeeae09..9f66c07267d6 100644
--- a/math/sage/files/spkg-patch-python_-_src_Modules__ctypes_libffi_configure
+++ b/math/sage/files/spkg-patch-python_-_src_Modules__ctypes_libffi_configure
@@ -1,5 +1,5 @@
--- python-2.7.3.p0/src/Modules/_ctypes/libffi/configure.orig 2011-06-11 15:46:26.000000000 +0000
-+++ python-2.7.3.p5/src/Modules/_ctypes/libffi/configure 2012-04-22 00:23:14.000000000 +0000
++++ python-2.7.3.p6/src/Modules/_ctypes/libffi/configure 2012-04-22 00:23:14.000000000 +0000
@@ -6289,7 +6289,7 @@
rm -rf conftest*
;;
diff --git a/math/sage/files/spkg-patch-python_-_src_Modules_fcntlmodule.c b/math/sage/files/spkg-patch-python_-_src_Modules_fcntlmodule.c
index 5b1646f3b981..c728c311f844 100644
--- a/math/sage/files/spkg-patch-python_-_src_Modules_fcntlmodule.c
+++ b/math/sage/files/spkg-patch-python_-_src_Modules_fcntlmodule.c
@@ -1,5 +1,5 @@
--- python-2.7.3.p0/src/Modules/fcntlmodule.c.orig 2011-06-11 15:46:27.000000000 +0000
-+++ python-2.7.3.p5/src/Modules/fcntlmodule.c 2012-04-22 00:23:34.000000000 +0000
++++ python-2.7.3.p6/src/Modules/fcntlmodule.c 2012-04-22 00:23:34.000000000 +0000
@@ -97,20 +97,15 @@
{
#define IOCTL_BUFSZ 1024
diff --git a/math/sage/files/spkg-patch-python_-_src_Python_thread_pthread.h b/math/sage/files/spkg-patch-python_-_src_Python_thread_pthread.h
index 2b30d7a97085..238ac77a553a 100644
--- a/math/sage/files/spkg-patch-python_-_src_Python_thread_pthread.h
+++ b/math/sage/files/spkg-patch-python_-_src_Python_thread_pthread.h
@@ -1,5 +1,5 @@
--- python-2.7.3.p0/src/Python/thread_pthread.h.orig 2011-06-11 15:46:28.000000000 +0000
-+++ python-2.7.3.p5/src/Python/thread_pthread.h 2012-04-22 00:23:46.000000000 +0000
++++ python-2.7.3.p6/src/Python/thread_pthread.h 2012-04-22 00:23:46.000000000 +0000
@@ -38,13 +38,18 @@
#endif
#endif
diff --git a/math/sage/files/spkg-patch-python_-_src_setup.py b/math/sage/files/spkg-patch-python_-_src_setup.py
index 7f1f682d4c4f..74ff58606be9 100644
--- a/math/sage/files/spkg-patch-python_-_src_setup.py
+++ b/math/sage/files/spkg-patch-python_-_src_setup.py
@@ -1,6 +1,65 @@
---- python-2.7.3.p0/src/setup.py-orig 2012-04-22 00:04:08.000000000 +0000
-+++ python-2.7.3.p5/src/setup.py 2012-04-22 00:10:25.000000000 +0000
-@@ -1432,10 +1432,24 @@
+--- python-2.7.3.p6/src/setup.py-orig 2013-03-17 03:13:46.000000000 +0000
++++ python-2.7.3.p6/src/setup.py 2013-03-17 03:15:11.000000000 +0000
+@@ -642,7 +642,7 @@
+ # use the same library for the readline and curses modules.
+ if 'curses' in readline_termcap_library:
+ curses_library = readline_termcap_library
+- elif self.compiler.find_library_file(lib_dirs, 'ncursesw'):
++ elif self.compiler.find_library_file(lib_dirs, 'xxxncursesw'):
+ curses_library = 'ncursesw'
+ elif self.compiler.find_library_file(lib_dirs, 'ncurses'):
+ curses_library = 'ncurses'
+@@ -681,7 +681,7 @@
+ 'termcap'):
+ readline_libs.append('termcap')
+ exts.append( Extension('readline', ['readline.c'],
+- library_dirs=['/usr/lib/termcap'],
++ library_dirs=['/usr/lib', '/usr/lib/termcap'],
+ extra_link_args=readline_extra_link_args,
+ libraries=readline_libs) )
+ else:
+@@ -783,6 +783,8 @@
+ # OpenSSL doesn't do these until 0.9.8 so we'll bring our own hash
+ exts.append( Extension('_sha256', ['sha256module.c']) )
+ exts.append( Extension('_sha512', ['sha512module.c']) )
++ else:
++ open('.without_own_sha', 'w')
+
+ # Modules that provide persistent dictionary-like semantics. You will
+ # probably want to arrange for at least one of them to be available on
+@@ -1120,7 +1122,7 @@
+ sysroot = macosx_sdk_root()
+ f = os.path.join(sysroot, f[1:])
+
+- if os.path.exists(f) and not db_incs:
++ if os.path.exists(f):
+ data = open(f).read()
+ m = re.search(r"#s*define\s+HASHVERSION\s+2\s*", data)
+ if m is not None:
+@@ -1246,12 +1248,13 @@
+ # provided by the ncurses library.
+ panel_library = 'panel'
+ if curses_library.startswith('ncurses'):
+- if curses_library == 'ncursesw':
++ if curses_library == 'xxxncursesw':
+ # Bug 1464056: If _curses.so links with ncursesw,
+ # _curses_panel.so must link with panelw.
+ panel_library = 'panelw'
+ curses_libs = [curses_library]
+ exts.append( Extension('_curses', ['_cursesmodule.c'],
++ library_dirs = ['/usr/lib'],
+ libraries = curses_libs) )
+ elif curses_library == 'curses' and platform != 'darwin':
+ # OSX has an old Berkeley curses, not good enough for
+@@ -1264,6 +1267,7 @@
+ curses_libs = ['curses']
+
+ exts.append( Extension('_curses', ['_cursesmodule.c'],
++ library_dirs = ['/usr/lib'],
+ libraries = curses_libs) )
+ else:
+ missing.append('_curses')
+@@ -1432,10 +1436,22 @@
macros = dict()
libraries = []
@@ -17,8 +76,6 @@
+ libraries = []
+
+ elif platform in ('freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'):
-+ # FreeBSD's P1003.1b semaphore support is very experimental
-+ # and has many known problems. (as of June 2008)
+ macros = dict( # FreeBSD 7+
+ HAVE_SEM_OPEN=1,
+ HAVE_SEM_TIMEDWAIT=1,
@@ -27,3 +84,23 @@
libraries = []
elif platform.startswith('openbsd'):
+@@ -1484,7 +1500,7 @@
+ missing.append('linuxaudiodev')
+
+ if (platform in ('linux2', 'freebsd4', 'freebsd5', 'freebsd6',
+- 'freebsd7', 'freebsd8')
++ 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10')
+ or platform.startswith("gnukfreebsd")):
+ exts.append( Extension('ossaudiodev', ['ossaudiodev.c']) )
+ else:
+@@ -2066,9 +2082,7 @@
+ ext_modules=[Extension('_struct', ['_struct.c'])],
+
+ # Scripts to install
+- scripts = ['Tools/scripts/pydoc', 'Tools/scripts/idle',
+- 'Tools/scripts/2to3',
+- 'Lib/smtpd.py']
++ scripts = []
+ )
+
+ # --install-platlib
diff --git a/math/sage/files/spkg-patch-sage_-_doc_common_builder.py b/math/sage/files/spkg-patch-sage_-_doc_common_builder.py
index 84659a7dc304..bfef917f3b53 100644
--- a/math/sage/files/spkg-patch-sage_-_doc_common_builder.py
+++ b/math/sage/files/spkg-patch-sage_-_doc_common_builder.py
@@ -1,5 +1,5 @@
--- sage-5.8.rc0/doc/common/builder.py-orig 2013-03-17 20:50:38.000000000 +0000
-+++ sage-5.8/doc/common/builder.py 2013-03-17 20:56:42.000000000 +0000
++++ sage-5.9/doc/common/builder.py 2013-03-17 20:56:42.000000000 +0000
@@ -272,13 +272,16 @@
# build the other documents in parallel
diff --git a/math/sage/files/spkg-patch-sage_-_sage_misc_getusage.py b/math/sage/files/spkg-patch-sage_-_sage_misc_getusage.py
deleted file mode 100644
index 7c0be074b4d4..000000000000
--- a/math/sage/files/spkg-patch-sage_-_sage_misc_getusage.py
+++ /dev/null
@@ -1,40 +0,0 @@
---- sage-5.7.beta4/sage/misc/getusage.py-old 2013-02-09 23:05:24.000000000 +0000
-+++ sage-5.8/sage/misc/getusage.py 2013-02-09 23:09:50.000000000 +0000
-@@ -20,6 +20,8 @@
- """
- Return the 'top' or 'prstat' line that contains this running Sage
- process.
-+ For FreeBSD, return the line containing this running Sage process from
-+ 'ps -axwww -o pid,user,vsz,rss,state,pri,nice,time,cpu,comm'.
-
- OUTPUT:
-
-@@ -55,6 +57,8 @@
- cmd = '/usr/bin/prstat -n 100000 1 1 | grep "^ *%s "' % pid
- elif U[:6] == 'cygwin':
- cmd = 'top -b -n 1 -p %s' % pid
-+ elif U == 'freebsd':
-+ cmd = 'ps -axwww -o pid,user,vsz,rss,state,pri,nice,time,cpu,comm | grep "^ *%s "' % pid
- else:
- raise NotImplementedError("top not implemented on platform %s" % U)
-
-@@ -85,6 +89,9 @@
- usage, ``prstat`` will output the data in KB, MB or GB. In each
- case, the value returned by this function will always be in MB.
-
-+ - ``FreeBSD`` - Returns float number (in megabytes) that matches
-+ RSS column of ``ps -auxwww``
-+
- - ``other`` - not implemented for any other operating systems
-
- EXAMPLES::
-@@ -131,6 +138,9 @@
- m = float(memory_in_KB_MB_or_GB.strip("M"))
- elif memory_in_KB_MB_or_GB.endswith("G"):
- m = float(memory_in_KB_MB_or_GB.strip("G")) * 1024
-+ elif U == 'freebsd':
-+ memory_in_KB = top().split()[3]
-+ m = float(memory_in_KB) / 1024
- else:
- raise NotImplementedError("memory usage not implemented on platform %s" % U)
-